Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 11-25-2005, 12:12 AM   #1
Registered: Apr 2002
Location: Chicago, IL
Distribution: Mandriva 2009.0 PowerPack x86_64
Posts: 150

Rep: Reputation: 15
How do I connect to Webmin remotely?

I have Mandriva 2006, I can access webmin locally using https://localhost:10000 and even by https://server01:10000. However, if I try connecting from any other computer I get "The operation timed out when attempting to contact server01". I can get to http://server01 and https://server01 remotely just fine. I liked at webmin settings, it is set to allow all IPs, I do have shorewall, so I checked it, and it had 80, and a few other ports that it accepted, but it did not have 10000 so I added 10000 to the list but I still get the same error when accessing webmin remotely. What could possibly be stopping it? Can someone help me figure this out?

Old 11-25-2005, 03:11 AM   #2
Registered: Oct 2004
Location: Germany
Distribution: Debian
Posts: 274

Rep: Reputation: 34
The most secure way is using
ssh -L 10001:localhost:10000 youruserhere@server01

this will open an ssh connection to server01 using username yourusername.
after you logged in, your local port 10001 is forwared through the ssh connection to server01 (localhost on the other end...) port 10000.

now you can open your browser and type https://localhost:10001
for server01 this will look like you connect from localhost to port 10000.
Old 08-25-2010, 07:56 PM   #3
LQ Newbie
Registered: Aug 2010
Posts: 1

Rep: Reputation: 0
I just wanted to follow up because I had a similar problem and this thread was the only thing on google related to this issue (sorry for the late response). It turns out that my Linux Firewall was blocking port 10000 so I added an exception. You can do this in the "Networking" section of the far right menu and then clicking on "linux firewall." If it says something like "allow port 22" and under that "always reject" then you can't http into port 10000. By ssh-ing in you circumvent this firewall, but that is not ideal if you're maintaining a cluster of 20 computers like I am! All my computers are behind my VPN so I just disabled the firewall entirely. If you want Im sure you can figure out how to add an exception. I hope that helps someone!
Old 11-18-2010, 05:03 AM   #4
LQ Newbie
Registered: Nov 2010
Posts: 1

Rep: Reputation: 0
Hi dustinechos,

I've got the same problem so I'm going to have to disable my firewall as well, but if you've figured out how to add an exception I'd be really grateful if you could share it with me?

Many thanks!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't remotely ftp connect jake3988 *BSD 10 04-16-2005 01:52 PM
Remotely connecting to Webmin running on Debian enigma101 Linux - Software 2 01-24-2005 09:55 PM
connect remotely pyre Linux - Newbie 8 03-19-2004 12:20 PM
Help: Unable to connect remotely tejpatil Linux - Newbie 3 02-14-2004 09:36 PM
cannot connect remotely noizez Linux - Networking 2 04-03-2003 10:53 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:04 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration