LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-27-2006, 03:10 AM   #1
onyangoliech
Member
 
Registered: May 2003
Location: Kenya
Posts: 45

Rep: Reputation: 15
File Too Large in postfix


I got the following error message after sending mail to a recipient in the mail address shown, any ideas what the problem is?


This is the Postfix program at host mail.dpm.go.ke.

I'm sorry to have to inform you that the message returned
below could not be delivered to one or more destinations.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the message returned below.

The Postfix program

<onyangoliech@dpm.go.ke>: cannot access mailbox /var/mail/onyangoliech for user
onyangoliech. error writing message: File too large
 
Old 10-27-2006, 08:29 PM   #2
WindowBreaker
Member
 
Registered: Oct 2005
Distribution: Slackware
Posts: 228

Rep: Reputation: 40
Quote:
Originally Posted by onyangoliech
<onyangoliech@dpm.go.ke>: cannot access mailbox /var/mail/onyangoliech for user
onyangoliech. error writing message: File too large
They are using virtual_mailbox_domains to deliver emails to mailboxes for which no UNIX system account exists.

There are a few possibilities here.
First (and most likely), the size of the mailbox named onyangoliech is larger than the "virtual_mailbox_limit" parameter. I'll quote the man pager here to describe this parameter:
Quote:
The maximal size in bytes of an individual mailbox or maildir file, or zero (no limit).
Quoted from HERE in case you'd like to take a look for yourself.

This is the most likely cause of your problem.
To see what that parameter is currently set to, do the following as root
Code:
postconf virtual_mailbox_limit
To make it unlimited, run the following command as root
Code:
postconf -e "virtual_mailbox_limit = 0"
Then you need to refresh Postfix with
Code:
postfix reload
Another possibility is that the partition where /var/mail/onyangoliech is mounted is full. You can check this with the following command
Code:
df -h
In my opinion this is less likely, because unless onyangoliech has his/her own partition, others would likely complain of the same issue.

Let us know how it turns out.

Cheers

Last edited by WindowBreaker; 10-27-2006 at 08:30 PM.
 
Old 10-29-2006, 11:58 PM   #3
onyangoliech
Member
 
Registered: May 2003
Location: Kenya
Posts: 45

Original Poster
Rep: Reputation: 15
Thanks all, I added mailbox_size_limit=0 and it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Large DUMP file. mojoman Linux - General 1 09-06-2006 03:27 AM
Large file with c program exvor Programming 4 12-30-2005 09:54 AM
file is too large to edit ukrainet Linux - Newbie 4 02-28-2005 07:46 AM
File does not exist/Large file support dreamtheater Linux - General 3 04-19-2004 09:14 AM
Large tar file taking huge disk space in ext3 file system pcwulf Linux - General 2 10-20-2003 07:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration