LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   File Too Large in postfix (https://www.linuxquestions.org/questions/linux-networking-3/file-too-large-in-postfix-495988/)

onyangoliech 10-27-2006 04:10 AM

File Too Large in postfix
 
I got the following error message after sending mail to a recipient in the mail address shown, any ideas what the problem is?


This is the Postfix program at host mail.dpm.go.ke.

I'm sorry to have to inform you that the message returned
below could not be delivered to one or more destinations.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the message returned below.

The Postfix program

<onyangoliech@dpm.go.ke>: cannot access mailbox /var/mail/onyangoliech for user
onyangoliech. error writing message: File too large

WindowBreaker 10-27-2006 09:29 PM

Quote:

Originally Posted by onyangoliech
<onyangoliech@dpm.go.ke>: cannot access mailbox /var/mail/onyangoliech for user
onyangoliech. error writing message: File too large

They are using virtual_mailbox_domains to deliver emails to mailboxes for which no UNIX system account exists.

There are a few possibilities here.
First (and most likely), the size of the mailbox named onyangoliech is larger than the "virtual_mailbox_limit" parameter. I'll quote the man pager here to describe this parameter:
Quote:

The maximal size in bytes of an individual mailbox or maildir file, or zero (no limit).
Quoted from HERE in case you'd like to take a look for yourself.

This is the most likely cause of your problem.
To see what that parameter is currently set to, do the following as root
Code:

postconf virtual_mailbox_limit
To make it unlimited, run the following command as root
Code:

postconf -e "virtual_mailbox_limit = 0"
Then you need to refresh Postfix with
Code:

postfix reload
Another possibility is that the partition where /var/mail/onyangoliech is mounted is full. You can check this with the following command
Code:

df -h
In my opinion this is less likely, because unless onyangoliech has his/her own partition, others would likely complain of the same issue.

Let us know how it turns out.

Cheers

onyangoliech 10-30-2006 12:58 AM

Thanks all, I added mailbox_size_limit=0 and it worked.


All times are GMT -5. The time now is 02:32 PM.