LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-30-2003, 07:53 PM   #46
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45

No, you must call me "beavis" or "butthead", lol,

Can you outline briefly what you did when you say you were "able to successfully recompile the acx100 driver"? Did you use cvs to download the latest (0.2.0pre2) version and compile it? Did you move the compiled module (acx100_pci.o) to a location somewhere under you /lib/modules/`uname -r`/ directory tree? Did you run depmod -a after that? Is there an "options acx100_pci..." line in you /etc/modules.conf with the proper var set describing the location of the firmware? Does ifconfig show the correct MAC address for the card?
 
Old 09-30-2003, 10:33 PM   #47
highartboi
LQ Newbie
 
Registered: Sep 2003
Location: California
Distribution: Red Hat 9
Posts: 14

Rep: Reputation: 0
HI Beavis, I used CVS to download the lates acx100 driver. I compiled under directory /usr/acx100. But I didn't copy it to /lib/modules/2.4.20-20.9 I didn't do any depmod -a, There is no options acx100_pci... in /etc/modules.conf. Here is the /etc/modules.conf:

[root@chris 2.4.20-20.9]# more /etc/modules.conf
alias eth0 e100
alias usb-controller usb-uhci
alias ieee1394-controller ohci1394
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

I'm not sure how to add the acx100_pci option. Please shine some light.

This is what my start_net script looks like:
DEV=wlan0
IP=192.168.0.200
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
ESSID=House # any == associate to any ESSID
# Default rate configured as 11Mbps to not cause connection problems with non-22Mbps hardware...
RATE=11M
CHAN=6
#TXPOWER=16 # 16 == 16.5dBm, 18 == 18dBm (default)
MODE=Managed
DEBUG=0xb
#KEY=B401CD21B44CCD21DEADBEEF11 # WEP128
ALG=open # open == Open System, restricted == Shared Key

after i start start_net, this is the output of ifconfig -a:
wlan0 Link encap:Ethernet HWaddr 00:40:05:5A:A8:21
inet addr:192.168.0.200 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:576 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:3 Base address:0x4400

the MAC address of the pcmcia card is correct.
this is the output of iwconfig:
[root@chris scripts]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 v0.2.0pre2 ESSID:"House"
Mode:Ad-Hoc Channel:6 Cell: 00:00:00:00:00:00
Bit Rate=11Mb/s Tx-Power:18 dBm
Encryption keyff
Link Quality:100/100 Signal level:13/100 Noise level:0/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

This is the output when i try to change the mode
[root@chris scripts]# iwconfig wlan0 mode managed
[root@chris scripts]# iwconfig wlan0 commit
Error for wireless request "Commit changes" (8B00) :
SET failed on device wlan0 ; Operation not supported.
[root@chris scripts]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 v0.2.0pre2 ESSID:"House"
Mode:Ad-Hoc Channel:6 Cell: 00:00:00:00:00:00
Bit Rate=11Mb/s Tx-Power:18 dBm
Encryption keyff
Link Quality:75/100 Signal level:38/100 Noise level:25/100
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

No matter how i try to change the mode, it still stays as "Ad-Hoc"
I didn't find any instruction about modifying /etc/modules.conf in the README file that comes with the driver.

Last edited by highartboi; 09-30-2003 at 10:37 PM.
 
Old 09-30-2003, 10:53 PM   #48
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Right, the readme in the driver has you loading the module and putting the param in that way like this: "insmod src/acx100_pci.o firmware_dir=firmware", which I assume is how the driver got loaded.

The instructions in my howto for this chipset (http://www.houseofcraig.net/acx100_howto.php) attempt to help you set things up where the card is integrated into the system like any *normally* supported device, meaning it starts on boot, comes back from suspend and can be removed/inserted normally, all without too much intervention on your part. This is why you'll see a variance between their readme and my howto. The big exception here is that gui network config tools don't quite get it. The exception here is kwifimanager, which you may want to try, other than it being obviously hard-coded to cut off at 11Mbps, it seems to work with the card and gives those nifty "stair-step" signal bars on the kicker that we're all used to seeing, IMO, redhat's wifi applet is a bit nicer though.

Tell me, when you looked at the readme, did you see the part about enabling the "EXPERIMENTAL_VER_0_3" #define in include/acx100.h? Did you do that? I just did, and I had to go back and set it to 0 and recompile, interestingly enough, with that defined, my card also would not come out of ad-hoc mode. Another option if you're a C programmer would be to find and set the default mode in the source to managed instead of ad-hoc, although this seems a bit kludgy. If you'd like I'll take a look at that.

From the looks of your iwconfig, the card is functional, just not set associated, this is where you can't get it to come out of ad-hoc?
you've tried "iwconfig wlan0 mode managed channel x key off essid house rate 11M".
 
Old 09-30-2003, 11:27 PM   #49
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Ok found the spot to set default to managed mode, open src/acx100_helper.c and modify line #1657 to read "wlandev->mode = 0x2;" from "wlandev->mode = 0x0;", then cd to the top level acx100 directory, "make clean" and "make", then do whatever you're doing to load the module, you may have to "rmmod acx100_pci" first, then load the new module.

I did this and turned EXPERIMENTAL_VER_0_3 back on and recompiled, the card now starts out in managed mode and gets associated, it's a hack and whether you use the experimental #define or not you may want to try it.
 
Old 10-01-2003, 10:35 AM   #50
highartboi
LQ Newbie
 
Registered: Sep 2003
Location: California
Distribution: Red Hat 9
Posts: 14

Rep: Reputation: 0
Cool, I will look at your README link and play around with the srouce code and try to recompile again. I however have a question about how acx100_pci gets to be added to the /etc/modules.conf file and /lib/modules/2.4.20-20.9 directory. I have done "insmod src/acx100_pci.o firmware_dir=firmware" after make driver as instructed in the sourceforge readme file, but that does not put the acx100_pci module in the /lib/modules/2.4.20-20.9 directory nor in the /etc/modules.conf file. Isn't insmod supposed to register the module with the kernel? I have manually copied the module into the /lib/modules/2.4.20-20.9 dir, but it still does not work. Anyways, let me check out your link. thanks
 
Old 10-03-2003, 01:15 PM   #51
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
I don't think insmod does much besides inserting (thus the "ins") a module into the running kernel and resolving (or attempting to) the symbols.

Once you've copied the acx100_pci.o file to a directory under /lib/modules/`uname -r`/, a depmod -a, should get it listed in /lib/modules/`uname -r`/modules.pcimap, and when the card is either inserted, or detected at boot (after pcmcia has loaded), the hotplug system should check that file and match the module to the device. If you change the module, it's location, or remove it, run depmod -a again (unless you've just booted, since it normally gets run at boot).

I should point out that the line number I listed earlier for where to change wlandev->mode to default to managed mode should be used for the 0.2.0pre2 source code only.
 
Old 10-03-2003, 04:38 PM   #52
highartboi
LQ Newbie
 
Registered: Sep 2003
Location: California
Distribution: Red Hat 9
Posts: 14

Rep: Reputation: 0
I see. Once I have put the module in the /lib/modules/`uname -r`/ directory and do a depmod -a, do i still need to run the start_net script, that comes with the driver, every time I reboot the system? Does the start_net script still get used? Do I still need to set the right values in the start_net script? Thanks
 
Old 10-03-2003, 05:05 PM   #53
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Go one way or the other, not both. In other words, if you go with the modifications to your system files outlined in my howto, then don't use start_net at all (I don't). On the other hand, if you're going to use start_net, don't make any of those modifications to your system files, just modify start_net as described in that file and use it alone.
 
Old 10-04-2003, 06:12 PM   #54
highartboi
LQ Newbie
 
Registered: Sep 2003
Location: California
Distribution: Red Hat 9
Posts: 14

Rep: Reputation: 0
Hi Beavis, I followed the your HOW-TO page step by step, I downloaded the driver and compiled it myself. I also copied over the firmware from my windows machine. I modified the /etc/modules.conf and copied all the files needed to the /lib/modules... directories. After I did a depmod -a and inserted my pcmcia card, no module was loaded. here is the output of
[root@chris 2.4.20-20.9]# tail -n 20 /var/log/messages

Oct 4 15:55:36 chris insmod: /lib/modules/2.4.20-20.9/kernel/drivers/net/acx100_pci.o.gz: insmod /lib/modules/2.4.20-20.9/kernel/drivers/net/acx100_pci.o.gz failed
Oct 4 15:55:36 chris insmod: /lib/modules/2.4.20-20.9/kernel/drivers/net/acx100_pci.o.gz: insmod acx100_pci failed
Oct 4 15:55:36 chris /etc/hotplug/pci.agent: ... can't load module acx100_pci
Oct 4 15:55:36 chris /etc/hotplug/pci.agent: missing kernel or user mode driver acx100_pci
Oct 4 15:55:37 chris devlabel: devlabel service started/restarted

I'm not sure what's wrong here. Thanks
 
Old 10-04-2003, 11:03 PM   #55
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Looks like the hotplug system (pci.agent) really *wants* to load the module, but can't, in the log, just a few lines before the 1st one you posted from /var/log/messages it might say why the insmod failed, for one thing, it seems to be looking for acx100_pci.o.gz, not acx100_pci.o, is the module gzip'ed? can you post an ls -l of the directory where the module is located under /lib/modules/.
 
Old 10-06-2003, 08:14 PM   #56
highartboi
LQ Newbie
 
Registered: Sep 2003
Location: California
Distribution: Red Hat 9
Posts: 14

Rep: Reputation: 0
Hi Beavis, thank you so much for your help! Guess what? I'm posting this very message with my D-Link PCMCIA card!!! I restarted all over again and followed exactly the same steps listed on acx100.sf.net, which is the same steps I've gone through for the past dozen tries. The only difference in this try is I unplug the wired ethernet -- eth0. So the only connection is the pcmcia card, and it's working now. Can't believe I had to go througth so much trouble to get it to work. Oh well thank you very much for you help!!!
 
Old 10-06-2003, 08:36 PM   #57
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Yes!!, this is excellent! Good job!
 
Old 10-09-2003, 09:25 PM   #58
highartboi
LQ Newbie
 
Registered: Sep 2003
Location: California
Distribution: Red Hat 9
Posts: 14

Rep: Reputation: 0
hi Beavis, I still got one question tho. Even though my D-Link card is working, the signal level is only 35/100, and it drops connection frequently. So I have to constantly reload the module to reconnect. Any idea why it's doing that? Why is the signal level so low?
Thanks a bunch
 
Old 10-09-2003, 09:32 PM   #59
akaBeaVis
LQ Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
Even with the latest version of the driver, v0.2.0pre3, you need to make sure the mtu setting in ifconfig is 576, to get around possible buffer overruns. You can also try iwconfig txpower xx, (try 40) and see if it responds. Finally, you can try setting the rate back to 11M or 5.5M.

My signal is always 90+, even out in the parking lot, so I'm not sure what's going on there, how far is the access point from you, and what obstructions exist?
 
Old 10-21-2003, 12:47 AM   #60
bige
Member
 
Registered: Mar 2003
Location: Kansas
Distribution: debian
Posts: 44

Original Poster
Rep: Reputation: 15
Talking omfg ... SUCCESS

hey akabeavis, sorry, I'm finally getting back to you after your digression w/ highartboi. Here is my status: I totally got pissed at all that debian shit, and was reading slashdot one day to find out that slack9.1 is out. Installed it and ventured once again w/ the wireless fiasco. After following your guide (you are the man) I compiled the source for the driver, installed it and configured the card. There were a few hitches, but I got it. I am posting this message right now *WIRELESSLY* thanx to you (you are the man)!! anyways... Just thought you would like to know that you are benefiting the human race in one way or the other. I took your advice and didn't give up, I just assumed alternate means of satisfaction! Thanks again and you rule... Maybe now, w/ all my tinkering I can someday help someone like you helped me! YOU are the MAN (take that TI)

ohya... and Slackware 9.1 is nice too, I am enjoying the 2.4.22 kernel for the time being. The OS is nice and fresh, give it a try if you have the time and/or motivation
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dwl-650 + hostap problems.. tacogrande Linux - Networking 2 09-14-2005 04:02 PM
dwl-650+ problems es7us Linux - Networking 2 09-11-2004 06:32 PM
Problems w/ Kismet on Fedora Core 1, DWL-650+ atlantanewbie Linux - Wireless Networking 2 05-18-2004 06:15 PM
SuSE 9 w/ D-LINK DWL-650+ problems... captainhog Linux - Wireless Networking 4 03-23-2004 09:13 AM
D-Link DWL-650+ Problems pdepass Linux - Laptop and Netbook 32 12-05-2003 09:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration