LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-04-2004, 02:21 PM   #1
kidicarus
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 93

Rep: Reputation: 15
dhcpd confusions


Hi.

I recently decided to try comcast cable modems, switching from AOL DSL. With AOL DSL, I would connect to the net with ppp0, then use firestarter to share the connection, and then i would use dhcpd to assign the other computers an ip address.

Right now I think I'm stuck on the last part. I changed firestarter and my dhcpd conf to work with my new configurations, but when i try and start up dhcpd i get:
Starting dhcpd: Internet Software Consortium DHCP Server 2.0pl5
Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software Consortium.
All rights reserved.

Please contribute if you find this software useful.
For info, please visit http://www.isc.org/dhcp-contrib.html

Listening on Socket/eth1/192.168.0.0
Sending on Socket/eth1/192.168.0.0
No subnet declaration for eth0 (24.x.x.x).
Please write a subnet declaration in your dhcpd.conf file for the
network segment to which interface eth0 is attached.
exiting.

I've tried different subnets and different configurations, even tried a class A network, my last attempt was with this:
subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.2 192.168.0.100;
option domain-name-servers 216.x.x.x;
option domain-name "attbi.com";
option routers 192.168.0.1;
option broadcast-address 192.168.0.255;
default-lease-time 9000;
max-lease-time 10000;
}

I really don't know what the subnet should be:
eth0 Link encap:Ethernet HWaddr 00:E0:29:3E:EB:C4
inet addr:24.x.x.x Bcast:255.255.255.255 Mask:255.255.240.0

I don't understand why the first octet is 24 first of all, second, i don't know what that 240 is.

My last configuration worked fine like this:
subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.2 192.168.0.100;
option domain-name-servers 198.x.x.x;
option routers 192.168.0.1;
option broadcast-address 192.168.0.255;
default-lease-time 9000;
max-lease-time 10000;
}

And never complained when ppp0 was connected, any advice?
 
Old 11-04-2004, 04:34 PM   #2
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
Your internal subnet ( the default) should be 255.255.255.0 {and you did change it to this on your final attempt}

I'm assuming that Eth0 is your internet connection.
The 24 in 24.x.x.x is part of your IP address. Your ISP assigns you one of their IP addresses and it just happens that yours starts with 24. There isn't anything you can do (except down the nic) and it isn't going to hurt you, so I wouldn't
worry about it. The 240 in the subnet mask is just because the ISP probably has many subnets for your surrounding areas. You are on the 255.255.240 subnet, and again you should worry about that. Neither of those things will affect your NAT if your are connecting multiple computers.

Since you changed your internal network to
192.168.x.x and the subnet is its default of 255.255.255.0, you've setup
everything correctly and consequently it worked. Since you did get it to
work, I'm wondering what question (besides just answering the Why is this number...) you have.

Just because the default subnet for 192.168.x.x is 255.255.255.0 doesn't mean you couldn't make your internal network just like the ISPs. You could change it to 255.255.240.0, but you wouldn't gain or lose anything so why bother. If you want more info on subnets, check out learntosubnet.com
 
Old 11-04-2004, 05:01 PM   #3
kidicarus
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 93

Original Poster
Rep: Reputation: 15
No, I still haven't got it to work, even if i set the ip address manually on my windows machine it will not work.

What worked was my old configuration, which was like this: Eth0 connected to the adsl modem, which when connected would bring up ppp0. I would then set firestarter to share the connection (NAT) and then I would use DHCPD to assign ip addresses automatically. It worked great.

Now, however, I replaced my dsl modem with cable, and eth0 comes up and connects fine, as does firestarter, but my internal network is not working except for pinging:

eth1 looks like this:

eth1 Link encap:Ethernet HWaddr 00:20:78:1C:8F:06
inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.240.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:222 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43157 (42.1 Kb) TX bytes:0 (0.0 b)
Interrupt:9 Base address:0x1400

(ip address set manually)

dhcpd.conf looks like this:
subnet 192.168.0.0 netmask 255.255.240.0 {
range 192.168.0.2 192.168.0.100;
option domain-name-servers 216.x.x.x;
option domain-name "attbi.com";
option routers 192.168.16.1;
option subnet-mask 255.255.240.0;
option broadcast-address 192.168.0.255;
default-lease-time 9000;
max-lease-time 10000;
}
when i type /etc/init.d/dhcpd start
the error I get is this:


Listening on Socket/eth1/192.168.0.0
Sending on Socket/eth1/192.168.0.0
No subnet declaration for eth0 Please write a subnet declaration in your dhcpd.conf file for the
network segment to which interface eth0 is attached.
exiting.
[FAILED]


Here, a gentleman had much the same problem, and I'm not sure what he did to fix it.
 
Old 11-04-2004, 05:04 PM   #4
kidicarus
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 93

Original Poster
Rep: Reputation: 15
Basically I'm not sure if my internal network should be 192.168.0.x, nor am I sure what the subnet declaration should be.
 
Old 11-04-2004, 05:11 PM   #5
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
The default for 192.168.x.x is 255.255.255.0

Now I'm curious why the router is 192.168.16.1
I would assume for a home network that it be 192.168.0.1
 
Old 11-04-2004, 05:13 PM   #6
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
If it says no declaration for eth0, it sounds like dhcpd is listening to eth0 and you don't want that.

also, I'm not at all familiar with firestarter, so I have to assume that is working properly.

Last edited by musicman_ace; 11-04-2004 at 05:16 PM.
 
Old 11-04-2004, 05:19 PM   #7
kidicarus
Member
 
Registered: Aug 2003
Distribution: Debian Sid
Posts: 93

Original Poster
Rep: Reputation: 15
Quote:
Now I'm curious why the router is 192.168.16.1
That was just a trial, it's back to 192.168.0.1 and it's still not working. If eth0 is down it works, but that doesn't really solve anything, i think eth0 always comes into play.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dhcpd subnet declaration problems in dhcpd.conf vcrispo Linux - Networking 6 07-15-2005 11:32 AM
Wine configuration confusions majordmbss Linux - Newbie 3 04-02-2005 09:12 AM
DHCPD startup failure, mdk 9.2, dhcpd v3.0.1rc11 fuzzyworm Linux - Networking 1 02-14-2004 04:58 AM
kernel confusions? fool_inteligent Slackware 3 08-29-2002 04:36 PM
dhcpd.master or dhcpd.conf rickg Linux - Networking 0 04-11-2002 04:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration