LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-28-2003, 01:55 PM   #1
Llwyd
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 8.0
Posts: 12

Rep: Reputation: 0
Cgi-bin


I know this has been covered, and I think I've read every prior thread on this issue. I'm having a problem with Apache displaying my .pl files as text as opposed to actually executing the files.

Here's the relevant part of my httpd.conf file:

ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"

<IfModule mod_cgid.c>
#
# Additional to mod_cgid.c settings, mod_cgid has Scriptsock <path>
# for setting UNIX socket for communicating with cgid.
#
#Scriptsock logs/cgisock
</IfModule>

#
# "/var/www/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "/var/www/cgi-bin">
AllowOverride None
Options ExecCGI
AddHandler cgi-script .cgi .pl
Order allow,deny
Allow from all
</Directory>

All permissions are set to 755.

If you can see something wrong with this PLEASE let me know. I'm running out of hairs to pull out.

Thanks,

Lance
 
Old 02-28-2003, 05:02 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,571

Rep: Reputation: 180Reputation: 180
Moved to Linux-Networking... Llwyd asked for Linux-General, but it fits betther here IMHO.

Suggestion: do you have mod_cgi (httpd -l)? Are you sure suexec is off?
 
Old 02-28-2003, 05:34 PM   #3
Llwyd
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 8.0
Posts: 12

Original Poster
Rep: Reputation: 0
No, I never installed mod_cgi.


"suEXEC feature which is never installed or activated by default"

I never enabled it, so I can safely say no.
 
Old 03-01-2003, 01:46 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,571

Rep: Reputation: 180Reputation: 180
You need mod_cgi.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cgi-bin in RedHat 7.1 Citizen Bleys Linux - Networking 10 03-27-2006 09:02 PM
Cgi-bin Cool_Hand_Luke Linux - Newbie 3 04-02-2005 03:32 PM
CGI to work out side of cgi-bin? crashedspine Linux - Newbie 13 09-02-2004 08:49 PM
arghh!! cgi-bin help harry_nutt Linux - Software 3 11-09-2002 08:16 PM
http://www.burstnet.com/cgi-bin/ads/ad7954a.cgi/3980/RETURN-CODE rverlander LQ Suggestions & Feedback 1 06-07-2002 07:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration