Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 04-02-2005, 11:52 AM   #1
Registered: Feb 2005
Posts: 40

Rep: Reputation: 15

Ok I need help. I had everything working perfectly and then decided to install this web server stuff which required me to change permissions on the CGI-BIN directory to 777 which I did.

Anyways the thing never worked and after removing the stuff I discoverd none of my previous scripts work now!

What do I need to change back? All the scripts are still 755 and the CGI-BIN directory is 777? Is this correct?

Please HELP as my webforms are no longer working or even a simple test script I wrote.


Cool Hand...
Old 04-02-2005, 12:31 PM   #2
Senior Member
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,289

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
What errors do you get from your CGI scripts? Is there anything in your Apache error log that would illuminate the problem? In general, it's a bad idea to have world writeable directories, particularly in a Web server settinhg. I'd change the cgi-bin directory back to 755 unless you have some other reason not to.
Old 04-02-2005, 03:30 PM   #3
Registered: Feb 2005
Posts: 40

Original Poster
Rep: Reputation: 15
This is the error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache-AdvancedExtranetServer/2.0.44 (Mandrake Linux/11mdk) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.44 OpenSSL/0.9.7a PHP/4.3.1 Server at Port 80
All I changed was the permissions and now it doesn't work at all But it used to. I don't know what the original settings were either.
Old 04-02-2005, 03:32 PM   #4
Registered: Feb 2005
Posts: 40

Original Poster
Rep: Reputation: 15
Fixed it! Thanks for the response.

You see I changed to permissions back to what the other directories were 775. However once I made it 755 it worked!





Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
cgi-bin in RedHat 7.1 Citizen Bleys Linux - Networking 10 03-27-2006 09:02 PM
CGI to work out side of cgi-bin? crashedspine Linux - Newbie 13 09-02-2004 08:49 PM
Cgi-bin Llwyd Linux - Networking 3 03-01-2003 01:46 PM
arghh!! cgi-bin help harry_nutt Linux - Software 3 11-09-2002 08:16 PM rverlander LQ Suggestions & Feedback 1 06-07-2002 07:35 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:01 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration