LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-09-2004, 07:22 PM   #1
Terje
Member
 
Registered: May 2004
Location: My own little world...
Distribution: MX Linux, Slackware
Posts: 64

Rep: Reputation: 16
Question Automatic Mounting Of WinXP Shares At Start?


Hello.

Is there any way to get WinXP shares mounted automatically at startup on my Slackware10.0 box, without putting a clear-text password in /etc/fstab or any other config file?

I can manually access shares on each machine rw from the other machine, and my Linux shares show up automatically on the WinXP machine, but I can't figure out a secure way to automatically mount the WinXP shares on this machine. This isn't a huge issue since I can gain access manually, but it would make things easier if I could automate the process.

Any help is greatly appreciated.

Thanx,
Terje
 
Old 08-10-2004, 12:22 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
You can pass a credentials option. See the "smbmount" mna page for the usage details.
 
Old 08-11-2004, 01:34 AM   #3
Terje
Member
 
Registered: May 2004
Location: My own little world...
Distribution: MX Linux, Slackware
Posts: 64

Original Poster
Rep: Reputation: 16
Thanx!

After reading the smbmount man pages, and a few threads from LQ, I've managed to get the shares from both machines automatically shared at startup. I did, however, encounter something of a glitch while testing the /etc/fstab settings...

After I got everything set up, but before rebooting, I mounted the WinXP share. Permissions were right, I had full rw access, and everything was working just fine -- until I tried to umount it. Even though I had shut down Konqueror, which I was using to browse the share, I got an error that saying "umount: /mnt/ksd: device is busy". Anybody have any ideas about that? The /etc/fstab entry is as follows:

//KIM/SharedDocs /mnt/ksd smbfs credentials=/etc/samba/private/credentials,uid=1001,gid=100 0 0

Terje
 
Old 08-11-2004, 02:44 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
You may be able to use "lsof" to see what is locking the directory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WinXP Cannot Access RH9 Shares SpotsPaw Linux - Networking 8 01-24-2006 01:10 AM
Samba: Can't access shares with WinXP thorax Linux - Software 14 07-28-2004 06:13 AM
Automatic mapping of Samba shares at login on Fedora chaan Linux - Software 2 05-14-2004 11:43 AM
Automatic ftp login for WinXP to Linux Alek Linux - Networking 2 10-21-2003 01:17 PM
access linux shares from winxp flynnhandley Linux - Networking 2 08-27-2003 02:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration