LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-15-2003, 04:04 AM   #1
Batiu-Drami
LQ Newbie
 
Registered: Jun 2003
Posts: 2

Rep: Reputation: 0
Modem Not Detecting


Hi Everyone,

I just loaded Red-Hat 8.0 with Gnome 2 and KDE3. All was going well, but when i tried to connect to the internet, Red Hat wouldn't detect my modem. Its a D-Link DFM-5601+ Internal Modem on COM2.

My PC is dual-booted with XP Home, so if worst comes to worst Ican always boot that up, but I would rather be able to acces it through RedHat

--Phillip Bryant
Linux
 
Old 06-15-2003, 05:41 AM   #2
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Try this... Start kppp, Choose Setup -> Device ->
Under modem device choose /dev/ttiS1 (com2)
Select the modem tab and choose query modem. You should see information about your modem if it is installed corectly.
 
Old 06-15-2003, 10:31 AM   #3
RaI
LQ Newbie
 
Registered: Jun 2003
Location: Germany
Posts: 9

Rep: Reputation: 0
Hello People,

I'm having similar problem.s I've installed Redhat 9 and can't get it to detect my modem. On Windows I get the problem too. I've to get the system to detect a PCI modem enumerator first, then all goes well. But I don't know how to do that on linux. It an HCF modem.

Please help.
 
Old 06-15-2003, 10:52 AM   #4
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
Go to www.linmodems.org and see if you can find your modem in the list... with special drivers, it should work ok.
 
Old 06-19-2003, 03:01 AM   #5
Batiu-Drami
LQ Newbie
 
Registered: Jun 2003
Posts: 2

Original Poster
Rep: Reputation: 0
UPDATE: Ok, I've got it configured, and it detects the modem, but it says 'Modem is Busy', even when I completely unplug the phone and reboot before trying.

Any ideas?

--Phillip
 
Old 06-19-2003, 03:44 AM   #6
juby
Member
 
Registered: Dec 2002
Location: Bangalore, India
Distribution: Ubuntu 5.*
Posts: 241

Rep: Reputation: 30
hey go to http://www.mbsi.ca
they have the drivers for ur modem (I presume that dlink uses a connexant chipset based modem )
 
Old 06-19-2003, 09:59 AM   #7
RaI
LQ Newbie
 
Registered: Jun 2003
Location: Germany
Posts: 9

Rep: Reputation: 0
I've found an appropriate driver for my modem at www.linuxant.com. And now its working fine. www.linmodems.org brought me there. Thanks mad_ady.
If your modem is using a connexant chipset you might also have luck, Batiu-Drami.
 
Old 06-19-2003, 11:36 AM   #8
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
You're welcome....

I had the same problem with my modem (a Motorola SM56 PCI), and I solved it by switching to a cable modem!
 
Old 06-19-2003, 05:04 PM   #9
dark_light
Member
 
Registered: Mar 2002
Location: On Mars
Posts: 115

Rep: Reputation: 15
i have the same problem.i m getting this "busy" message. the modem works fine on xp.
I have a motorola modem.
would linmodems.org fix it?
 
Old 06-19-2003, 05:08 PM   #10
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
# Modem and connection troubleshooting
Modem NHFs
Modem HOWTO
Linmodems.org
Conexant/Rockwell modem HOWTO
The Unofficial PCTel Linux Driver page
I finaly got my PcTel hsp56 mr modem to work
Linux driver for Winmodems with Lucent Apollo (ISA) and Mars (PCI) chipsets
Lucent AMR modem listed as an Intel AC'97 - Smart Link Modems
The kppp Handbook
Dial-up Networking Configuration Using KDE's Kppp
Troubleshooting ISP Connection Problems
Connecting to AOL with Linux

# Compiling kernel modules
You will need to have installed:
1. The developmental packages (compiler)
2. The kernel source code that matches your running kernel
3. The module source or install code

Check out your system and see what's under the hood and see if you installed the stuff you need to do the job. Open an x terminal and type in this sequence of commands to see what kernel we are running and see if you have the kernel source installed:
Code:
[phil@uilleann phil]$ su -
Password: 
[root@uilleann root]# uname -r
2.4.18-3
I am running kernel version 2.4.18-3. Do I have the proper source code?
Code:
[root@uilleann root]# cd /usr/src
[root@uilleann src]# ls -alc
total 3
drwxr-xr-x    4 root     root          136 Jun 12 14:53 .
drwxr-xr-x   16 root     root          424 Jun  4 12:04 ..
lrwxrwxrwx    1 root     root           14 Jun  4 12:11 linux-2.4 -> linux-2.4.18-3
drwxr-xr-x   16 root     root          584 Jun  4 12:11 linux-2.4.18-3
drwxr-xr-x    7 root     root          168 Jun  4 12:08 redhat
[root@uilleann src]#
I do have the same kernel version source code installed in the directory /usr/src/linux-2.4.18-3 and there is a symbolic link named linux-2.4 pointing to it.

If you don't see something similiar to this (but in color), you will need to install the kernel source.

NOTE: I noticed that Red Hat didn't make the symbolic link /usr/src/linux that all of the INSTALL files that I have read mentioned that I need, so I may as well make one now to save editing the files in the source code to install.So, I'll make it just now:
Code:
[root@uilleann src]# ln -s linux-2.4.18-3 linux         
[root@uilleann src]# ls -alc
total 3
drwxr-xr-x    4 root     root          160 Jun 12 15:46 .
drwxr-xr-x   16 root     root          424 Jun  4 12:04 ..
lrwxrwxrwx    1 root     root           14 Jun 12 15:46 linux -> linux-2.4.18-3
lrwxrwxrwx    1 root     root           14 Jun  4 12:11 linux-2.4 -> linux-2.4.18-3
drwxr-xr-x   16 root     root          584 Jun  4 12:11 linux-2.4.18-3
drwxr-xr-x    7 root     root          168 Jun  4 12:08 redhat
[root@uilleann src]#
Ah, there it is, so that's done.

Next, did I install the compiler?
Code:
[root@uilleann src]# gcc -v          
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-113)
[root@uilleann src]#
Yes, I have a compiler installed.

If you don't have those two things installed, you have to install them first off your install CD.

If they are installed, download the source and happy comiling. Make sure you carefully read the README and INSTALL files after extracting and before compiling/installing.

# Guides to software and installation and uninstallation
LNAG - How do I install a program I downloaded from the Internet?
Rute Guide's software explanation
You might want to check out CheckInstall to manage source code installations/uninstallation

# Configuring a pci modem
To configure a pci modem, open an x terminal and su - to the root account:
Code:
[phil@fancypiper phil]$ su -
Password: 
[root@fancypiper root]# cat /proc/pci
Look for your modem in the returned list. Look for something similar to mine:
Code:
  Bus  2, device   2, function  0:
    Communication controller: PCI device 151f:0000 (TOPIC SEMICONDUCTOR Corp) (rev 0).
      IRQ 5.
      I/O at 0xc400 [0xc407].
With this info, I use the setserial command:
Code:
[root@fancypiper root]# setserial /dev/ttyS2 irq 5 port 0xc400 uart 16550a
Then I test the modem with the internet connection wizard and it works. I edit /etc/rc.d/rc.local and enter the setserial command:
Code:
[root@fancypiper root]# pico -w /etc/rc.d/rc.local
My file for an example
Code:
#!/bin/sh
# Redhat /etc/rc.d/rc.local file
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.

touch /var/lock/subsys/local
# configure modem
setserial /dev/ttyS2 irq 5 port 0xc400 uart 16550a
Now, it remains configured after a reboot.
 
Old 06-20-2003, 12:20 PM   #11
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
dark_light: Unfortunatelly Motorola doesn't support any more their modems, but you can get it to work only on a Red Hat 7.0 or 7.1 Linux or Mandrake 8.0
If you try it under a newer linux, you'll get the busy signal

The drivers are rpm.
 
Old 06-20-2003, 03:19 PM   #12
dark_light
Member
 
Registered: Mar 2002
Location: On Mars
Posts: 115

Rep: Reputation: 15
I guess there is a way. But i need some suggestion.

What if i install the Kernel of RHlinux 7.1, edit my grub.config so that i could have the option of running kernel of 7.1 or 8.0 and when i need to connect the internet . i just enter the 7.1 kernel while for other stuff i use 8.0

i think it should work. but i haven't tried it yet so wish me luck
 
Old 06-20-2003, 10:31 PM   #13
juby
Member
 
Registered: Dec 2002
Location: Bangalore, India
Distribution: Ubuntu 5.*
Posts: 241

Rep: Reputation: 30
Thumbs up It will work

Ya it will work perfectly.. i run sm 56 like that

just rpm -ivh kernel-2.4.2 --force
edit ur grub.conf
and then install the drivers ..it will work fine

for more info visit
http://www.infologics.tk/linux.htm
 
Old 06-21-2003, 09:29 AM   #14
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
It works?!?! It's a miracle!

I heard that it was using something that got thrown out of newer kernels... I guess I'm wrong!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Detecting modem pengie Fedora 8 12-21-2004 11:17 PM
Modem Not Detecting sagar Linux - Hardware 5 11-04-2004 08:28 AM
Not detecting modem? Ghimlok Linux - Software 1 12-01-2003 08:19 AM
Modem not Detecting muhammadawood Linux - Hardware 3 12-20-2002 02:27 PM
Ssue 8 not detecting my isapnp modem as a modem cmisip Linux - Hardware 6 11-10-2002 01:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration