LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-07-2003, 02:25 AM   #1
dxdad
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 75

Rep: Reputation: 15
Unhappy IMPS/2 Mouse in Mandrake 9.0


I was happily using my intellimouse (imps/2) in Mandrake 9.0 a few months back. When all of a sudden one time when I started Linux, the mouse wouldn't work. When starting X - a message mentioned that the device was busy or anavailiable.Then with a bit of fiddling I fixed it - I was messing with the permissions of the /dev/mouse and suddenly it worked (it may have had nothing to do with me).

Well, now it did it again and I fiddled and fiddled and it still doesn't work. The mouse works fine in Slackware and windows but not in Mandrake.

Any suggestions would be greatly appreciated.

ps - it has just occured to me that it stopped working not long after giving Debian a go - the first time. And this time I have recently installed Slackware (separate partition, of course).

pps - My appologies, it's early morning. Distro:Mandrake 9.0, Kernel:2.4.19-mdk.

Last edited by dxdad; 08-07-2003 at 02:32 AM.
 
Old 08-08-2003, 06:13 AM   #2
PsychosisNode
Member
 
Registered: Apr 2003
Location: Reading, Berkshire, IN-GER-LUND!!!
Distribution: Mandriva 2006
Posts: 228

Rep: Reputation: 30
XF86Config?

I had mouse problems before when this part of the XF86Config-4 file was a bit funny...

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

-Taiyo
 
Old 08-16-2003, 01:38 PM   #3
dxdad
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 75

Original Poster
Rep: Reputation: 15
Thumbs up Sorted

It turns out it messed up when I accidently booted from the mandrake installation CD. I'm not sure why but I had to go through the setup process - only upgrade - and it fixed it. There is probably an easier (quicker) way but it did the job.

From now on I'll be carefull to remove the CD after adding software from it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack 8.1 XFree 4.2.0 IMPS/2 mouse problem sefirot Slackware 7 06-14-2005 02:02 AM
Synaptics Touchpad - Mandrake 10 psmouse.proto=imps fix doesn't work mepaco Linux - Hardware 2 07-20-2004 09:56 PM
Using two mouses. A Ps/2 and Imps/2 tearinox Linux - General 0 07-18-2004 01:41 AM
problem with mouse after chanignig to IMPS/2 in XF86Config zstingx Linux - General 1 11-13-2003 12:26 PM
IMPS/2 Intellimouse problems stooby Linux - General 3 01-23-2002 10:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration