LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-06-2011, 05:10 AM   #1
thecarpy
Member
 
Registered: Apr 2005
Location: France
Distribution: Devuan, Suse, Slackware
Posts: 130

Rep: Reputation: 21
HP CM 2320 fxi scanner and sane - sudden no device detected


I have a problem here where sane no longer detects my scanner.

Code:
lsusb
reports
Bus 007 Device 002: ID 03f0:5b17 Hewlett-Packard


Code:
sane-find-scanner
reports:

found USB scanner (vendor=0x03f0 [Hewlett-Packard], product=0x5b17 [HP Color LaserJet CM2320fxi MFP]) at libusb:007:002

Code:
scanimage -L
reports

No scanners were identified.

xsane reports no devices detected (I have it in French, "Aucun périférique disponible")

I get the same when I launch xsane as root, so I doubt it is a usb-rules issue.

It used to work; I checked /proc/bus/usb, but that is empty.

Any ideas?
 
Old 03-06-2011, 07:25 PM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: debian IceWM
Posts: 5,718

Rep: Reputation: Disabled
hi

I no longer have a hp but why not run with root powers

hp-setup

Last edited by aus9; 03-07-2011 at 05:05 AM. Reason: some format issue duplicate thingee
 
Old 03-07-2011, 03:39 AM   #3
thecarpy
Member
 
Registered: Apr 2005
Location: France
Distribution: Devuan, Suse, Slackware
Posts: 130

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by thecarpy View Post
I get the same when I launch xsane as root, so I doubt it is a usb-rules issue.

It used to work; I checked /proc/bus/usb, but that is empty.

Any ideas?
So sane does not find my scanner with root privs. Besides, scanning as user root is not right.
 
Old 03-23-2011, 01:46 PM   #4
thecarpy
Member
 
Registered: Apr 2005
Location: France
Distribution: Devuan, Suse, Slackware
Posts: 130

Original Poster
Rep: Reputation: 21
I fixed it by installing all the hplib packages, apparently, when updating ubuntu, some packages were not upgraded, just purely removed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
usb scanner premissions issue when running sane-find-scanner vlsd Linux - Hardware 4 08-20-2009 02:20 PM
Installing sane scanner software JeTa SUSE / openSUSE 3 03-29-2006 01:25 AM
Sane will NOT detect installed scanner! revdg Linux - Hardware 2 01-21-2005 05:04 PM
sane /dev/scanner? jeru Linux - Hardware 3 10-22-2004 09:28 PM
Help with SANE, parallel scanner sb73542 Linux - Software 0 07-31-2003 09:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration