LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-07-2007, 09:25 AM   #1
dashcloud
LQ Newbie
 
Registered: Jul 2006
Posts: 11

Rep: Reputation: 0
Exclamation How I fixed sound on my Toshiba (ALC268)


Hi everyone, I have a Satellite A205-S4587 which has an Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02). aplay -l shows: card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]

I got sound (mostly) working by using the latest alsa drivers from the mercurial (hg) source, and by adding a patch I found in a bug report here: https://bugtrack.alsa-project.org/al...ew.php?id=3104
(get patch_realtek.c)

Install mercurial, all the build tools (including automake and autoconf), and if you want to build a version of the alsa utilities from source, install gettext.

Use the following commands to get the source:
hg clone http://hg-mirror.alsa-project.org/alsa-driver alsa-driver
hg clone http://hg-mirror.alsa-project.org/alsa-kernel alsa-kernel
hg clone http://hg-mirror.alsa-project.org/alsa-lib alsa-lib

and if you want a new version of alsa-utils:
hg clone http://hg-mirror.alsa-project.org/alsa-utils alsa-utils

Before you build it, copy or move the patch_realtek.c file to alsa-kernel/pci/hda (overwrite if asked).
To build it, go into each folder (except for alsa-kernel), and type ./hgcompile (instead of ./configure). Then type make,
and sudo make install.

Then you could rmmod snd-hda-intel, modprobe snd-hda-intel and things should be good once you check the mixer setttings.

Problems that will remain include less mixer options as compared to an unpatched ALSA-HG, and the sound is extremely low when headphones are plugged in no matter what you do.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SB AWE64 MIDI no sound-fixed it discipled1 Slackware 0 08-26-2004 04:05 PM
FC2 Sound problem fixed. Sort of. sybian Fedora 4 05-23-2004 06:23 AM
Fixed my Alsa sound problem with Slack 9.1 Cyclops Slackware 4 10-25-2003 11:33 PM
KsCD has no sound... FIXED rocannon LinuxQuestions.org Member Success Stories 0 06-05-2003 09:26 PM
??? Somehow I fixed my sound Infamous Tim Linux - General 0 07-16-2001 11:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration