LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-18-2006, 04:23 PM   #1
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/Win7/8/10
Posts: 677

Rep: Reputation: 30
hard drive no longer detected


Hello i was tightening the screws in the back of my laptop and when i went to start it up i get error message about hard disk not being detected iv tried taking it out and re-sitting it several times,but to no avail can anybody give me any suggestions.on what else i could do.The laptop is a dell c600 the hard disk is an ibm travelstar iv never had any problems with this before.
 
Old 01-18-2006, 05:14 PM   #2
esteeven
Senior Member
 
Registered: Oct 2001
Location: Bristol UK
Distribution: Slackware, Ubuntu
Posts: 1,066

Rep: Reputation: 46
Is this error message at bios?
 
Old 01-19-2006, 11:05 AM   #3
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/Win7/8/10
Posts: 677

Original Poster
Rep: Reputation: 30
yes my laptop will not detect it is there.I went in to the bios and no hard drive is being detected,when i power my laptop on i get this error.
"Primary hard disk drive 0 not found
No bootable device(s) selected
strike f1 to retry boot,f2 for setup utility.
I can boot from a live cd.
Thanks nige
 
Old 01-19-2006, 11:16 AM   #4
bharathvn
Member
 
Registered: Mar 2005
Distribution: Redhat , Debian
Posts: 43

Rep: Reputation: 15
hey man, check it out whether u have connected the hard drive to motherboard.
 
Old 01-19-2006, 11:26 AM   #5
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/Win7/8/10
Posts: 677

Original Poster
Rep: Reputation: 30
well it just slots in the side and a flap comes down to lock it in place.
Thanks nige
 
Old 01-19-2006, 08:20 PM   #6
ScottReed
Member
 
Registered: Dec 2005
Location: Montana
Distribution: Debian "squeeze"
Posts: 157

Rep: Reputation: 30
Does it spin up when you power on the laptop?
 
Old 01-20-2006, 09:50 AM   #7
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/Win7/8/10
Posts: 677

Original Poster
Rep: Reputation: 30
yes it does.
 
Old 01-20-2006, 11:59 AM   #8
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 126Reputation: 126
If you press F2 and go into setup, is the IDE interface enabled? Does asking for a refresh of IDE devices show it?

What made it need the screws tightened?
 
Old 01-20-2006, 12:42 PM   #9
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/Win7/8/10
Posts: 677

Original Poster
Rep: Reputation: 30
when i press f2 and go in to setup under primary hard drive it says "none" i am not given the option to change that.Below this it says "diskette reconfig" i am given the choice to either have "any time" or "at reboot only" i have got this set on "any time" i dont see any setting to refresh this.
Thanks nige
 
Old 01-20-2006, 01:37 PM   #10
ScottReed
Member
 
Registered: Dec 2005
Location: Montana
Distribution: Debian "squeeze"
Posts: 157

Rep: Reputation: 30
What I would do is this.

Remove the HD again from the laptop. Put it in an external firewire/usb enclosure using a 2.5 inch ide converter (basically a cable + power) and see if the drive mounts on another machine.

If it does then you have a logic board problem on your laptop.

If it doesn't then you have a bad disk.

I would assume the disk is bad, that's my assumption.

Keep us posted, im curious.

Scott
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard drive not detected gudum35 Linux - Laptop and Netbook 3 06-30-2005 08:43 AM
Hard Drive Not Being Detected yrkely Debian 2 06-17-2005 01:19 PM
hard drive will no longer boot-wd30gig7200 mikeybsae Linux - Hardware 1 12-08-2003 05:50 AM
slave hard disk no longer detected by bios mikeybsae Linux - Hardware 1 10-22-2003 10:11 PM
CD-Drive no longer detected? M4A1Carbine Linux - Hardware 1 09-23-2003 11:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration