LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-18-2013, 08:30 PM   #1
felipefv
Member
 
Registered: Sep 2010
Distribution: Debian
Posts: 59

Rep: Reputation: 5
Question Fan always working (high speed)


Hello!

I've installed Debian Wheezy on a Dell laptop and the fan just don't stop working. The CPU doesn't need to be cooled, but the fan keeps working at high speeds. I've searched in various forums threads (including on other websites), but have not found a similar situation: analyzing cpufreq-info command, I realized that the minimum frequency of operation is equal to the maximum, even in conservative or on demand settings. Could this be the cause?

Can anyone help me on solving this?

Thanks!

Felipe
 
Old 10-18-2013, 09:19 PM   #2
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: infinity; (randomly born:) Milwaukee, WI, US, Earth
Distribution: any UNIXish that works well on my cheapest with mostly KDE, Xfce, JWM or CLI but open ;-)
Posts: 1,324
Blog Entries: 2

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
Chill mat (sorry just discovered LMGTFY ) or put a fan on it to see if it stops PCs fan? (then we should know if it's the OS)

On my Debian Nepomuk server (virtuoso\process) for file indexing runs on boot for a while (works hard) but then stops, did you try the system monitor or:
Code:
top

Last edited by jamison20000e; 10-18-2013 at 09:24 PM.
 
Old 10-19-2013, 08:54 AM   #3
felipefv
Member
 
Registered: Sep 2010
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by jamison20000e View Post
Chill mat (sorry just discovered LMGTFY ) or put a fan on it to see if it stops PCs fan? (then we should know if it's the OS)

On my Debian Nepomuk server (virtuoso\process) for file indexing runs on boot for a while (works hard) but then stops, did you try the system monitor or:
Code:
top

Great Google site, haha!
So, I think that the temperature is ok. It is at 39C on both cores right now, but the fan is crazy. On Windows this just doesn't happen. Something got to be wrong...
 
Old 10-19-2013, 09:53 AM   #4
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: infinity; (randomly born:) Milwaukee, WI, US, Earth
Distribution: any UNIXish that works well on my cheapest with mostly KDE, Xfce, JWM or CLI but open ;-)
Posts: 1,324
Blog Entries: 2

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
Yes, if it doesn't happen in windows then you must have some process that's out of control or fan control? My only thought is to use 'top' in a command line then hit shift r 2 times to sort CPU usage top to bottom and you should also do some as 'sudo top'

P.s: after looking at my top I think the list is sorted and R twice is frivolous except to pirates RR
 
Old 10-19-2013, 03:25 PM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,346
Blog Entries: 2

Rep: Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978
An always running fan in a laptop can also be caused by the video-chip and its drivers. Which video hardware do you have and which drivers are you using?
 
Old 10-19-2013, 09:50 PM   #6
felipefv
Member
 
Registered: Sep 2010
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by jamison20000e View Post
Yes, if it doesn't happen in windows then you must have some process that's out of control or fan control? My only thought is to use 'top' in a command line then hit shift r 2 times to sort CPU usage top to bottom and you should also do some as 'sudo top'

P.s: after looking at my top I think the list is sorted and R twice is frivolous except to pirates RR
evolution-alarm 99,50% of CPU use, and I don't even open it.

---------- Post added 10-19-13 at 11:51 PM ----------

Quote:
Originally Posted by TobiSGD View Post
An always running fan in a laptop can also be caused by the video-chip and its drivers. Which video hardware do you have and which drivers are you using?
Can you help me on retrieving that driver information?
 
Old 10-19-2013, 10:23 PM   #7
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: infinity; (randomly born:) Milwaukee, WI, US, Earth
Distribution: any UNIXish that works well on my cheapest with mostly KDE, Xfce, JWM or CLI but open ;-)
Posts: 1,324
Blog Entries: 2

Rep: Reputation: 338Reputation: 338Reputation: 338Reputation: 338
https://bugs.launchpad.net/ubuntu/+s...on/+bug/543492 try killing the PID number in top, hit k to do so and see if fan stops after awhile then?
 
Old 10-20-2013, 07:20 AM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,346
Blog Entries: 2

Rep: Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978
Quote:
Originally Posted by felipefv View Post
Can you help me on retrieving that driver information?
Code:
lspci|grep VGA
glxinfo|grep render
 
1 members found this post helpful.
Old 10-20-2013, 03:38 PM   #9
felipefv
Member
 
Registered: Sep 2010
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by jamison20000e View Post
https://bugs.launchpad.net/ubuntu/+s...on/+bug/543492 try killing the PID number in top, hit k to do so and see if fan stops after awhile then?
Killed it, and CPU usage went down. The thing is, I really don't know what's happening here. It looks like my notebook has come to life and chooses when to turn the fan on, because, right now sensors are saying that both cores equals to 39/40C, and it is still working. And some time ago sensors showed me 54C and the fan was "normal"... What is going on?
 
Old 10-20-2013, 03:39 PM   #10
felipefv
Member
 
Registered: Sep 2010
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by TobiSGD View Post
Code:
lspci|grep VGA
glxinfo|grep render
lspci | grep VGA:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

glxinfo | grep render:
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
GL_NV_conditional_render, GL_ARB_ES2_compatibility,
 
Old 10-20-2013, 11:59 PM   #11
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,346
Blog Entries: 2

Rep: Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978
Ivybridge CPUs and older kernels (like in Debian Stable) are not a good combination to begin with, those older kernels lack Intel's p-state driver for power-management on newer CPUs and the standard ondemand cpufreq-driver does not work correctly with them. The first thing I would try is to upgrade to a kernel >=3.10 and watch if that behavior still occurs.
 
Old 10-21-2013, 06:55 AM   #12
felipefv
Member
 
Registered: Sep 2010
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by TobiSGD View Post
Ivybridge CPUs and older kernels (like in Debian Stable) are not a good combination to begin with, those older kernels lack Intel's p-state driver for power-management on newer CPUs and the standard ondemand cpufreq-driver does not work correctly with them. The first thing I would try is to upgrade to a kernel >=3.10 and watch if that behavior still occurs.
I'm running a 3.10 kernel right now, and the problem persists... Sensors shows 45C on both cores...
 
Old 10-21-2013, 08:21 AM   #13
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,346
Blog Entries: 2

Rep: Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978
Have you changed the governor to the p-state driver?
 
Old 10-21-2013, 08:28 AM   #14
felipefv
Member
 
Registered: Sep 2010
Distribution: Debian
Posts: 59

Original Poster
Rep: Reputation: 5
Quote:
Originally Posted by TobiSGD View Post
Have you changed the governor to the p-state driver?
This is what I've found:

Starting with kernel 3.9, the new pstate power scaling driver is used automatically for modern Intel CPUs instead of the other drivers below. This driver takes priority over other drivers and in fact is inbuilt as opposed to being a module. This driver is currently automatically used for Sandy Bridge and Ivy Bridge type CPUs. If you encounter a problem while using this driver, add intel_pstate=disable to your kernel line. You can use the same user space utilities with this driver but cannot control it.

So, there's no change updating the kernel. Or did I miss something?

EDIT: Fresh installed Debian testing (jessie) with 3.10 kernel to test it.

Last edited by felipefv; 10-21-2013 at 08:33 AM. Reason: Add information
 
Old 10-21-2013, 08:36 AM   #15
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,346
Blog Entries: 2

Rep: Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978Reputation: 3978
Quote:
Originally Posted by felipefv View Post
So, there's no change updating the kernel. Or did I miss something?
Nope, since that has not fixed your problems the cause for that heat does seem to be something different. Sadly, I am out of clue now, but you can test if that behavior is caused by the GUI (or one of the GUI programs) or by the underlying system with disabling the GUI (or booting into single user mode) and have a look at the temperatures.
 
1 members found this post helpful.
  


Reply

Tags
cpufreq, fan, high, speed


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] high cpu temp; no effect on fan speed ; kernel panic but not always. ununun Linux - Hardware 11 12-04-2012 12:00 PM
Can't Change CPU fan speed form High. theKbStockpiler Linux - Hardware 9 08-01-2011 07:35 AM
High temperature and fan speed Deimoz Linux - Hardware 4 08-03-2010 09:14 AM
Fan running at high speed gmartin Slackware 1 09-15-2009 12:30 AM
howto: control CPU fan speed and Northbridge fan speed? hedpe Linux - Software 2 04-18-2005 02:18 AM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration