LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-05-2009, 04:21 PM   #1
viroos
LQ Newbie
 
Registered: Dec 2005
Posts: 5

Rep: Reputation: 0
Arduino no /dev/ttyUSB* on Ubuntu 9.04 amd64 nor Arch 64 (ftdi chip)


Hi,
I just got Arduino Duemilanove. But I have big problems using it on my desktop.

I tried on Ubuntu and Arch (both 64 bit).

This is my dmesg output from ubuntu:

Code:
[ 1841.584142] usb 5-2: device descriptor read/64, error -71
[ 1841.809118] usb 5-2: device descriptor read/64, error -71
[ 1842.024208] usb 5-2: new full speed USB device using uhci_hcd and address 4
[ 1842.144129] usb 5-2: device descriptor read/64, error -71
[ 1842.368132] usb 5-2: device descriptor read/64, error -71
[ 1842.585113] usb 5-2: new full speed USB device using uhci_hcd and address 5
[ 1843.000129] usb 5-2: device not accepting address 5, error -71
[ 1843.112121] usb 5-2: new full speed USB device using uhci_hcd and address 6
[ 1843.529123] usb 5-2: device not accepting address 6, error -71
[ 1843.529152] hub 5-0:1.0: unable to enumerate USB device on port 2

this is uname -a:
Code:
Linux cyklop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux
I have removed brltty.

Arduino board is OK because it's works under debXO with 32bit kernel 2.6.25.15


It's strange that I don't see Vonder and Product Id in lsusb -v output on Ubunt. But from debXO I determined its 0x043 0x6001

I tried
Code:
sudo modprobe ftdi_sio
and then
Code:
sudo echo -n "0x403 0x6001" /sys/bus/usb-serial/drivers/ftdi_sio/new_id
But it didn't helped.

TIA for help.

regards,
Maciej
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unmount kills /dev/scd0 - Ubuntu 8.10 amd64 joker20 Ubuntu 0 02-03-2009 02:41 PM
Vmplayer succes in amd64 distros? slamd64, arch linux dysenteryduke Linux - Software 1 09-16-2006 08:14 PM
no /dev/ttyUSB* with FC3 please help derddera Fedora 3 12-30-2004 08:43 AM
portable distro for amd64 arch escargot22026 Linux - Distributions 5 12-28-2004 12:41 PM
/dev/ttyUSB? disappaers on SuSE 9.1 with pilot-link gevard Linux - Laptop and Netbook 0 08-29-2004 03:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration