LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-20-2005, 11:57 AM   #1
cmario00
LQ Newbie
 
Registered: Sep 2004
Posts: 7

Rep: Reputation: 0
vanilla-kernel v.2.6.9, devfs & scsi drive issue


Ok, so i figured out that devfs keeps a weird format for scsi drives, but changing my fstab or my lilo.conf hasnt helped, when i boot up my system i get:

VFS: Cannot open root device "801" or unknown-block(8,1)
please append a correct "root=" boot option
kernel panic- not syncing : VFS : Unable to mount root fs on unknown-block(8,1).

Now let me go into detail:

I'm setting up Gentoo Linux ontop of VMWare on my cheapass acer laptop. Gentoo linux identifies my VMWare virtual drive as an 8gig scsi drive. Installation with LiveCD (which happens to use a similar kernel without devfs) went well, which means i was able to partition the virtual drive and install everything on it. The LiveCD kernel enumerates scsi drives as sd[a-z], devfs has a different format.

Through the process compiling the standard 2.6.9 linux kernel with devfs (as required by the gentoo guidelines), there were no problems. On restart, i got the error message i mentioned above. I tried both grub and lilo, and neither worked. I believe the root=[...] argument is sent to the kernel, which means that the kernel is unable to access the device im addressing. Ive tried to address the device in both devfs format (see below) as well as non-devfs.

root=/dev/sda1

or

root=/dev/scsi/host0/bus0/target0/lun0/part1

Can someone give me a hint as to how i can debug this issue real time. Or even better, a solution?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
synaptic & vanilla kernel seriesx4 Ubuntu 1 11-10-2005 03:00 PM
SCSI & Generic Drive issues Azhrarn Linux - Hardware 2 08-29-2005 03:08 AM
CD-RW install/setup/scsi issue with k3b/xcdroast and kernel compile probs Texicle Slackware 17 01-09-2004 01:50 AM
boot kernel issue with raid controller and scsi cdrom mrtwice Slackware 3 08-31-2003 09:43 PM
SCSI controler card selection & drive ID help ScreeminChikin Linux - Hardware 1 11-20-2002 03:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration