LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (https://www.linuxquestions.org/questions/linux-general-1/)
-   -   vanilla-kernel v.2.6.9, devfs & scsi drive issue (https://www.linuxquestions.org/questions/linux-general-1/vanilla-kernel-v-2-6-9-devfs-and-scsi-drive-issue-280155/)

cmario00 01-20-2005 12:57 PM

vanilla-kernel v.2.6.9, devfs & scsi drive issue
 
Ok, so i figured out that devfs keeps a weird format for scsi drives, but changing my fstab or my lilo.conf hasnt helped, when i boot up my system i get:

VFS: Cannot open root device "801" or unknown-block(8,1)
please append a correct "root=" boot option
kernel panic- not syncing : VFS : Unable to mount root fs on unknown-block(8,1).

Now let me go into detail:

I'm setting up Gentoo Linux ontop of VMWare on my cheapass acer laptop. Gentoo linux identifies my VMWare virtual drive as an 8gig scsi drive. Installation with LiveCD (which happens to use a similar kernel without devfs) went well, which means i was able to partition the virtual drive and install everything on it. The LiveCD kernel enumerates scsi drives as sd[a-z], devfs has a different format.

Through the process compiling the standard 2.6.9 linux kernel with devfs (as required by the gentoo guidelines), there were no problems. On restart, i got the error message i mentioned above. I tried both grub and lilo, and neither worked. I believe the root=[...] argument is sent to the kernel, which means that the kernel is unable to access the device im addressing. Ive tried to address the device in both devfs format (see below) as well as non-devfs.

root=/dev/sda1

or

root=/dev/scsi/host0/bus0/target0/lun0/part1

Can someone give me a hint as to how i can debug this issue real time. Or even better, a solution?


All times are GMT -5. The time now is 02:22 PM.