LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-15-2002, 12:50 PM   #1
NetScripter
Member
 
Registered: Feb 2002
Location: Russia
Distribution: Gentoo 2005.1, Ubuntu 5.10, Debian 3.1
Posts: 66

Rep: Reputation: 15
Problems with mailing from PHP


Here is my problem: I just have moved my mailing php script from one server to another. Old's mail server was Courier and everything was fine, but the new X-mail server does'n let me to send a mail. There is a message in apache error file:
sh: permissions denied
when I attempting to call php mail() function.
The path to sendmail is correctly set to /var/MailDir/bin/sendmail in php.ini
Does anyone can help me?
 
Old 03-10-2003, 04:23 PM   #2
figmentium
Member
 
Registered: Mar 2002
Location: Alberta, Canada
Distribution: Debian 4.0 Etch
Posts: 64

Rep: Reputation: 15
hi, if you're still around (lol), did you ever get this problem solved? I'm experiencing a similar problem.

I'm curious if anyone else has any input about this problem under this situation.

I am using RedHat 7.3, PHP 4.3.1 and Apache 1.3.27... I installed Xmail, which replaces my sendmail, and simulates it ....

The problem i'm having is when using a php form to send a form by email using the mail() function. I installed apache with ./configure --prefix=/etc/apache --enable-module=so and then installed PHP ./configure --with-mysql --with-apxs=/www/bin/apxs .

Yes, my php.ini is configured.

By accident or fluke, I happened to install apache over top the existing apache and then the email form started working... i'm very puzzled by this. I would like to work under normal circumstances (if there are any lol).

I don't understand why it would work by reinstalling it over again and not the way its installed now.

I've since reformatted and did a fresh install of everything. And I get the same issue.

Thank you very much for any input

***additional info: I just went hunting for some log files and I found some in my apache error logs... it says:

sh: /usr/sbin/sendmail: /bin/bash: bad interpreter: Permission denied

I'm not sure what to do now...

Last edited by figmentium; 03-10-2003 at 04:44 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help With Mailing! linuxnoob7 Linux - Software 14 08-15-2005 11:14 AM
mailing praveenv Linux - Newbie 2 09-10-2004 06:19 AM
slackware, apache and PHP from .tgz - problems with PHP szymon Slackware 2 09-06-2004 05:57 PM
e-mailing Linux~Powered Linux - Software 3 02-12-2004 09:07 PM
Mailing Lists Orwick Alefgard Linux - General 3 08-22-2003 02:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 06:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration