LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 01-09-2005, 06:30 AM   #16
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53

Quote:
Amazingly that still doesn't do the trick.
You mean the artsdsp thing?

Since you think you're using ALSA, can you post the output of lsmod and the contents of your /etc/asound.conf and/or your ~/.asoundrc file(s)?
 
Old 01-25-2005, 04:57 PM   #17
zlamma
LQ Newbie
 
Registered: Mar 2004
Location: Poland
Posts: 3

Rep: Reputation: 0
If it's using alsa, you will allso need chmod +wr for the /dev/snd/*
 
Old 02-09-2005, 07:21 PM   #18
Danus ex
LQ Newbie
 
Registered: Oct 2004
Location: Ramsey, Minnesota
Distribution: Slackware 10.1
Posts: 16

Rep: Reputation: 0
I have (had) this same problem, but it was solved by doing the 'artsdsp mozilla-firefox' command!
 
Old 02-21-2005, 08:57 PM   #19
DSLC
LQ Newbie
 
Registered: Jun 2004
Location: Ireland
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
My suggestion, which involves TWO steps, is the following:

STEP 1: check if you have either an .asoundrc file (/home/~/.asoundrc), or an asound.conf (probably in /etc). It's quite likely you don't have either - my slackware distribution didn't have them anyway.

If not, you can try this (VERY BASIC, and quite possibly flawed, file):

Code:
        pcm.emu10k1 {
           type hw
           card 0
        }

        ctl.emu10k1 {
           type hw
           card 0
        }

        pcm.dsp0 {
           type plug
           pcm.slave emu10k1
}
I have used "emu10k1' because you said you have a SoundBlaster Audigy card. If there's a problem, you can search for a more suitable file for your card here.
Save that file to either /home/xxx/.asoundrc, or /etc/asound.conf.

Step 2: in the shell, type:
Code:
aoss firefox
replace firefox with the full path of the program if necessary.

Hope that helps. It did for me anyway!!
 
Old 03-06-2005, 06:26 PM   #20
neatflux
LQ Newbie
 
Registered: Oct 2004
Location: Provo, UT
Distribution: Fedora Core 2
Posts: 15

Rep: Reputation: 0
This might work

This solution sounds too easy but it worked for me....
By default (for me) in KMix the PCM output volume was set all the way down. After adjusting it, restart Firefox. homestarrunner.com, at least, works now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash Player, Firefox: sound in blackbox but not KDE DaneM Slackware 11 11-21-2006 01:41 PM
KDE blocks sound? cant play sound from other programs. Smurfen Linux - Hardware 1 04-02-2005 07:14 PM
Gentoo 64-bit on AMD. Console sound with ALSA OK, but no sound in KDE. damien Linux - Software 7 02-02-2005 01:05 AM
kde sound options gone except for root, login sound gone memphisSuseUser Linux - Distributions 2 12-10-2004 05:55 PM
Gnome has sound/switch to KDE no sound Lar Fedora 6 11-05-2004 03:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 07:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration