LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 05-08-2003, 11:01 PM   #1
lostboy
Member
 
Registered: Mar 2003
Location: Florida
Distribution: Slackware 9.1,10.1
Posts: 268

Rep: Reputation: 30
Question Alright, I have correct output for ' cdrecord -scanbus ', but can't mount drive


Here is the output of ' cdrecord -scanbus ' :

root@JAC:~# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
scsibus0:
.........0,0,0.......0) 'SONY ' 'CD-RW CRX100E ' '1.0m' Removable CD-ROM
.........0,1,0......1) *
.........0,2,0......2) *
.........0,3,0......3) *
.........0,4,0......4) *
.........0,5,0......5) *
.........0,6,0......6) *
.........0,7,0......7) *
root@JAC:~#

Here is fstab :

/dev/hdc1.........swap............swap...........defaults....................0 0
/dev/hdc2........./.....................ext2............defaults....................1 1
/dev/hda5........./D..................vfat.......defaults,umask=0000..0 0
/dev/hda6........./E..................vfat..............defaults....................0 0
/dev/cdrw........./mnt/CD-RW...iso9660.....noauto,owner,ro...0 0
/dev/fd0.........../mnt/A............auto...........noauto,owner...........0 0
devpts............../dev/pts.........devpts........gid=5,mode=620.....0 0
proc................../proc...............proc..........defaults.......................0 0


And here is the relevant lilo entry :


image =/boot/vmlinuz
label = Linux
read-only
root = /dev/hdc2
append="hdd=ide-scsi"


SCSI emulation is enabled directly in my kernel, and so is SCSI support, so I have nothing going on with modules.

What do I need to do to make the drivr mount ?

JC

Last edited by lostboy; 05-08-2003 at 11:12 PM.
 
Old 05-08-2003, 11:03 PM   #2
PTBmilo
Member
 
Registered: Jan 2003
Posts: 167

Rep: Reputation: 30
mount /dev/scd0 /mnt/cdrom

( /dev/hdd turns into scd0 with scsi-emulation)
 
Old 05-08-2003, 11:10 PM   #3
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
ln -sf /dev/scd0 /dev/cdrw
mount /dev/cdrw /mnt/CD-RW

SCSI emulation, remember?

# CD burning info
Adding an IDE CD-Writer to Linux
CD Writing HOWTO
# Burn an ISO to disk
cdrecord -v speed=5 dev=0,0,0 /path/to/foo.iso
# Burn from disk to disk
cdrecord -v dev=0,0,0 speed=5 -isosize /dev/cdrom
# Generate an ISO from a directory.
mkisofs -Jr -o foo.iso /path/to/directory
mkisofs -vrTJUV "Label" -o foo.iso /path/to/directory
# Generate an ISO from a CD
dd if=/dev/cdrom of=foo.iso
Linux MP3 CD Burning mini-HOWTO
# Convert mp3 to wav with lame
for i in *.mp3; do lame --decode $i `basename $i .mp3`.wav; done
# Burn a CD from wav files
cdrecord -v -audio -pad speed=5 dev=0,0,0 /path/to/*.wav
# Erase a CDRW
cdrecord -v dev=0,0,0 speed=5 blank=fast
 
Old 05-08-2003, 11:16 PM   #4
lostboy
Member
 
Registered: Mar 2003
Location: Florida
Distribution: Slackware 9.1,10.1
Posts: 268

Original Poster
Rep: Reputation: 30
Thanks for the replys. I forgot to mention that I did create a symlink in ' /dev ' called ' cdrw ' and it points to ' scd0 ' .

JC
 
Old 05-08-2003, 11:28 PM   #5
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 60
Are you mounting as root and do you have aCD with the iso9660 filesystem (data disk) in the drive? Audio CDs don't mount.
 
Old 05-08-2003, 11:40 PM   #6
lostboy
Member
 
Registered: Mar 2003
Location: Florida
Distribution: Slackware 9.1,10.1
Posts: 268

Original Poster
Rep: Reputation: 30
Yes it's iso9660 . It's the Slackware 9.0 CD. It mounts fine when I treat the drive like a CD-ROM.

JC
 
Old 05-09-2003, 12:01 AM   #7
lostboy
Member
 
Registered: Mar 2003
Location: Florida
Distribution: Slackware 9.1,10.1
Posts: 268

Original Poster
Rep: Reputation: 30
Talking

Hold everything, sorry . My fault. I missed two items in the kernel config - enable scsi cdrom support, and disable the mulitple lun setting. I'm cooking up a new kernel, and will see what happens.

Thanks,

JC
 
Old 05-09-2003, 12:45 AM   #8
lostboy
Member
 
Registered: Mar 2003
Location: Florida
Distribution: Slackware 9.1,10.1
Posts: 268

Original Poster
Rep: Reputation: 30
Ok, I have found my blunder. It was those two settings in the kernel config. With my new kernel, there's no problem seeing the drive as a CD-RW and it mounts now.

Thanks

JC
 
Old 05-09-2003, 02:10 AM   #9
PTBmilo
Member
 
Registered: Jan 2003
Posts: 167

Rep: Reputation: 30
party on lostboy
 
Old 05-09-2003, 11:26 AM   #10
lostboy
Member
 
Registered: Mar 2003
Location: Florida
Distribution: Slackware 9.1,10.1
Posts: 268

Original Poster
Rep: Reputation: 30
"party on lostboy"

You bet PTBmilo ! I feel like partying now. I'm starting to get the hang of Slackware.

JC
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrecord -scanbus output Permaximus Linux - Software 4 04-03-2005 07:56 AM
cdrecord -scanbus is returning the wrong drive rdluce Linux - Newbie 3 05-28-2004 07:55 PM
CDrecord -scanbus Gerardoj Linux - Software 4 05-02-2004 09:27 PM
Problem with cdrecord -scanbus and a USB CD-RW drive pib Linux - Hardware 1 09-08-2003 12:37 PM
cdrecord -scanbus Cybers19 Linux - General 4 05-22-2003 02:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration