LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 09-03-2017, 08:02 AM   #1
jr_bob_dobbs
Member
 
Registered: Mar 2009
Distribution: Linux From Scratch, Bedrock
Posts: 299
Blog Entries: 43

Rep: Reputation: 12
reducing verbosity of some modules


When booting my BLFS system, I often get text that "spams" the screen over the login prompt. Sometimes I'll stare at my computer like a ninny before I realize that it actually is waiting for the user name input. D'oh!

Sometimes, if I am in text mode (not in xorg) I'll get random messages that overlay whatever test is by the cursor. Makes text editing a bit fiddly.

The messages are usually of this sort (typed by hand from a screen shot, so there could be mistakes):
Code:
[   34.153687] iwlwifi 00:0d:00.0: L1 Enabled - LTR Enabled
[   34.369347] IPv6: ADDRCONF(NETDEV_UP): wlp13s0: link is not ready
That one is always present at boot-time. It can also be one the later random ones. wlp13s0 is the wifi device name and iwlwifi is the intel wifi driver module. Sometimes the random ones I think print something about USB or HID.

The messages do not seem to indicate real errors. Network and the USB continue to work. What I would like is to not have my login prompt obscured nor any other text while in the console after logging on.

How can I stop this text spammy-ness?

p.s. I once had something like this in Gentoo. At the time, the solution was to install a system logging package. I'm pretty sure the basic LFS install put in a logger. I know I have logs files and that they grow, since I have to run a logrotate script from time to time. So I am unsure as to a solution.

Thank you.

Last edited by jr_bob_dobbs; 09-03-2017 at 08:06 AM.
 
Old 09-03-2017, 10:05 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,904
Blog Entries: 7

Rep: Reputation: 2438Reputation: 2438Reputation: 2438Reputation: 2438Reputation: 2438Reputation: 2438Reputation: 2438Reputation: 2438Reputation: 2438Reputation: 2438Reputation: 2438
i remember there were different solutions on different systems, but this has worked for me (recently):
https://superuser.com/a/351402
 
Old 09-03-2017, 05:40 PM   #3
Luridis
Member
 
Registered: Mar 2014
Location: Texas
Distribution: LFS 8.0 Custom, Merged Usr, Linux 4.9.35
Posts: 488

Rep: Reputation: 121Reputation: 121
Code:
cat > /boot/grub/grub.cfg << "EOF"
# Begin /boot/grub/grub.cfg
set default=0
set timeout=5

insmod ext2
set root=(hd0,2)

menuentry "GNU/Linux, Linux 4.12.7-lfs-8.1-systemd" {
    linux /boot/vmlinuz-4.12.7-lfs-8.1-systemd root=/dev/sda2 ro loglevel=4
}
EOF
 
Old 09-04-2017, 03:08 PM   #4
jr_bob_dobbs
Member
 
Registered: Mar 2009
Distribution: Linux From Scratch, Bedrock
Posts: 299
Blog Entries: 43

Original Poster
Rep: Reputation: 12
I read the first reply, then followed the links and then read some man pages. I came up with a new /etc/sysctl.conf file that looked like this:
Code:
# Created by me, not mentioned in the standard [B]LFS book(s).  Our goal is to 
# get it to stop usb and ilwwifi messages from going to the console.  To logs 
# is ok

# four columns
# * CUR = current severity level; only messages more important than this level
#   are printed
# * DEF = default severity level assigned to messages with no level
# * MIN = minimum allowable CUR
# * BTDEF = boot-time default CUR

# possible values for each column
# 0 - emergency
# 1 - alert
# 2 - critical
# 3 - error
# 4 - warning
# 5 - notice
# 6 - informational
# 7 - debug This is too noisy

kernel.printk = 4	4	1	4
Rebooted. That worked, yay.

I came to post here... and then saw the second reply. Wow: one parameter passed to the kernel is much simpler.

Thank you both for the replies.
 
Old 09-05-2017, 06:43 PM   #5
Luridis
Member
 
Registered: Mar 2014
Location: Texas
Distribution: LFS 8.0 Custom, Merged Usr, Linux 4.9.35
Posts: 488

Rep: Reputation: 121Reputation: 121
Yea, it will work from there too. However, if you want the early printk messages to be reduced, before the rootfs is loaded to produce less output, you need to put it on the kernel command line.

The same post-boot file to edit for systemd users is /etc/systemd/system.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ftp command does not recognise verbosity tonj Linux - Newbie 4 07-29-2014 04:29 AM
no verbosity from rsync tonj Linux - Software 5 02-05-2014 09:31 PM
rsync 3 verbosity guyboisvert Linux - Software 2 06-01-2012 10:26 AM
Changing X verbosity level atunguyd Linux - Newbie 3 07-24-2008 02:28 AM
no verbosity with boot after 2.6 upgrade fincher69 Slackware 2 09-11-2006 12:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 08:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration