LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 08-29-2011, 10:30 PM   #1
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Rep: Reputation: Disabled
Need Haelp


When I am recovering my password through singel user mode booting, I m getting the prompt as:-

[root@localhost].. and when I type passwd there, it doesn't prompts me for new password... rather it agin gives the same prompt as [root@localhost]???



What do I do now??? Plz help!!
 
Old 08-29-2011, 11:03 PM   #2
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
What OS / version?
 
Old 08-30-2011, 01:57 AM   #3
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled
Redhat 6.0
 
Old 08-30-2011, 11:34 AM   #4
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Quote:
Originally Posted by guptaaditya24@gmail.com View Post
Redhat 6.0
Did you try to use this command?

Code:
[root@localhost]# passwd root
 
Old 08-30-2011, 12:01 PM   #5
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled
yes frnd I did try!!! no use .. no prompt!!!
 
0 members found this post helpful.
Old 08-30-2011, 12:12 PM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,641

Rep: Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898
Quote:
Originally Posted by guptaaditya24@gmail.com View Post
yes frnd I did try!!! no use .. no prompt!!!
Spell your words out.

It says you're already logged in as root...try just typing in "passwd", and see if it works then. If not, you can always edit the /etc/shadow file manually. You should see a line like "root:<some string here>:1388::::::". Remove everything between the first colon ":" and the second...that's your encrypted password. Next time you log in, you won't have a password, but will have to set one.
 
Old 08-30-2011, 12:17 PM   #7
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled
But Sir, I want to learn password recovery thats Y I m asking the problem.. I know the password this tym, But what about when I will appear for RHCE exam.. I will be asked to Recover Roots password Buddy.. So for that situation I m learning, the trap, I m fussed into!!!!

Plz help// Ok..
Tell me, dis.. I read smwhere that when we enter init boot after pressing b at the last step, I shud get prompt smthing like "sshs#" or smthing like thaT.. If its ryt, than Y M I getting the prompt, as I told u : "[root@localhost]#"
Any help Plz....
 
0 members found this post helpful.
Old 08-30-2011, 12:29 PM   #8
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,978
Blog Entries: 1

Rep: Reputation: 209Reputation: 209Reputation: 209
Quote:
Originally Posted by guptaaditya24@gmail.com View Post
yes frnd I did try!!! no use .. no prompt!!!
You can boot into the rescue mode to change the passowrd via the DVD
 
1 members found this post helpful.
Old 08-30-2011, 12:32 PM   #9
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled
My purpose n query not solved.. I told U, learning for RHCE.. so DVD usage not allowed, to recover password in dat xm!!!!
 
0 members found this post helpful.
Old 08-30-2011, 12:38 PM   #10
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Quote:
Originally Posted by guptaaditya24@gmail.com
I know the password this tym, But what about when I will appear for RHCE exam.. I will be asked to Recover Roots password Buddy..
http://www.redhat.com/certification/rhce/objectives/

Odd. I don't see "reverse cryptographic digest" anywhere on the exam objectives.
 
1 members found this post helpful.
Old 08-30-2011, 12:40 PM   #11
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,641

Rep: Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898
Quote:
Originally Posted by guptaaditya24@gmail.com View Post
But Sir, I want to learn password recovery thats Y I m asking the problem.. I know the password this tym, But what about when I will appear for RHCE exam.. I will be asked to Recover Roots password Buddy.. So for that situation I m learning, the trap, I m fussed into!!!!

Plz help// Ok..
Tell me, dis.. I read smwhere that when we enter init boot after pressing b at the last step, I shud get prompt smthing like "sshs#" or smthing like thaT.. If its ryt, than Y M I getting the prompt, as I told u : "[root@localhost]#"
Any help Plz....
One more time, SPELL YOUR WORDS OUT, that text-speak garbage isn't pleasant for anyone.

Again, have you tried just typing in "passwd"? And if you don't know the root password and you have to recover it, you either boot to single user mode and edit the shadow file as I ALREADY TOLD YOU, or you boot via DVD, and do it that way. You are getting the root prompt because you're ALREADY LOGGED IN AS ROOT. So, again, type "passwd" (not "passwd root"), and try it.

Last edited by TB0ne; 08-30-2011 at 12:44 PM.
 
Old 08-30-2011, 12:46 PM   #12
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled
Nothing Lyk dat Sir... I already thanked u for replying but was just asking what cud I do in dat case!!! Its not like dat, I didn't like ur answer!! Infact there's evrytym newthings, I gotta learn from nebody's reply.. Thnx , but need more help from u!!! If possible for u
 
0 members found this post helpful.
Old 08-30-2011, 01:11 PM   #13
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,641

Rep: Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898
Quote:
Originally Posted by guptaaditya24@gmail.com View Post
Nothing Lyk dat Sir... I already thanked u for replying but was just asking what cud I do in dat case!!! Its not like dat, I didn't like ur answer!! Infact there's evrytym newthings, I gotta learn from nebody's reply.. Thnx , but need more help from u!!! If possible for u
Since you appear to be a slow learner: SPELL OUT YOUR WORDS. Text-speak junk will get you nowhere fast.

You've been given the answer several times...how many more times do you need to be given the answers?
 
Old 08-30-2011, 01:30 PM   #14
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled
Sir Again I m in a trap.. I tried ur method.. I opened up /etc/shadow file, using vim command.. and then I removed the encrypted password as u said.. but it says that

"Can't write viminfo file $HOME/. viminfo! "


What to do???? Plz help
 
0 members found this post helpful.
Old 08-30-2011, 02:14 PM   #15
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,641

Rep: Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898
Quote:
Originally Posted by guptaaditya24@gmail.com View Post
Sir Again I m in a trap.. I tried ur method.. I opened up /etc/shadow file, using vim command.. and then I removed the encrypted password as u said.. but it says that

"Can't write viminfo file $HOME/. viminfo! "
What to do???? Plz help
Pay attention: SPELL OUT YOUR WORDS AND QUIT USING TEXT SPEAK GARBAGE. Understand that?? It's "your" not "ur", "please" not "plz". How many times do people need to tell you things????

We'll go through this again from step one. PAY ATTENTION and ANSWER QUESTIONS
  • Have you tried just typing in "passwd", by itself?
  • Have you tried typing in "/usr/bin/passwd root"?
  • Have you booted from CD/DVD?
  • After you got the message from VI, did the shadow file actually save? Have you looked??
If you're going for an RHCE....don't, until you learn to pay attention, follow instructions, and THINK about what you're doing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 10:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration