LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 08-30-2011, 03:01 PM   #16
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled

OK Sir, I got you now!!!

yeah,
1. I tried typing in "passwd" but failed!!
2. I tried typing in "/usr/bin/passwd root", but I failed!!!!
3. It is not A\allowing me to save that file or write that file instead!!!


whatta do?
 
Old 08-30-2011, 03:28 PM   #17
pix9
Member
 
Registered: Jan 2010
Location: Mumbai, India
Distribution: ArchLinux, Fedora 24, Centos 7.0
Posts: 177

Rep: Reputation: 19
well, post creator, very first thing please give appropriate title for your posts like "unable to recover password(rhel6.0)" which can help readers to understand nature of your problem. Second thing Please try to provide more details, like operations system vendor version etc. Nobody can help you without complete information. Solution for your problem is to disable selinux before you change your root password, use this command when you switch over to single user mode # setenforce 0 only after this you can reset your root password in rhel6.

Thank you
Pushkar

Last edited by pix9; 08-30-2011 at 03:40 PM. Reason: typo
 
Old 08-30-2011, 04:34 PM   #18
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,641

Rep: Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898Reputation: 6898
Quote:
Originally Posted by guptaaditya24@gmail.com View Post
OK Sir, I got you now!!!

yeah,
1. I tried typing in "passwd" but failed!!
2. I tried typing in "/usr/bin/passwd root", but I failed!!!!
3. It is not A\allowing me to save that file or write that file instead!!!
whatta do?
Again, spell out your words...."whatta do"...really??

And saying "but failed!" tells us NOTHING. WHAT HAPPENED? What did the screen say? What were the results?? Again, you need to either boot from CD/DVD, and reset the password from there, or you need to boot to single-user mode by typing in an "S" in the Grub menu. If you're already in single-user mode, you reset the password from there.

And are you running a 'real' machine or a virtual machine? If it's virtual, then selinux will come into play.
 
Old 08-30-2011, 08:55 PM   #19
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 7.7 (?), Centos 8.1
Posts: 17,847

Rep: Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584
... and drop the exclamation marks; that's the equivalent of shouting.
 
Old 09-03-2011, 11:35 AM   #20
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled
OK SIR.

I will Keep all these Suggestions in Mind, while I make Posts later. This was the first post by me, so didn't know the rules to be followed .

And Thank you for the replies. I learnt a lot , and let me check if my problem gets solved by disabling Selinux
 
Old 09-03-2011, 11:45 AM   #21
guptaaditya24@gmail.com
LQ Newbie
 
Registered: Jul 2011
Location: Delhi
Posts: 22

Original Poster
Rep: Reputation: Disabled
Thank You Sir . You solved my problem. After I disabled Selinux, I could reset "root's" password by command "passwd root".

Thanks a tonne!!!
 
Old 09-07-2011, 02:37 AM   #22
chandhokshashank
LQ Newbie
 
Registered: Sep 2011
Posts: 20

Rep: Reputation: Disabled
This is a bug in SElinux policy version. You can still disable the SE Linux and try running the command. That will work.

Try running "setenforce 0"

or edit /etc/selinux/config

set "SELINUX=disabled" and reboot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 10:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration