LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 07-10-2004, 06:19 PM   #1
biblefreak
Member
 
Registered: Dec 2002
Location: West Texas
Distribution: Ubuntu Hardy
Posts: 44

Rep: Reputation: 15
Suse 9.1 Sound Issue


Problem with my sound. I can get it to work by changing the options of my sound card through Yast and diasbling the support for DXS Channels, then running alsaconf at the CLI as root. The problem is when I reboot my system, the sound stops working until I repeat the above process. Seems as though either something is not getting saved, or something at boot is not pointing at what was changed by "fixing" the sound the last time I was logged in.

I am using a VIA 8235 on-board soound on a Gigabyte MoBo.

Any ideas?
 
Old 07-10-2004, 07:22 PM   #2
Vlad-A
Member
 
Registered: May 2004
Location: Vienna, Austria
Distribution: Open SuSE 11, Mac OS X 10.5
Posts: 299

Rep: Reputation: 33
You may try following:
dxs support is disabled with the option dxs_support=2
Take a look on your /etc/modprobe.conf

look for an entry like snd_via82xx or snd-via82xx
If not thre you have to add in your /etc/modprobe.conf
options snd-via82xx dxs_support=2

If there make sure that dxs_support=2 is passed as parameter to the module.
Be aware that a # infront of the options keyword outcomments the line, means
the options line has no effect.
If you find an entry via82xx (so without leading snd- or snd_) then it's relted to the OSS
and not ALSA driver.

Just one remark: This helped to fix the sound problem on one Mobo.
There is absolutely no garantee that it will work in your case.

Last edited by Vlad-A; 07-10-2004 at 07:24 PM.
 
Old 07-10-2004, 08:05 PM   #3
biblefreak
Member
 
Registered: Dec 2002
Location: West Texas
Distribution: Ubuntu Hardy
Posts: 44

Original Poster
Rep: Reputation: 15
It doesn't seem to be there. Do I just put the string you mentioned at the bottom of the modprobe.comf file or is there a certain place it needs to go?

Thanks.

re-edited to add:

been playing around and searching for answers.

added the line you mentioned to the etc/modprobe.conf

options snd-via82xx dxs_support=2

but didn't work, so changed the - to a _ so it looks like

options snd_via82xx dxs_support=2

plus added the same line to etc/modprobe.conf local

and uninstalled the kde multimedia mixer as per a suggestion on another post.

Rebooted, and the sound works great so far!!

Thanks for all the help.



Last edited by biblefreak; 07-10-2004 at 08:56 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Issue, SuSE 9.3 IBM Thinkpad Toolbox Linux - Hardware 9 10-08-2005 12:54 AM
SuSE 9.2 Sound issue newtwolinux Linux - Newbie 1 05-06-2005 02:10 PM
sound issue suse 9.1 escopf SUSE / openSUSE 0 02-10-2005 04:35 PM
Suse 9.0 Sound issue fix! Caeda Linux - Laptop and Netbook 11 01-19-2004 09:20 AM
sound issue zetox Slackware 4 08-12-2003 06:59 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 06:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration