LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 08-23-2019, 08:58 PM   #1
Crippled
Member
 
Registered: Sep 2015
Distribution: Xubuntu 18.04LTS
Posts: 327

Rep: Reputation: Disabled
No login dailog box and no password


I have SparkyLinux 5.8 (64-bit) installed. There is no login dialog box and no password is ever asked on boot up even though there are countless video reviews of SparkyLinux 5.8 that shows a login dialog box and password being asked. I am using the Xfce desktop envirorment. I didn't select auto login. I asked on the SparkyLinux forums but I have received no replies on this issue as of yet. Does anyone know how to get the login dialog box working?
 
Old 08-23-2019, 09:04 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 15,330
Blog Entries: 25

Rep: Reputation: 4391Reputation: 4391Reputation: 4391Reputation: 4391Reputation: 4391Reputation: 4391Reputation: 4391Reputation: 4391Reputation: 4391Reputation: 4391Reputation: 4391
You have told us what you do not see when you boot the computer. What do you see? In other words, since you do not boot to a graphical display manager (GDM) with a login dialog, what do you boot to?
 
Old 08-23-2019, 09:13 PM   #3
permaroot
Member
 
Registered: Aug 2019
Location: Arden, NC
Distribution: Manjaro, Centos7, Arch
Posts: 105

Rep: Reputation: 46
Quote:
Originally Posted by Crippled View Post
I have SparkyLinux 5.8 (64-bit) installed. There is no login dialog box and no password is ever asked on boot up even though there are countless video reviews of SparkyLinux 5.8 that shows a login dialog box and password being asked. I am using the Xfce desktop envirorment. I didn't select auto login. I asked on the SparkyLinux forums but I have received no replies on this issue as of yet. Does anyone know how to get the login dialog box working?
If itís automatically logging in I promise you can google ďdisable automatic login sparkylinux or Ubuntu ď , since Itís based in Ubuntu.

https://vitux.com/how-to-enable-disa...ntu-18-04-lts/

If auto login isnít what happens when you log in, we need more info.

Also tell us what, if anything, you have tried that didnít work.

Cheers!
 
Old 08-23-2019, 09:19 PM   #4
Crippled
Member
 
Registered: Sep 2015
Distribution: Xubuntu 18.04LTS
Posts: 327

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frankbell View Post
You have told us what you do not see when you boot the computer. What do you see? In other words, since you do not boot to a graphical display manager (GDM) with a login dialog, what do you boot to?
It boots through the G.U.I. to the desktop. But it never asks me for a password since login dialog box never apears.
 
Old 08-23-2019, 09:31 PM   #5
permaroot
Member
 
Registered: Aug 2019
Location: Arden, NC
Distribution: Manjaro, Centos7, Arch
Posts: 105

Rep: Reputation: 46
Quote:
Originally Posted by Crippled View Post
It boots through the G.U.I. to the desktop. But it never asks me for a password since login dialog box never apears.
See link above.
 
Old 08-23-2019, 10:15 PM   #6
Crippled
Member
 
Registered: Sep 2015
Distribution: Xubuntu 18.04LTS
Posts: 327

Original Poster
Rep: Reputation: Disabled
Looks like this one has everyone stumped. Some movement on the SparkyLinux forum that ened up into a dead stop. I was advised to "Have a look in /etc/lightdm/lightdm.conf under [Seat;*] for autologin-user=

If it is uncommented (missing the #) then that is what the installer has set. - If you have already set a password, you might be safe to comment that line again to ignore autologin." Sorry for not putting in between code because there was no selection to do so. I set a password. This is what I found which I can't make any sense of this.
Quote:
[Seat:*]
#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# lock-memory = True to prevent memory from being paged to disk
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# logind-check-graphical = True to on start seats that are marked as graphical by logind
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# sessions-directory = Directory to find sessions
# remote-sessions-directory = Directory to find remote sessions
# greeters-directory = Directory to find greeters
# backup-logs = True to move add a .old suffix to old log files when opening new ones
# dbus-service = True if LightDM provides a D-Bus service to control it
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7
#lock-memory=true
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#logind-check-graphical=false
#log-directory=/var/log/lightdm
#run-directory=/var/run/lightdm
#cache-directory=/var/cache/lightdm
#sessions-directory=/usr/share/lightdm/sessions:/usr/share/xsessions:/usr/share/wayland-sessions
#remote-sessions-directory=/usr/share/lightdm/remote-sessions
#greeters-directory=$XDG_DATA_DIRS/lightdm/greeters:$XDG_DATA_DIRS/xgreeters
#backup-logs=true
#dbus-service=true

#
# Seat configuration
#
# Seat configuration is matched against the seat name glob in the section, for example:
# [Seat:*] matches all seats and is applied first.
# [Seat:seat0] matches the seat named "seat0".
# [Seat:seat-thin-client*] matches all seats that have names that start with "seat-thin-client".
#
# type = Seat type (local, xremote, unity)
# pam-service = PAM service to use for login
# pam-autologin-service = PAM service to use for autologin
# pam-greeter-service = PAM service to use for greeters
# xserver-backend = X backend to use (mir)
# xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
# xmir-command = Xmir server command to run (can also contain arguments e.g. Xmir -special-option)
# xserver-config = Config file to pass to X server
# xserver-layout = Layout to pass to X server
# xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
# xserver-share = True if the X server is shared for both greeter and session
# xserver-hostname = Hostname of X server (only for type=xremote)
# xserver-display-number = Display number of X server (only for type=xremote)
# xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# unity-compositor-command = Unity compositor command to run (can also contain arguments e.g. unity-system-compositor -special-option)
# unity-compositor-timeout = Number of seconds to wait for compositor to start
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# greeter-allow-guest = True if the greeter should show a guest login option
# greeter-show-manual-login = True if the greeter should offer a manual login option
# greeter-show-remote-login = True if the greeter should offer a remote login option
# user-session = Session to load for users
# allow-user-switching = True if allowed to switch users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# greeter-wrapper = Wrapper script to run greeter with
# guest-wrapper = Wrapper script to run guest sessions with
# display-setup-script = Script to run when starting a greeter session (runs as root)
# display-stopped-script = Script to run after stopping the display server (runs as root)
# greeter-setup-script = Script to run when starting a greeter (runs as root)
# session-setup-script = Script to run when starting a user session (runs as root)
# session-cleanup-script = Script to run when quitting a user session (runs as root)
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
# autologin-in-background = True if autologin session should not be immediately activated
# exit-on-failure = True if the daemon should exit if this seat fails
#
[Seat:*]
#type=local
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-backend=
#xserver-command=X
#xmir-command=Xmir
#xserver-config=
#xserver-layout=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#unity-compositor-command=unity-system-compositor
#unity-compositor-timeout=60
greeter-session=lightdm-greeter
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
user-session=xfce
#allow-user-switching=true
#allow-guest=true
#guest-session=
#session-wrapper=lightdm-session
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
autologin-user=mauser
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# listen-address = Host/address to listen for XDMCP connections (use all addresses if not present)
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
# hostname = Hostname to report to XDMCP clients (defaults to system hostname if unset)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn. Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#listen-address=
#key=
#hostname=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# command = Command to run Xvnc server with
# port = TCP/IP port to listen for connections on
# listen-address = Host/address to listen for VNC connections (use all addresses if not present)
# width = Width of display to use
# height = Height of display to use
# depth = Color depth of display to use
#
[VNCServer]

Last edited by Crippled; 08-23-2019 at 10:17 PM.
 
Old 08-23-2019, 10:42 PM   #7
permaroot
Member
 
Registered: Aug 2019
Location: Arden, NC
Distribution: Manjaro, Centos7, Arch
Posts: 105

Rep: Reputation: 46
Is there not a GUI setting menu with an auto-login option?
 
Old 08-24-2019, 12:44 AM   #8
Crippled
Member
 
Registered: Sep 2015
Distribution: Xubuntu 18.04LTS
Posts: 327

Original Poster
Rep: Reputation: Disabled
Thank you "frankbell" for trying to help. I found the solution on the SparkyLinux forum from "21grams" and some figuring out myself. The line where it says "autologin-user=mauser" needed to be changed to "#autologin-user=mauser" Just changing it as root didn't work because it would revert back to it's originonal settings. It was opening with LibreOffice by defualt. Then I remember reading something about text editors. I used Mousepad to edit it and saved it. This time when I rebooted it worked as it should of from the begining which it origonally didn't.
 
Old 08-24-2019, 12:50 AM   #9
permaroot
Member
 
Registered: Aug 2019
Location: Arden, NC
Distribution: Manjaro, Centos7, Arch
Posts: 105

Rep: Reputation: 46
Quote:
Originally Posted by Crippled View Post
Thank you "frankbell" for trying to help. I found the solution on the SparkyLinux forum from "21grams" and some figuring out myself. The line where it says "autologin-user=mauser" needed to be changed to "#autologin-user=mauser" Just changing it as root didn't work because it would revert back to it's originonal settings. It was opening with LibreOffice by defualt. Then I remember reading something about text editors. I used Mousepad to edit it and saved it. This time when I rebooted it worked as it should of from the begining which it origonally didn't.
It might be beneficial to learn to edit config files with the command line via a text editor like nano, vim, gvim etc.

Find the one you like and add export EDITOR=vim to .bashrc (replacing vim with the editor you want)

This should resolve permission issues such as libre office not being able to write to config files.

Last edited by permaroot; 08-24-2019 at 01:15 AM.
 
  


Reply

Tags
login dialog box, login password, sparkylinux, xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] After 10 installation, login screen password fails. (rootuser works though) (login screen is not username password) studpenguin Debian 8 08-18-2019 12:32 PM
Unable to find Administrators password does not recognize my login password the only password I entered at setup of Linux scholarsgold Linux - Newbie 6 01-23-2018 03:58 PM
My raspbian box have to ping other box first then other host can see my box jtingkir Linux - Networking 10 08-09-2013 07:53 AM
How to set login and password and root password in suse 10.2 sirius57 SUSE / openSUSE 8 07-24-2007 09:51 AM
Password Message Box when accessing linux box from Window Machine mikeccs Linux - Networking 1 08-04-2004 05:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 05:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration