LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 08-24-2014, 09:40 PM   #1
Siljrath
Bedrock Linux Advocate
 
Registered: Nov 2004
Location: the internet
Distribution: server:Gentoo | workstation:Bedrock (hijacked:void, fetched:Gentoo devuanstable;testing;ceres arch )
Posts: 207

Rep: Reputation: 64
bedrock not using brsh.conf, dropped to bedrock's /bin/sh


[edit][solved] spoiler (to spare you the boring details) ~ dont run brp with your clients disabled/down. if you do, no biggie, just enable/up your clients and re-run brp, and all is well again.[/solved][/edit]


bedrock linux 1.0alpha4 flopsie

clients:
arch
sid
gentoo



expected:
when i log in, i get my bash prompt telling me i'm using gentoo's bash.

what i get instead:
when i log in, i get an error message saying:
Code:
Error: brsh can not find shell specified in ~/.brsh.conf, defaulting to /bin/sh

a quick check with brw confirms that i am not just booted out of gentoo's bash to gentoo's sh, but am in bedrock's sh.

the contents of ~/.brsh/conf has not changed, still saying
Code:
/bin/bash
so i am uncertain where else to look for what is causing this.

this came about from a failed attempt to install a new kernel, after disabling (down'ing) and re-enabling (re-up'ing) all clients. was working fine before that. not sure why it is now failing to launch /bin/bash from ~/.brsh.conf, since running /bin/bash (once in a client with bash, not in bedrock), works. or
Code:
brc sid bash
, though after doing so
Code:
echo $SHELL
tells me it's still /bin/sh.

so... why is bedrock not picking up ~/.brsh.conf's /bin/bash, and redirecting me to the bedrock client and sh?
is there something stopping me from logging in to a client in the first place, and so it's looking in bedrock client for ~/.brsh.conf?

same situation and error message happens once in Xwindow.

i'm outta ideas. i dont know what i could have changed when attempting the new kernel install to have caused this.
this same behaviour is continued once in X running terms.

---
additional info:
when creating a new window in tmux, i got a few more lines of output than i did from logging into tty:
Code:
-sh: 2: /home/digit/.bashrc: source: not found
-sh: 39: /home/digit/.bashrc: shopt: not found
-sh: 45: /home/digit/.bashrc: shopt: not found
-sh: 130: /home/digit/.bashrc: shopt: not found
-sh: 136: /home/digit/.bashrc: shopt: not found
-sh: 717: /home/digit/.bashrc: Syntax error: "(" unexpected
also, even though my $PATH shows up correctly (with bedrock locations at start and end), attempting to launch firefox (installed in gentoo) from sid's bash failed
Code:
bash: firefox: command not found
, requiring to be launched specifying "brc gentoo" at the start. :/ idk if this is indicative of / related to the same problem or if i have other things broken too, but added here just incase.

ps, oh! i got curious to remind myself what brp was, and ran it once thinking it would output help like some of the other bedrock commands. is that it? is that what's messed this up?

Last edited by Siljrath; 08-25-2014 at 05:41 AM. Reason: additional info, and a PS on 2nd edit. solved-spoiler on 3rd edit.
 
Old 08-25-2014, 05:32 AM   #2
Siljrath
Bedrock Linux Advocate
 
Registered: Nov 2004
Location: the internet
Distribution: server:Gentoo | workstation:Bedrock (hijacked:void, fetched:Gentoo devuanstable;testing;ceres arch )
Posts: 207

Original Poster
Rep: Reputation: 64
okies...

was about to run off and try the /etc/passwd alternative method to brp. luckily, i did a little further investigating before going down that brain bending road.

so..

as best i can make sense of this...
it seems like i must have had my accidental run of brp when clients were disabled.

i looked in /bedrock/brpath/bin, and it didnt even contain enough executables to fill the screen. that was the clue.

so, i jumped back into root with a su -l ( after re-checking my clients were up with bri -l ), re-ran brp, and they're all there.

^_^ i knew it had to be something simple. (ok, i didnt, i was freaking out.)

[s]~still theory, but one i'm confident in... i'll be back to mark "[SOLVED]" (i hope.)[/s] is [solved]

Last edited by Siljrath; 08-25-2014 at 05:47 AM. Reason: typo + solved
 
Old 08-25-2014, 05:47 AM   #3
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 18,916

Rep: Reputation: 3249Reputation: 3249Reputation: 3249Reputation: 3249Reputation: 3249Reputation: 3249Reputation: 3249Reputation: 3249Reputation: 3249Reputation: 3249Reputation: 3249
Didn't even know of bedrock - maybe should put aside some time for a buid.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] No audio for user in bedrock with sid & gentoo Siljrath Linux - Desktop 1 06-16-2014 01:44 PM
LXer: Google-Bedrock-Red Hat Indulge in Mud-Slinging Now LXer Syndicated Linux News 0 04-23-2011 01:40 PM
I can't find the CGI-BIN directory and http.conf file is blank Dapernia Linux - Software 1 10-02-2007 10:52 PM
I can't find the CGI-BIN directory and http.conf file is blank Dapernia Programming 1 10-01-2007 02:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 03:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration