LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-22-2004, 03:10 PM   #1
jayrusso
LQ Newbie
 
Registered: Nov 2004
Location: NJIT
Posts: 14

Rep: Reputation: 0
FC3 and CPU speed


Hello,
I just purchased my new laptop and decided to load up linux. (I'm still kinda newbish so bare with me)
my specs are as follows:
Compaq r3000z
A64 3400+
1 gig ram
80 gig 5400
64mb nvidia 440
8x dvd burner
15.4 wsga+ (1680x1050)
broadcom 802.11g & bluetooth
I've recently installed FC3 and got pretty much everything configured the way I wanted.
After some tinkering I got the video drivers working properly at the correct resolution, used the ndis wrapper for the wireless and made the touchpad work.
Now while I was playing with my new toy, I installed gkrellm with the cpu speed plugin and noticed the processor speed was 797 Mhz. I figured It was doing that power now stuff and lowing the processor speed just like in windows but when I stress the cpu, the speed does not increase.
So I started searching, I found that there should be a program called cpuspeed that controls the stepping but when I do a ps -A as root, there is not process which is even close to this.
Does anyone know why my cpu isnt at full power and what I can do to make it speed step properly?
I'm Loving this OS but It sux cause I want my full cpu power when I need it.
any input would be appreciated.
thanks
jay
 
Old 11-22-2004, 03:50 PM   #2
The_JinJ
Member
 
Registered: Apr 2004
Location: Scotland
Distribution: Suse, OpenWRT
Posts: 299

Rep: Reputation: 30
Re: FC3 and CPU speed

Quote:
Originally posted by jayrusso
Hello,
I just purchased my new laptop and decided to load up linux. (I'm still kinda newbish so bare with me)
my specs are as follows:
Compaq r3000z
A64 3400+
1 gig ram
80 gig 5400
64mb nvidia 440
8x dvd burner
15.4 wsga+ (1680x1050)
broadcom 802.11g & bluetooth
I've recently installed FC3 and got pretty much everything configured the way I wanted.
After some tinkering I got the video drivers working properly at the correct resolution, used the ndis wrapper for the wireless and made the touchpad work.
Now while I was playing with my new toy, I installed gkrellm with the cpu speed plugin and noticed the processor speed was 797 Mhz. I figured It was doing that power now stuff and lowing the processor speed just like in windows but when I stress the cpu, the speed does not increase.
So I started searching, I found that there should be a program called cpuspeed that controls the stepping but when I do a ps -A as root, there is not process which is even close to this.
Does anyone know why my cpu isnt at full power and what I can do to make it speed step properly?
I'm Loving this OS but It sux cause I want my full cpu power when I need it.
any input would be appreciated.
thanks
jay
Try -

#cat/proc/cpu

This should show the cpu speed. The 3400+ will have a real clock speed of 2x00 as it's a 3400+ is a performance indicator (although slower will be equivalent to a 3400)
794 is way to low though - is there a specific driver for Xp cpus loaded in /etc/cpuspeed.conf?

Found a few links that may interest - just be careful
http://www.cs.ucl.ac.uk/staff/s.zachariadis/x31.html
http://www.deater.net/john/powernowd.html


Last edited by The_JinJ; 11-22-2004 at 04:00 PM.
 
Old 11-22-2004, 06:59 PM   #3
jayrusso
LQ Newbie
 
Registered: Nov 2004
Location: NJIT
Posts: 14

Original Poster
Rep: Reputation: 0
yea, I am aware that it is not 3400 mhz (its 2.2 ghz)
when I do a $ less /proc/cpuinfo , it tells me the right info.....except the cpu speed. it says 797 mhz.
I went to the system settings > server settings > services utility and saw that cpuspeed was checked off to run but the service was stopped. If I go to start it, it says its started properly but to then must quit right after because upon a refresh, it is stopped again.
If I look at the cpuspeed.conf in /etc/ it says the following

VMAJOR=1
VMINOR=1
OPTS="-i 2"
#DRIVER="powernow-k7"
#OPTS="-a /proc/acpi/ac_adapter/*/state -t /proc/acpi/thermal_zone/*/temperature 75"

I tried changing it to powernow-k8 thinking that may be the problem but no go.

I'm stumped........ if cpuspeed isnt working correctly, it should be stuck at full speed, not 797mhz.
any other ideas?
thanks
jay
 
Old 11-23-2004, 12:02 AM   #4
jayrusso
LQ Newbie
 
Registered: Nov 2004
Location: NJIT
Posts: 14

Original Poster
Rep: Reputation: 0
ok.... i got desperate so I just reinstalled and still no go.
It seems to be stuck at 797 mhz even when I run a folding@home console.
heres my cpuinfo.

processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 4
model name : AMD Athlon(tm) 64 Processor 3400+
stepping : 10
cpu MHz : 797.944
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush mmx fxsr sse sse2 syscall nx mmxext lm 3dnowext 3dnow
bogomips : 1576.96

I'm stumped. any suggestions?
 
Old 11-23-2004, 10:36 AM   #5
jayrusso
LQ Newbie
 
Registered: Nov 2004
Location: NJIT
Posts: 14

Original Poster
Rep: Reputation: 0
ok,
After some more debugging I'm still confused.
I d'loaded phlak and ran a live install on my laptop and that seem to say the same thing; 797mhz which doesnt change.
So now I thought there was something wrong...... so I booted into windows (dual boot) and windows says 797mhz but..... whenever the system is stressed; it bumps up to 2.2ghz.
Now i'm thinking that this loptop may default to 800mhz and speedstep in hardware? is that possible? any other ideas?
thanks
jay
 
Old 11-23-2004, 07:36 PM   #6
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Just an idea: Did you try disabling the speed control daemon?
# /etc/init.d/cpuspeed stop
 
Old 11-24-2004, 09:12 AM   #7
jayrusso
LQ Newbie
 
Registered: Nov 2004
Location: NJIT
Posts: 14

Original Poster
Rep: Reputation: 0
ok.... I got it working .....kinda
Last night I looked at my cpuspeed.conf again and noticed that the module line was commented out (doh!)
so I un-commented it then tried to start the daemon.
I got a module not found error. Then I switched to the powernow-k8 and tried it again. It seemed to work but only for a few mins then it wouldnt scale.
Finally I disabled all the acpi features in Klaptop and it scales normally now........ almost.
when the laptop is plugged in; it will scale from 800 > 1800 > 2200 ..........great.
but when the laptop is on battery; it will only scale from 800 > 1800.......... no 2200.
This isnt a huge deal but I got this far, I might as well get it fully working.
so.......
does anyone have a fix for this?
thanks
jay
 
Old 02-26-2005, 03:18 PM   #8
integr8er
LQ Newbie
 
Registered: Mar 2004
Location: Milwaukee, Wi. USA
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
Hi,

I have a HPz5000z laptop and have noticed the same problem.
I have slightly modified the /etc/cpuspeed.conf file to look like the following and it has resulted in the speed scaling within a few seconds of busy activity up to 2393.889. Upon becomming idle, the speed scales back to low speed of 797.963. Your original email thread here has helped me out on this matter and here is what I did and so far - I'm happy now. I figured that the default of -i 2 would lead to a more responsive scaling (seems that it says 1/10 seconds intervals, but I was seeing ~20 seconds before it adjusted itself - not intuitive) and the other parameters work. Well, did not check the temp as working, but did test pull the power plug and it did scale back. Oh, but even sending signal to cpuspeed SIGUSR1 to force full speed, with plug pulled, it still slowed to 797. Put the plug back in and the speed up again to max. Well, if anything, this confirms your findings but does still leave a dangling question about an easy and automatic way to still get more speed out of the machine even if under battery alone. But then again, off battery mode low speed is probably the priority in the cpuspeed program. Lastly, if you remove the -a argument from the conf file, without the ac power, it scales back to 1994.907. Plugging in ac again it stays at 1994 (and not back up to 2400), until I let the cpu get idle and then it scales back to 2400 upon busy cpu as expected... Thus, it seems a tad quirky, but I'm happy with it.

kas

VMAJOR=1
VMINOR=1
#OPTS="-i 2"
DRIVER="powernow-k8"
OPTS="-i 2 -a /proc/acpi/ac_adapter/*/state -t /proc/acpi/thermal_zone/*/temperature 75"
 
Old 03-06-2005, 01:04 AM   #9
integr8er
LQ Newbie
 
Registered: Mar 2004
Location: Milwaukee, Wi. USA
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
Hi All,

I'm still running my setup as I had already posted and I see in the gkrellum monitor that my cpu speed is scaling up and down just as I would like it. THe 2 second wait time in the /etc/cpuspeed.conf file works well. Just adding confirmation that it still works.
 
Old 03-23-2005, 09:01 AM   #10
javb
Member
 
Registered: Dec 2004
Posts: 83

Rep: Reputation: 15
i have the same laptop, and the same problem, im using SuSe 9.2 AMD64, but i CANT find /etc/cpuspeed.conf.... where can i find the equivaLENT file?
 
Old 03-24-2005, 10:07 PM   #11
integr8er
LQ Newbie
 
Registered: Mar 2004
Location: Milwaukee, Wi. USA
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
I am not sure how other distros manage cpu frequency. But as I looked around to try to find something to help you out with, I begin to wonder if a lot of folks do not even realize that this is occurring. Unless you look and find out if your speed is being scaled for you, you might have a big fast laptop that runs at its slowest speed all the time and you never really realize this!!!!!!! For example, before I knew about this speed scaling, I assumed that I was running full speed - NOT - the laptop by defaulkt runs at 800Mhz and is scaled up by the software. Any assumption that it runs at full speed and that the software scales it down when idle is exactly wrong (at least with this laptop model anyhow). I was initially playing Americas Army at 800Mhz and thought it was pretty good, but then found it was really great when I got the speed scaling working proper. Anyhow, try looking around at some of the following links... Good luck... You might post back here for the benefit of others...

http://www.linux-on-laptops.com/hp.html
http://www.fozzilinymoo.org/dispensation/zv5000z.html
http://cmb.phys.cwru.edu/kisner/linux/compaq-r3000/
http://www1.uop.edu/~khughes/presario-r3120us/
 
Old 03-26-2005, 01:41 PM   #12
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Rep: Reputation: 15
I had this same problem when I installed FC3 on my P3 M laptop on Monday. The major difference being that my laptop is now getting slower as time goes by. It's weird.

I just posted the new problem HERE.

My laptop has a 1133MHz CPU. It was running at 731 most of the time. After installing CPUFreq to adjust from the Gnome panel, I could change it to 1133. Now it's the same, but the speeds are ~350 and ~550 MHz, respectively.
 
Old 04-09-2005, 10:53 PM   #13
krymsunmortis
Member
 
Registered: Jan 2003
Location: Fort Worth Tx
Distribution: Slackware RedHat Mandrake BackTrack
Posts: 31

Rep: Reputation: 15
possible fix

ok I have a Compaq Presario R3000Z how ever it is identified as R3200 CTO cause I had my hardware tweaked a bit basically from what compaq tells me it is the same thing just how they identify the custom built machines.
I was having problems with my WLNIC it is the broadcom 4306. I installed the NDISWrapper and then modeprobe was hanging and it seems slow at that time but figured I would do one issue at a time. I ran the RHN Update in FC and after it updated I then ran it again to get the newer kernel 2.6.10-1.770_FC3.
then re installed the NDISWrapper and now my NIC works. so started checking into the reason my machine seemed slow b4 and have seem to notice in most cases every one comes back to the cpuinfo and cpuspeed.conf

since doing the updates ( including the kernel update) here are my outputs from #cat

[root@lappy ~]# less /proc/cpuinfo
processor : 0
vendor_id : AuthenticAMD
cpu family : 15
model : 4
model name : AMD Athlon(tm) 64 Processor 3700+
stepping : 10
cpu MHz : 1994.979
cache size : 1024 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush mmx fxsr sse sse2 pni syscall nx mmxext lm 3dnowext 3dnow
bogomips : 3948.54


[root@lappy ~]# cat /etc/cpuspeed.conf
VMAJOR=1
VMINOR=1
OPTS="-i 2"
#DRIVER="powernow-k7"
#OPTS="-a /proc/acpi/ac_adapter/*/state -t /proc/acpi/thermal_zone/*/temperature 75"

as side note I can now seem to run at a very nice speed for Gnome and KDE. have not checked XFCE yet but it is usually alot faster than either of those 2. So I am not sure if it is something that was in the updates or if it was fixed in the kernel, only because I am not going to reinstall since it aint broken however just to let you know i am also running on the basic i386 version not the i386_64. Also my clock in the task panel now seems to keep the right time also instead of running in mach speed.
 
Old 04-13-2005, 05:53 PM   #14
pld
Member
 
Registered: Jun 2003
Location: Southern US
Distribution: Ubuntu 5.10
Posts: 206

Rep: Reputation: 30
Just a quick thought, as I ran into some laptop display issues on an ibm t30: did you guys check your bios for controlling processor speed? I know I had some strange issues a while ago with a bios setting, no matter what I did in fc1 at the time...
 
Old 05-11-2005, 03:15 PM   #15
pppoe_dude
LQ Newbie
 
Registered: May 2005
Location: Canada
Distribution: Fedora Core
Posts: 7

Rep: Reputation: 0
Hi. i have a Compaq Presario R4025 (very similar to the R3000 series) with an AMD 64 2.0Ghz...
I have had this problem with windows ever since i got it and I'm now trying to figure it out on linux... but I am not worried anymore about a hardware issue.

At first, windows would show me the CPU speed to be either 498Mhz (too low) or 997 Mhz (still low) and never 2.0 Ghz. however, i downloaded a prog for windows called cpuspeed and It does an active test for the cpu... I got a 1800 Mhz reading then. so i'm not worried anymore, however, back at FutureShop, I tried out their display model and it did read 1.99Ghz in My computer. So i'm a bit confused, but still hoping for the best.

FC4 test 2 still shows me 997.15Mhz in /proc/cpu which worries me a bit... I'm stil trying stuff out
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Processor clock speed vs. CPU speed moxieman99 Linux - General 4 06-24-2005 11:43 AM
howto: control CPU fan speed and Northbridge fan speed? hedpe Linux - Software 2 04-18-2005 03:18 AM
P3 M Laptop Running FC3 - CPU Speed Problem jeffk42 Linux - Laptop and Netbook 10 04-05-2005 08:53 AM
FC3 Cpu speed error... BEYAZITTOSUN Fedora 1 02-20-2005 07:04 AM
please help guys, wrong cpu speed shown with a regular non-mobile cpu !! : ( maku Linux - Hardware 1 01-02-2005 03:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 04:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration