LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 03-26-2005, 10:56 AM   #1
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Rep: Reputation: 15
P3 M Laptop Running FC3 - CPU Speed Problem


I found another thread regarding a similar problem, but it didn't seem to help me.

I have a laptop running Fedora Core 3 on a Pentium III M 1133MHz. For some reason, I just noticed that the laptop is running slowly. After I first installed FC3, the CPU was constantly running at 731 MHz. After a change to /etc/cpuspeed.conf (and after installing the CPUFreq Gnome applet for monitoring purposes), I was able to maually change the CPU speed to 1133 through the applet pull-down menu. Sometimes it would change back, but no big deal. I checked /proc/cpuinfo, and the value changed to match the faster CPU speed, so all was good.

Now, I can still supposedly change the CPU speed from 731 to 1133 via the pull-down menu, but that doesn't seem to actually work.

First off (and this has been the case ever since I installed it), CPUFreq gives me this when it loads up:

Error: Can't change the CPU speed. The daemon in charge of changing the CPU speed is not started. Please do so if you want to change your CPU speed, and then click on the applet.

Which is weird since it looks like I can change it. That being said, when the CPU speed reads 731, doing a /proc/cpuinfo gives me the following:

Code:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 11
model name      : Intel(R) Pentium(R) III Mobile CPU      1133MHz
stepping        : 1
cpu MHz         : 360.563
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 704.99
If I select 1133 from the pulldown menu and view cpuinfo again:

Code:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 11
model name      : Intel(R) Pentium(R) III Mobile CPU      1133MHz
stepping        : 1
cpu MHz         : 557.234
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 1089.53
Here is the current /etc/cpuspeed.conf:

Code:
VMAJOR=1
VMINOR=1
#OPTS="-i 2"
#DRIVER="powernow-k7"
OPTS="-i 2 -a /proc/acpi/ac_adapter/*/state -t /proc/acpi/thermal_zone/*/temperature 75"
I've tried stopping cpuspeed, and that just locks it at the 557 MHz value.

All of this is happening when the laptop is plugged in, so technically it should be running at full speed.

Can anyone help me with this?

Thanks,
Jeff
 
Old 03-27-2005, 08:43 PM   #2
rovitotv
Member
 
Registered: Jan 2003
Location: Dayton, Ohio
Distribution: Slackware 10.2
Posts: 116

Rep: Reputation: 15
Jeff,
Please keep in mind that I know nothing about Fedora Core so my advice might be useless, I do however run CPUFreq on my P3 M. CPU Freq controls the speed of the CPU and it is a kernel level function. It is possible to run a program like CPU Speed to control the speed of the processor automaticlly. Personally I like to have control so I don't run any programs. I learned about CPU Freq in the documentation of the kernel. Download the kernel sources from www.kernel.org and read all the documentation in the Documentation/cpu-freq directory. You will find that it is very easy to control the speed of your processor with Linux. Good luck.

TVR
 
Old 03-28-2005, 07:39 AM   #3
jeffk42
Member
 
Registered: Mar 2005
Location: Orlando, FL USA
Distribution: Fedora Core 13 x86_64 / RHEL 5.3
Posts: 76

Original Poster
Rep: Reputation: 15
Okay, here's the latest....

After wrestling with this problem to no avail for the last few days, this morning I woke up, rebooted to a failsafe terminal, and get the same 558 MHz value from /proc/cpuinfo and dmesg. I shut down the machine and brought it to work, as usual.

I started it up at work and found this:

Code:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 11
model name      : Intel(R) Pentium(R) III Mobile CPU      1133MHz
stepping        : 1
cpu MHz         : 1129.531
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36 mmx fxsr sse
bogomips        : 2236.41
That is..... maddening. I don't know what to say. I guess I'll see what happens when I go back home.
 
Old 03-31-2005, 01:50 AM   #4
jwn7
Member
 
Registered: Aug 2004
Location: pittsburgh, pa
Distribution: gentoo
Posts: 81

Rep: Reputation: 15
well i was going to offer some advice until i saw your last post. that is just bizzare. jawa:

if something happens completely randomly like that, it would think it's a bug somewhere. what kernel are you running? did you build it or is it the stock fc3 kernel? how well does acpi work for you?

i would start by doing what was suggested in the previous post. go get the latest kernel and experiment with some different configuration values, especially in the power management section. you probably should try building in all acpi and cpufreq things (just for your processor of course).

i'm running the 2.6.11 kernel with a pentium M and cpufreq works fine. in power management > acpi, i have sleep states as yes, and the next 7 things as modules which get loaded. power management > apm is set to no. power management > cpufreq > cpu frequnecy translation statistics is a module (this isn't really needed for it to work), the three different govenors and table helpers thing are built in, acpi processor p states driver is a module, intel enhanced speed step is built in and everything else is left out.

good luck

Last edited by jwn7; 03-31-2005 at 01:55 AM.
 
Old 03-31-2005, 11:19 PM   #5
integr8er
LQ Newbie
 
Registered: Mar 2004
Location: Milwaukee, Wi. USA
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
I did not see a driver configured in your /etc/cpuspeed.conf file. The default seems to be that k7 one and for the amd64, its the k8, but what is it dor your cpu - I don;t know... Just a thought...
 
Old 04-04-2005, 02:24 PM   #6
michaelthoward
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
Same experience on FC3

I have just installed FC3 on a Dell Latitude D600.
When I cat /proc/cpuinfo it usually says 598 Mhz
However, it will occasionally say 1395 Mhz

Q: Is it possible that they are (correctly) auto-adjusting based upon cpu utilization?

Michael
 
Old 04-04-2005, 02:48 PM   #7
michaelthoward
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
cpuspeed higher

I am now performing a bunch of cpu-intensive operations and /proc/cpuinfo is no reporting 1594 Mhz ... the correct max number on this machine.

So my theory is that they are dynamically ... and correctly ... changing the cpu freq based upon load.
 
Old 04-04-2005, 03:33 PM   #8
bullium
Member
 
Registered: Aug 2003
Location: Ohio
Distribution: Ubuntu 12.04, Mint 13, RHES 5.5, RHES 6
Posts: 146

Rep: Reputation: 17
The speed could be changing depending on the power source, wall or battery. If it is trying to conserve battery life.
 
Old 04-04-2005, 03:36 PM   #9
michaelthoward
LQ Newbie
 
Registered: Nov 2004
Posts: 4

Rep: Reputation: 0
For these tests I have been plugged in all the time.
Yes, I agree that presumably they are downshifting the clock frequency to preserve battery life when not plugged in.
 
Old 04-04-2005, 03:39 PM   #10
bullium
Member
 
Registered: Aug 2003
Location: Ohio
Distribution: Ubuntu 12.04, Mint 13, RHES 5.5, RHES 6
Posts: 146

Rep: Reputation: 17
Ok, just was wondering whether it was plugged in for each test is all .
 
Old 04-05-2005, 07:53 AM   #11
integr8er
LQ Newbie
 
Registered: Mar 2004
Location: Milwaukee, Wi. USA
Distribution: Redhat 9
Posts: 12

Rep: Reputation: 0
I have been using gkrellm for monitoring and in another window, for testing purposes, I merely start a shell command that just does an infinite loop and echos the date to the screen. That generates enough cpu activity that the cpuspeed daemon kicks up the speed as needed. Yes, depending on your power status, the speed is affected. On my HP zv5000 laptop, if I unplug the power (seemingly regardless of the settings in the /etc/cpuspeed.conf file), the speed drops to a lower than max speed. Maybe this is some limit built in the bios or something.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrong CPU speed reported on old laptop johnandrews Linux - Laptop and Netbook 2 08-02-2005 11:31 AM
FC3 and CPU speed jayrusso Fedora 15 05-23-2005 12:09 AM
M5414 laptop running fc3 bluknight43 Linux - Hardware 1 05-11-2005 12:12 PM
CPU speed problem... BEYAZITTOSUN Linux - Laptop and Netbook 3 03-02-2005 12:47 PM
FC3 Cpu speed error... BEYAZITTOSUN Fedora 1 02-20-2005 06:04 AM


All times are GMT -5. The time now is 09:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration