LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 12-31-2005, 12:59 PM   #1
sterrenkijker
Member
 
Registered: Mar 2004
Location: the Netherlands
Distribution: Debian Sarge
Posts: 302

Rep: Reputation: 31
setting umask for all users and all sorts of logins


Hello everybody,

I want to change umask from 022 to 002 for all normal users, also for graphical logins, so when a user creates a directory in nautilus or with a program, the default permissions will be rwxrwxr-x. Does anybody know if there is a login script of configuration file to edit?

Greetings and happy newyear,

Corien
 
Old 12-31-2005, 02:08 PM   #2
Monkey 9
Member
 
Registered: Nov 2005
Location: The Netherlands.
Distribution: Debian-Sarge (2.4) / openSuSE 11.0.42 (Linux 2.6.25.9-3-default)/Knoppix 3.9 (2.6) /DSL 4.0.1 (2.4)
Posts: 138

Rep: Reputation: 15
I am sorry, I did read wrong.
you allready changed your etc/fstab, and you want users to have to use passwords?

Last edited by Monkey 9; 12-31-2005 at 02:11 PM.
 
Old 12-31-2005, 05:14 PM   #3
PDock
Member
 
Registered: Aug 2004
Distribution: Slack10 & curr. tried numerous
Posts: 189

Rep: Reputation: 37
Look at /etc/login.def near bottom (assuming used by debian as is in slackware)

ppd
 
Old 01-01-2006, 05:19 AM   #4
sterrenkijker
Member
 
Registered: Mar 2004
Location: the Netherlands
Distribution: Debian Sarge
Posts: 302

Original Poster
Rep: Reputation: 31
The problem has to do with sharing data: two of my users (marleen and heleanne) don't have any technical knowledge, but they are working on some project together. I added both of them to the "barbiecoro" group, and set SGID for the directory:
Quote:
chmod -R 2775 barbiecoro/
ls -l
drwxrwsr-x 6 marleen barbiecoro 4096 2005-12-31 18:53 barbiecoro
Now both users have acces to the directory barbiecoro. But when eg heleanne creates a new directory within this directory, and later marleen wants to create a file in the directory heleanne just created, marleen won't get permission. This is because the directory heleanne created has file permissions drwxr-sr-x, so the group barbiecoro does not have write permissions.

This directory resides on /dev/hda5: It is mounted in /etc/fstab like:
/dev/hda5 /mnt/data ext3 defaults 0 2

I changed this to
/dev/hda5 /mnt/data ext3 defaults,umask=002 0 2
(following the fstab hint), but like this hda5 fails to mount (unrecognised option)

setting UMASK=002 in /etc/login.defs doesn't seem to have any effect, even after rebooting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab, umask and users permissions foucault Linux - Security 3 11-03-2005 01:13 AM
nfs umask setting mvo Linux - Newbie 1 09-16-2005 09:52 PM
setting root's umask triley Linux - Security 3 08-05-2005 08:56 AM
umask setting Cort Linux - Newbie 2 09-28-2004 12:18 PM
umask setting?? TheRealDeal Linux - General 4 01-03-2004 02:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration