View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 05-18-2009, 05:54 AM   #1
LQ Guru
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,415

Rep: Reputation: Disabled
Angry Partial upgrade of KDE 3.5 to 4.2 (grrrrr) in Squeeze

Hi Debianers,
One of my few complaints about Debian is how packages get into testing. This morning I did my normal upgrade (just upgrading packages already installed with nothing new added). Debian decided to upgrade some kde packages to 4.2. These are:
kde-icons-mono (4:4.2.2-1) ...
kdeartwork-emoticons (4:4.2.2-2) ...
kdeartwork-theme-icon (4:4.2.2-2) ...
kdeartwork-theme-window (4:4.2.2-2) ...
kdegames-card-data (4:4.2.2-1) ...
kdewallpapers (4:4.2.2-2) ...
and that is all. So now, for example, a game (kpat) opens normally but with no icons and no menus.

Has anyone had to deal with this yet? or am I alone? My feeling is just to carry on and manually upgrade the other 4.2 packages. I'm sure they'll be along quite soon anyway.

Last edited by jdkaye; 05-18-2009 at 06:34 AM.
Old 05-18-2009, 06:39 AM   #2
the trooper
Senior Member
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
No its not just you:

Pc1:~# aptitude safe-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
Resolving dependencies...
The following packages have been kept back:
  gwenview kappfinder{a} kdebase{a} kdebase-bin{a} kdebase-data{a} kdepasswd{a} kdm kfind{a} kipi-plugins
  konqueror{a} kscreensaver kscreensaver-xsavers
The following NEW packages will be installed:
  akonadi-server{a} gnokii-common{a} kaboom{a} kdebase-workspace-libs4+5{a} kdepimlibs-data{a}
  kdepimlibs5{a} libakonadiprivate1{a} libarchive1{a} libbluetooth2{a} libboost-program-options1.34.1{a}
  libdbd-mysql-perl{a} libdbi-perl{a} libgnokii4{a} libgraphicsmagick3{a} libhtml-template-perl{a}
  libical0{a} libkabcommon4{a} libkcddb4{a} libkdepim4{a} libkleo4{a} libkontactinterfaces4{a}
  libnet-daemon-perl{a} libpcsclite1{a} libplasma3{a} libplrpc-perl{a} libqt4-opengl{a} libqt4-webkit{a}
  libsensors3{a} libterm-readkey-perl{a} libzip1{a} mysql-client-5.0{a} mysql-server-5.0{a} phonon{a}
The following packages will be REMOVED:
  kregexpeditor{u} libkcddb1{u} libsensors4{u} libservlet2.3-java{u} lm-sensors{u}
The following packages will be upgraded:
  alien ark cpp cpp-4.3 cron exim4 exim4-base exim4-config exim4-daemon-light g++ g++-4.3 gcc gcc-4.3
  gcc-4.3-base graphicsmagick graphicsmagick-imagemagick-compat kaddressbook kamera kate kde-icons-oxygen
  kdebase-runtime kdebase-runtime-bin-kde4 kdebase-runtime-data kdelibs-bin kdelibs5 kdelibs5-data
  kdemultimedia-kio-plugins klipper knetworkconf konqueror-nsplugins konsole ksysguard ksysguardd
  libcommons-digester-java libcommons-logging-java libdb-je-java libgcj-bc libgcj-common libmtp8
  libnewt0.52 liboil0.3 libschroedinger-1.0-0 libstdc++6-4.3-dev lp-solve mtp-tools myspell-en-us
  openssl-blacklist python-newt soundkonverter whiptail
The following packages are RECOMMENDED but will NOT be installed:
  ffmpeg timidity
50 packages upgraded, 33 newly installed, 5 to remove and 12 not upgraded.
Need to get 167MB of archives. After unpacking 170MB will be used.
Do you want to continue? [Y/n/?] n
Looks like we have some major changes for KDE coming.
I think i'll hold off updating and see what happens.
Old 05-18-2009, 08:13 AM   #3
LQ Guru
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,415

Original Poster
Rep: Reputation: Disabled
Thanks Trooper, I think I'll do the same.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Squeeze users: DO NOT UPGRADE APT!!! Telemachos Debian 8 05-08-2009 07:28 AM
Partial System Breaks Down after upgrade to v10.1 Manuel-H Slackware 1 03-09-2005 06:32 PM
SuSE 9.1: partial sound loss after upgrade to KDE 3.3.2 darkmatter333 SUSE / openSUSE 20 01-26-2005 06:14 AM
Partial upgrade with APT pinning (debian)? MaulingMonkey Linux - Software 1 01-21-2005 07:11 AM
Kaffeine keeps loading!! GRRRRR help Mystical Itachi SUSE / openSUSE 5 10-17-2004 03:14 AM

All times are GMT -5. The time now is 11:33 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration