LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-02-2009, 08:48 PM   #1
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Rep: Reputation: 50
NO bootlog messages


hi

I've enabled in /etc/default/bootlogd => BOOTLOGD_ENABLE=Yes,
but after Retsrat NO bootlog file /var/log/boot

Last edited by cccc; 01-07-2010 at 06:09 PM.
 
Old 08-03-2009, 03:13 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Have you checked to see if your bootlogd is running?
Also make sure you have the file /sbin/bootlogd
If you don't have that file then you need to install the sysvinit package.
cheers,
jdk

Last edited by jdkaye; 08-03-2009 at 03:19 AM.
 
Old 08-03-2009, 09:16 AM   #3
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Code:
# whereis bootlogd
bootlogd: /sbin/bootlogd /usr/share/man/man8/bootlogd.8.gz
I cannot understand, if I enable bootlogd why it doesn't create /var/log/boot file?

Last edited by cccc; 08-04-2009 at 07:25 AM.
 
Old 08-03-2009, 09:31 AM   #4
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
Hello cccc

I'm talking ubuntu; translate as necessary into Lenny.

The /etc/rc[2-5].d/S99bootlogd links are to stop bootlogd at the end of the boot process. bootlogd is started by /etc/rcS.d/S<small number>bootlogd.
Code:
c@CW8:~$ \ls -l /etc/rc*.d/S*bootlogd
lrwxrwxrwx 1 root root 23 2009-07-18 20:42 /etc/rc2.d/S99stop-bootlogd -> ../init.d/stop-bootlogd
lrwxrwxrwx 1 root root 23 2009-07-18 20:42 /etc/rc3.d/S99stop-bootlogd -> ../init.d/stop-bootlogd
lrwxrwxrwx 1 root root 23 2009-07-18 23:18 /etc/rc4.d/S99stop-bootlogd -> ../init.d/stop-bootlogd
lrwxrwxrwx 1 root root 23 2009-07-18 20:42 /etc/rc5.d/S99stop-bootlogd -> ../init.d/stop-bootlogd
lrwxrwxrwx 1 root root 18 2009-07-18 20:42 /etc/rcS.d/S01bootlogd -> ../init.d/bootlogd
Best

Charles
 
Old 08-03-2009, 10:41 AM   #5
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Did you set enable to YES in
/etc/default/bootlogd

Quote:
# Run bootlogd at startup ?
BOOTLOGD_ENABLE=Yes
 
Old 08-03-2009, 12:06 PM   #6
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by repo View Post
Did you set enable to YES in
/etc/default/bootlogd
Yep, pls see my first posting.
 
Old 08-03-2009, 12:22 PM   #7
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
Hello cccc

You could try running, as root
Code:
/etc/init.d/bootlogd start
sleep 2
ps -ef | grep bootlogd
to see what happens and post the results back.

Best

Charles
 
Old 08-03-2009, 05:19 PM   #8
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
Quote:
Originally Posted by catkin View Post
Hello cccc

You could try running, as root
Code:
/etc/init.d/bootlogd start
sleep 2
ps -ef | grep bootlogd
to see what happens and post the results back.

Best

Charles
Cannot understand, from command line, put in a script?
 
Old 08-03-2009, 06:38 PM   #9
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,394
Blog Entries: 55

Rep: Reputation: 3566Reputation: 3566Reputation: 3566Reputation: 3566Reputation: 3566Reputation: 3566Reputation: 3566Reputation: 3566Reputation: 3566Reputation: 3566Reputation: 3566
On the commandline just run '/etc/init.d/bootlogd start; sleep 2; pgrep -l bootlogd'. The long listing ("-l") should show the commandline bootlogd is started with plus the process Id.
 
Old 08-04-2009, 07:26 AM   #10
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,623

Original Poster
Rep: Reputation: 50
I've reinstalled sysvinit, but it doesn't help.

Last edited by cccc; 01-07-2010 at 06:07 PM.
 
Old 08-04-2009, 07:28 AM   #11
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
Quote:
Originally Posted by cccc View Post
Cannot understand, from command line, put in a script?
Same, same.
 
Old 08-09-2009, 08:56 AM   #12
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Debian
Posts: 8,577
Blog Entries: 31

Rep: Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195Reputation: 1195
Quote:
Originally Posted by cccc View Post
I've reinstalled sysvinit and now it seems to work.
Great Please mark the thread solved using Thread Tools.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick Question: Bootlog phsythax Linux - Software 3 08-19-2006 01:40 PM
NO BOOTLOG MESSAGES after Kernel Update on Debian Sarge cccc Debian 1 01-09-2006 06:19 PM
Redirecting the kernel messages to file other than /var/log/messages jyotika_b83 Linux - General 3 04-28-2005 06:39 PM
where does kernel keep bootlog atom Linux - Newbie 4 03-28-2005 02:45 AM
bootlog powadha Debian 1 03-16-2004 11:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 05:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration