LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-17-2006, 07:38 PM   #1
wjmallard
LQ Newbie
 
Registered: Oct 2004
Location: Berkeley, CA
Distribution: Debian GNU/Linux (Sid)
Posts: 3

Rep: Reputation: 0
Imagemagick display cannot find Helvetica font


The image viewer, display, of the Imagemagick suite, seems to be broken on all of my Debian machines. I get this error:

$ display foo.png
display: unable to load font `-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1'.
display: unable to load font `-*-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1'.

Now, i know that Helvetica is a trademarked font, but Debian should have an alias somewhere in the font management system. I checked my installed fonts, and sure enough, a font matching the above description is present:

$ xlsfonts | egrep "^-.*-helvetica-medium-r-normal--12-.*-iso8859-1$"
-adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1
-adobe-helvetica-medium-r-normal--12-120-75-75-p-67-iso8859-1

I'm running sid, so i'm guessing that Display broke during a recent dist-upgrade in which Defoma became the default font manager. If i recall correctly, this occurred in the last month.

Has anyone else encountered this problem? I'd appreciate any advice.
 
Old 04-19-2006, 09:00 AM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 57
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=363371

Somebody (you?) opened a bug report for this one.

(which doesn't give you the solution..)

edit:
on my sid it works, if it can help:

me@debian:~/Desktop$ xlsfonts | egrep "^-.*-helvetica-medium-r-normal--1.*-iso8859-1$"
-adobe-helvetica-medium-r-normal--11-80-100-100-p-56-iso8859-1
-adobe-helvetica-medium-r-normal--11-80-100-100-p-56-iso8859-1
-adobe-helvetica-medium-r-normal--11-80-100-100-p-56-iso8859-1
-adobe-helvetica-medium-r-normal--14-100-100-100-p-76-iso8859-1
-adobe-helvetica-medium-r-normal--14-100-100-100-p-76-iso8859-1
-adobe-helvetica-medium-r-normal--14-100-100-100-p-76-iso8859-1
-adobe-helvetica-medium-r-normal--17-120-100-100-p-88-iso8859-1
-adobe-helvetica-medium-r-normal--17-120-100-100-p-88-iso8859-1
-adobe-helvetica-medium-r-normal--17-120-100-100-p-88-iso8859-1

debian:~# dpkg -l defoma imagemagick xfs xfonts-100dpi libfreetype6 libx11-6
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-======================-======================-=================================
ii defoma 0.11.8-0.1 Debian Font Manager -- automatic font configuration framewor
ii imagemagick 6.2.4.5-0.8 Image manipulation programs
ii libfreetype6 2.1.10-3 FreeType 2 font engine, shared library files
ii libx11-6 1.0.0-6 X11 client-side library
ii xfonts-100dpi 1.0.0-2 100 dpi fonts for X
ii xfs 1.0.1-4 X font server

Last edited by nx5000; 04-19-2006 at 09:07 AM.
 
Old 04-19-2006, 01:43 PM   #3
wjmallard
LQ Newbie
 
Registered: Oct 2004
Location: Berkeley, CA
Distribution: Debian GNU/Linux (Sid)
Posts: 3

Original Poster
Rep: Reputation: 0
Nope, wasn't me. Yep, i've got all of those fonts and packages installed.

Thanks for pointing out the recent (18 Apr) filing of a bug report.

Still no luck, though. Anyone else have an idea?

Last edited by wjmallard; 04-20-2006 at 12:58 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DVDRIP does not find transcode and Imagemagick t2dreamer Linux - Software 3 10-25-2005 05:38 PM
improving linux font quality: how can i use adobe-helvetica-iso8859 from mozilla webazoid Linux - Software 6 07-04-2004 08:24 PM
Font problem on Helvetica bluedarkness Linux - General 1 04-25-2004 02:39 PM
no Helvetica font (and others) in KDE 3.1.4 Windy Debian 3 02-08-2004 02:04 PM
Can't see Helvetica font in GTK+ apps. (slack9) aaron_n Slackware 5 04-17-2003 03:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration