LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-28-2005, 05:33 AM   #1
Nick69
LQ Newbie
 
Registered: Nov 2005
Posts: 4

Rep: Reputation: 0
Clock Problem


Hi all,

I recently installed a Debian Sarge on a IBM ThinkCentre (Pentium 4 HT).
After having compiling the last kernel (2.6.14.2) with HT module, resolving some latence problems, I've got a strange behavior about the clock system.

My hard one (BIOS) still correct, but the date of the system goes backwards after a random (I think) time.

Here is the result of the date command each "real world" second :

Code:
everest:~# date
dim nov 27 02:24:37 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:37 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:37 CET 2005
everest:~# date
dim nov 27 02:24:37 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:38 CET 2005
everest:~# date
dim nov 27 02:24:39 CET 2005
But some times this works well...

I already change the battery on my motherboard.

Any ideas ?
 
Old 11-29-2005, 12:31 PM   #2
macondo
Senior Member
 
Registered: Jul 2003
Distribution: Devuan, Slackwre64-current
Posts: 1,020

Rep: Reputation: 62
# apt-get install ntpdate
 
Old 11-29-2005, 01:13 PM   #3
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,285

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
I can't say why you're seeing the drift in time as reported by the "date" command. Maybe that's just the way it is. I haven't run the date command multiple times per second to see if any of my systems exhibit this drift.

FYI, the "date" command reports the "system clock time". This is seperate from the "real time clock" (a.k.a. "BIOS clock", "hardware clock", "CMOS clock") which is reported by the "hwclock" command. You must be root to run hwclock. Invoke it like "hwclock --show" to read your hardware clock.

When your system boots, the hardware clock is read and the result is used to set the system clock. From then on out the hardware clock is not used. When you shutdown, the system clock data is written back to the hardware clock on many systems.

Other programs like "rdate", "ntpd", "ntpdate", etc. can be used to set your system clock using an external source as reference.
 
Old 11-30-2005, 04:36 AM   #4
Nick69
LQ Newbie
 
Registered: Nov 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for your responses.

I knew the "ntpdate" programs and other, but the problem was that my system went wrong during my system was up (no reboot at all).

Anyway, I resolved the problem removing some all modules in kernel about the clock. I know it is the easiest way, but it works...

Thanks again,
 
Old 10-25-2006, 02:42 PM   #5
dukezero
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
same problem

hey! Im just having the same problem with another IBM ThinCentre (w/ Pentium4 processor) and Linux kernel 2.16.6.1:

The system clock seems to be crazy: Most of the time it is running ok but eventually it slows down, and other times even jumping backwards several seconds. Seems to be a kernel issue

You said you solved the problem removing some modules from the kernel. Can you tell me which ones?

I am running these daemons in the server: postgresql, httpd(apache), svscan(daemonstool), acpid. Could these programs cause the clock behavior?

thanks a lot,


DukeZer0
 
Old 10-26-2006, 03:30 AM   #6
Nick69
LQ Newbie
 
Registered: Nov 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Hey Dukezero!

Well I solved my problem a long time ago, and I didn't notice the fix procedure... But I remember that the solution was in the kernel configuration, not about software.
Have a look at :

- Processor type and features > HPET Timer Support
> Symmetric multi-processing support [2 cpu]
> SMT (Hyperthreading) scheduler support
> No Forced Preemption (Server)
> Timer frequency (100Hz)
- No Power management options at all.

Hope it will help you.

Cheers,
Nick
 
Old 10-26-2006, 06:45 PM   #7
dukezero
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
100Hz?

hey nick! lots of thanks for your reply
I am rebuilding a kernel now. hope it works

the time freq should be 100Hz?

dukezero
 
Old 10-27-2006, 03:25 AM   #8
Nick69
LQ Newbie
 
Registered: Nov 2005
Posts: 4

Original Poster
Rep: Reputation: 0
Well that what I use...
 
Old 11-07-2006, 09:01 PM   #9
jptxs
LQ Newbie
 
Registered: Nov 2006
Posts: 7

Rep: Reputation: 0
crazy clock solution?

Quote:
Originally Posted by dukezero
hey! Im just having the same problem with another IBM ThinCentre (w/ Pentium4 processor) and Linux kernel 2.16.6.1:

The system clock seems to be crazy: Most of the time it is running ok but eventually it slows down, and other times even jumping backwards several seconds. Seems to be a kernel issue

You said you solved the problem removing some modules from the kernel. Can you tell me which ones?

I am running these daemons in the server: postgresql, httpd(apache), svscan(daemonstool), acpid. Could these programs cause the clock behavior?

thanks a lot,


DukeZer0
Did you figure this one out? I'm having almost the exact same issue...
 
Old 11-08-2006, 08:58 PM   #10
anseljh
LQ Newbie
 
Registered: May 2004
Posts: 2

Rep: Reputation: 0
Me too!

Quote:
Originally Posted by jptxs
Did you figure this one out? I'm having almost the exact same issue...
I'm having the same problem on an IBM NetVista Pentium 4 w/ Ubuntu (Dapper/Server). Has anyone solved this? If so, what did you do?

 
Old 11-09-2006, 01:24 PM   #11
dukezero
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
Thumbs down Solved!

The problem is solved. Thanks a lot Nick!

This is what I did: I rebuild the kernel, making the following changes in the configuration:

Symmetric multi-processing support -> Disabled
SMT (Hyperthreading) scheduler support-> Disabled
Preemption-> No Forced Preemption (Server)
Timer Frequency->100Hz

The kernel was the latest 2.6.? version but this procedure should work with other versions.
I did not remove the ACPI power management options and it worked OK.

This may be a serious kernel issue that the developers are maybe ignoring!

DukeZero.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 08:19 PM
Clock problem ragingchihuahua Linux - Newbie 3 04-04-2004 03:34 AM
clock problem schurt Linux - Software 1 03-31-2004 02:32 PM
clock problem minor Linux - General 12 10-31-2003 05:37 AM
Clock problem BajaNick Linux - Software 4 08-05-2003 08:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration