LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 12-08-2004, 05:52 PM   #1
rksanders
LQ Newbie
 
Registered: Nov 2004
Distribution: Debian gnu/linux
Posts: 28

Rep: Reputation: 15
cdrecord: Function not implemented. shmget failed


Everything was going so well!
Physical installation of Sony CD-RW CRX230ED 52-32-52 drive went without problems.
Using Woody r3 with 2.4.19 kernel.
Configuring the SCSI emulation went smoothly. Ran cdrecord -scanbus and got the device numbers.
Using mkisofs created ISO image.
Using diff compared Image with original file--no differences.
Then
'cdrecord dev=0,0,0 speed=16 -pad -v -eject fle.iso' resulted in the following
Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 Jorg Schilling
TOC Type:1 = CD-ROM
cdrecord: Function not implemented. shmget failed

And there I am!

Thanks
Rusty
 
Old 12-09-2004, 03:32 AM   #2
basileus
Member
 
Registered: Nov 2004
Location: Turku, Finland
Distribution: Debian, Ubuntu, Gentoo
Posts: 388

Rep: Reputation: 30
Checked from www.google.fi/linux

"cdrecord: Function not implemented. shmget failed

You removed SVSv IPC from your kernel. You need to enable it again."

Have you compiled a custom kernel? That could be the reason...

Check this site, it might help:

http://computing.ee.ethz.ch/sepp/cdr...o/README.linux

If not, try googling with your error messages.
 
Old 12-09-2004, 01:41 PM   #3
rksanders
LQ Newbie
 
Registered: Nov 2004
Distribution: Debian gnu/linux
Posts: 28

Original Poster
Rep: Reputation: 15
Hi Basileus,
Thanks for the response.
Yes I did compile a new kernel.
Did you mean SYS?
There doesn't seem to be a SVS inthe config file. There is a SYSVIPC
under the PCI Hotplug support section and it is not set, although it was set
in the last kernel I was using.

Thanks
Rusty
 
Old 12-10-2004, 04:04 PM   #4
rksanders
LQ Newbie
 
Registered: Nov 2004
Distribution: Debian gnu/linux
Posts: 28

Original Poster
Rep: Reputation: 15
Just to wind things up

I checked several .config files and all had SYSVIPC except the latest one.
So I recompiled with SYSVIPC compiled in, and after a few minor problems
I burned my first CD. It seems to be an accurate rendition of the original.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to connect to SDP server ...Function not implemented triona Linux - Software 2 03-24-2006 10:03 AM
QM_MODULES function not implemented pike Linux - General 4 12-22-2005 06:03 AM
lockdsvc: Function not implemented Yalla-One Slackware 4 10-05-2005 12:48 PM
2.6.3 swapon - function not implemented Sammy2ooo Linux - General 3 03-10-2004 07:08 AM
nfssvc: Function not implemented SiliconBadger Linux - Networking 5 05-14-2002 01:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration