LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 04-17-2005, 03:02 PM   #1
pike
LQ Newbie
 
Registered: Apr 2005
Posts: 19

Rep: Reputation: 0
QM_MODULES function not implemented


I have migrated from kernel 2.4.19 (Suse 8.1 Profesional) to 2.6.11.7 (the latest).
Now when I do depmod -a it produce the next error:

QM_MODLUES function not implemented.

I have read that this problem is fixed updating module_init_tools and modutils.

I have done that: module_init_tools to version 3.1 and modutils to version 2.4.27.

After that the problem isn't fixed, ocur again.

What can i do?
 
Old 04-17-2005, 03:11 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984
did you get *anywhere* near google before asking this? http://www.google.com/search?q=QM_MO...ot+implemented ;-)

it's a very common problem, install module-init-tools.
 
Old 04-17-2005, 03:16 PM   #3
pike
LQ Newbie
 
Registered: Apr 2005
Posts: 19

Original Poster
Rep: Reputation: 0
I have already updated module_init_tools

As I said in my message I have updated yet module_init_tools to version 3.1 but the problem continued.
 
Old 04-17-2005, 03:48 PM   #4
pike
LQ Newbie
 
Registered: Apr 2005
Posts: 19

Original Poster
Rep: Reputation: 0
solved

sorry, I did not put the correct --prefix option in ./configure when I install module_inti_tools

.
 
Old 12-22-2005, 07:03 AM   #5
frosken
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
I've got the exact same problem... except... I configured module-init-tools 3.2.2 correctly (--prefix=/), installed modutils 2.4.27 with --prefix=/, generate-modprobe.conf which returned:

modprobe: QM_MODULES: Function not implemented

Warning: not translating path[toplevel]=/lib/modules/2.6

Then it runs for a while, and I've got a new /etc/modprobe.conf
Reboot, same messages. QM_MODULES: Function not implemented

I've recompiled/reinstalled the modules, recompiled the whole kernel, nothing helps.
I'm running RH9.0, by the way. Upgrading to Kernel 2.6.11.12.

Pleeease help. :/

And I've read a lot of pages from google regarding the problem. For everybody, upgrading m-i-t to >=3.1 helps, but not for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lockdsvc: Function not implemented Yalla-One Slackware 4 10-05-2005 01:48 PM
QM_MODULES: Function not implimented edman007 Linux - General 4 01-17-2005 07:13 PM
Kernel 2.6.0 <=> QM_MODULES: Function not implemented Musikolo Linux - General 14 10-04-2004 10:51 AM
Kernel 2.6.3 QM_MODULES not implemented rajan_kanwar Linux - Software 1 04-28-2004 11:11 AM
2.6.3 swapon - function not implemented Sammy2ooo Linux - General 3 03-10-2004 08:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 09:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration