LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 09-22-2014, 05:52 PM   #1
fixer1234
Member
 
Registered: Aug 2014
Location: Virginia, USA
Posts: 50

Rep: Reputation: Disabled
Auto-login without password (KDM) help


I'm using Kwheezy 1.5, 64 bit (KDE/Debian Wheezy), as the only user on a home system. I want to boot up without a login.

The system settings include the ability to configure the KDM login manager. Under the Convenience tab, There are settings to enable auto-login and password-less logins. According to the Help instructions, there should be a list of users in the password-less login window that can be selected. That window is empty, as is the pull-down list of users under Enable Auto-Login. Administrator (me, user with regular priviledges) is listed as the only name in the Specified user pull-down list under Preselected User for Auto-Login. In the User tab of the login manager, no users are listed, including Administrator. These configuration screens are set up by default to be accessed from the system settings without root privileges.

I've found some other threads that deal with how to manually configure password-less login, but they all deal with other cases (CLI, other window managers, etc.), where there was no built-in provision for configuring this.

Any suggestions for what might be causing the login manager to not behave as described and how to make it work?

Last edited by fixer1234; 09-22-2014 at 05:55 PM.
 
Old 09-23-2014, 09:55 AM   #2
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 432
Blog Entries: 1

Rep: Reputation: 41
This would be an insecure idea. however it is possible. In KDE, go into System Settings, Login Screeen, then the Convenience tab. The section Enable Auto-Login allows you to select the user.

You could also replace starting kdm in the boot process with sudo -u <user> startx

Last edited by mpyusko; 09-23-2014 at 10:06 AM.
 
Old 09-23-2014, 12:13 PM   #3
fixer1234
Member
 
Registered: Aug 2014
Location: Virginia, USA
Posts: 50

Original Poster
Rep: Reputation: Disabled
Thanks for the reply. The system settings route is what doesn't work. No users are shown.

I'm fairly new to Linux and still hesitant about making system changes when I don't fully understand the ramifications. I would prefer to get the built-in tools to work. This seems like something that wouldn't slip through Debian's testing process as a bug and I don't find other people reporting the same issue.
 
Old 09-23-2014, 01:16 PM   #4
mpyusko
Member
 
Registered: Oct 2003
Location: Rochester, NY, USA
Distribution: Salckware ver 10.1 - 14.1, Debian too.
Posts: 432
Blog Entries: 1

Rep: Reputation: 41
Ok. Well as I am sure many others will tell you, it is a bad idea, very insecure idea, to have auto-login enabled. One of the reasons why Linux is so stable and secure is it's user/privilege based architecture. If you are this new to Linux, then I suggest waiting a decade or two before considering automating login or otherwise circumventing designed protections. I have been using Linux for more than 10 years and I'm the only user on my computers but I still login each time it boots. It's Linux.... It's how we do.
 
Old 09-23-2014, 01:50 PM   #5
fixer1234
Member
 
Registered: Aug 2014
Location: Virginia, USA
Posts: 50

Original Poster
Rep: Reputation: Disabled
In a secure home environment with no other users, what does the manual login buy you? If you auto-login to the same user account, don't you arrive at the same point once the system is running?
 
Old 09-25-2014, 06:19 PM   #6
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Debian
Posts: 214

Rep: Reputation: 27
It is strange that it shows no users, I enable that feature on my previous Debian system (I'm currently on Slackware), but I've reinstalled my Wheezy system multiple times & never seen that*. My system would have a root user & the normal user, the normal user would always show in that list. Are you running X as root or something odd (I'm not sure Debian even allows that)?

Try loading the login screen manager by searching for 'login' on the KDE start menu rather than through the System Settings panel, it may prompt for root password straight away & then provide you with more options than you're currently seeing.

*I have seen related issues with it in Jessie where the root login fails; it didn't prompt for password & just went straight to authentication failure, hence I couldn't setup auto-login or do system updates! Actually I think I may have had issues with there being no way to apply it in Wheezy because there was no way of logging into the screen as root (I think this is why I worked around it via loading the screen via start menu search).

I hope that helps.

Last edited by Mr Marmmalade; 09-25-2014 at 06:21 PM.
 
Old 09-26-2014, 11:12 AM   #7
fixer1234
Member
 
Registered: Aug 2014
Location: Virginia, USA
Posts: 50

Original Poster
Rep: Reputation: Disabled
Thanks for the reply. Good thought on trying from the start menu but no cigar--same situation. I haven't tinkered with system settings other than what is available as normal customization through the system settings panel. I'm actually running Kwheezy, which is a bundle designed to appeal to Windows users. Perhaps the developers figured that this audience needs to be protected from itself and disabled this feature. Maybe the next step would be to contact the developers or report it as a bug.
 
Old 09-26-2014, 11:30 AM   #8
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Debian
Posts: 214

Rep: Reputation: 27
I was using the KDE version of Wheezy debian-7.6.0-amd64-kde-CD-1.iso
 
Old 09-26-2014, 11:58 AM   #9
fixer1234
Member
 
Registered: Aug 2014
Location: Virginia, USA
Posts: 50

Original Poster
Rep: Reputation: Disabled
Interesting. That is an official Debian distro. I believe Kwheezy is a third party distro. It differs by including an extensive software collection and drivers collection, including a lot of non-free drivers, and some utilities not normally bundled with Debian that are more user friendly. It's targeted at Windows users and overcoming some of the characteristics of Debian that make it rough around the edges for newcomers to Linux. It's sort of like Mint with extra software, but based on Debian stable, like a souped up SolydK business version.
 
Old 09-26-2014, 02:05 PM   #10
Mr Marmmalade
Member
 
Registered: Oct 2002
Location: Scotland
Distribution: Debian
Posts: 214

Rep: Reputation: 27
I'd recommend going for the real thing rather than a spin-off distro, I've neaver heard of KWheezy, but maybe its good also. More people on this forum will then be able to help if you need any - although I would expect it to mostly be the same.

Last edited by Mr Marmmalade; 09-26-2014 at 02:06 PM.
 
Old 09-26-2014, 06:11 PM   #11
fixer1234
Member
 
Registered: Aug 2014
Location: Virginia, USA
Posts: 50

Original Poster
Rep: Reputation: Disabled
I had tried the real deal but there were too many things that required manual intervention to get it set up. I'm a Windows wuss and not yet proficient at non-gui Linux. I moved from Mint to Kwheezy because there were many problems with applications from the Ubuntu source. Other than this login problem, which is just an annoyance, everything in Kwheezy worked perfectly out of the box, including software that didn't work from Ubuntu origins. They did a great job of pre-configuring everything.
 
Old 09-26-2014, 10:33 PM   #12
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,628

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
As long as you continue to play with respins by people that do not fully understand the Linux system or don't approve of security you will run into all sorts of problems.

Passwordless log in is simply insecure and stupid. Don't do it.

I am also very worried by your user; "Administrator" which is usually used to indicate root privileges. You really don't want to go there.

Yes I realize a lot of MS users do this. Gee I wonder why they have problems you see all over the web? You can get in a lot of trouble running things like web browsers as root.

When you log in to a real Linux system without a password you will end up giving it more than once probably to do some very normal things that you would have the permission to do if you had identified yourself so that the system, not the gui DE, knows exactly who you are. This is not possible to do without following the correct protocol for loging in.

You are not alone with your box. You are obviously connected to the internet. If you read this the entire server(s) for LQ are there with you.

I ran MS for years, starting with MSDos. We didn't need a password for MSDos. It didn't connect to anything anyway and booted from a floppy.

Once Bill and his buddies decided that the web might catch on and came out with Windows you had a password unless you stupidly disabled it. My 76 year old mother in law has more sense than to do that.

If you want a no security system go to Windows and buy at least 2 damned good AV programs and a separate spyware program and run them at least twice a day.

If you want a secure system use a damned password like a big boy.
 
Old 09-27-2014, 01:09 AM   #13
fixer1234
Member
 
Registered: Aug 2014
Location: Virginia, USA
Posts: 50

Original Poster
Rep: Reputation: Disabled
Thanks for your reply. I wouldn't put Kwheezy in the respin boat you described. This thread was triggered by it not letting me bypass security.

I chose administrator as a user name. It is a regular user account, not root (unless I inadvertently selected a reserved name that Linux assumes is more than a regular user?). I understand that using root as your normal user account is nuts and auto-login to root is even more nuts.

From everything I've been able to research, my understanding is that auto-login pre-selects the user account to skip the user selection menu, and passwordless login does nothing more than start the display manager (KDM or GDM), without entering a password. After that, the system is in the same state it would be if you manually logged in through KDM. Everything I've read seems to indicate that anything that would require a password after manual login will still require a password; it doesn't open any backdoors or affect permissions. If I've misunderstood what I've read, I certainly need to reassess. Are you saying that setting up passwordless login via the KDM login manager affects things other than starting the desktop?

You also raised the reverse issue, that I could end up with additional requests for passwords. I'm not sure whether you were referring to logging in through KDM rather than a non-gui process, or bypassing login password entry in KDM. What kinds of things might I run into that would ask for a password that I would otherwise have permission to do?

If you were suggesting that a gui DE is not a "real Linux system", that's not an important distinction for me. I'm happy with imitation vinyl laminate veneer Linux as long as it works. I'm too spoiled by gui to go back to CPM and a terminal (I would also prefer not to service my own car or hunt my own meat). :-)
 
Old 09-28-2014, 10:25 AM   #14
replica9000
Senior Member
 
Registered: Jul 2006
Distribution: Debian Unstable
Posts: 1,065
Blog Entries: 2

Rep: Reputation: 227Reputation: 227Reputation: 227
You could edit /etc/kde4/kdm/kdmrc, and change these lines.

Code:
AutoLoginEnable=false (May also appear as #AutoLoginEnable=True)
AutoLoginUser=<insert-your-user-name-here>
I have done this on my laptop, but the HDD also has to be decrypted before the log in screen appears. Also the password is still required when the screen in locked.
 
Old 09-28-2014, 11:10 AM   #15
fixer1234
Member
 
Registered: Aug 2014
Location: Virginia, USA
Posts: 50

Original Poster
Rep: Reputation: Disabled
I looked at that configuration file. A few excerpts:

[X-*-Core]
AllowNullPasswd=false

[X-:*-Core]
AllowNullPasswd=true
NoPassEnable=true
NoPassUsers=

[X-:0-Core]
AutoLoginEnable=true
AutoLoginLocked=false
AutoLoginUser=

I'm not sure what I'm looking at. I assume the colon in the section label means something; it's the only difference between two conflicting entries that appear to relate to passwordless login. The autologinenabled line you mentioned is set to true. I excluded a line here that shows me as the default user. There is no user name in the autologinuser line, but I'm the only user so the system does pre-enter my user name on the login screen. It would be great if there was a user manual for these configuration files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Disable login screen (auto login) after waking from sleep (KDE/KDM) damgar Slackware 2 08-18-2018 10:29 PM
Auto-login Without user and password hraposo Fedora 1 07-12-2006 07:15 AM
Login without password in KDM frankmulder SUSE / openSUSE 3 10-31-2005 04:49 PM
Graphical Auto-Login without using KDM or GDM soda Linux - General 7 12-01-2002 12:57 PM
How to get the auto login to kdm! 1000mhz Linux - General 1 09-14-2002 04:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 01:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration