LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Blogs > CLI is your friend
User Name
Password

Notices


19/09/2013
My new goal is to recover the broken link in my secondary HDD to restablish a system.
First step:
to find out how is recognized my secondary HDD
Trying with fdisk
Output
fdisk /dev/sda
fdisk /dev/sdb

Recognizes both and also shows us UUID and GB

I know that my secondary HDD is /dev/sda

Now I have to find out how to make a custom entry in GRUB2

I have reviewd the information in help.ubuntu.com ... GRUB2
and now I know that I have to do the custom entry in /etc/grub.d/40customentry...

Now I only have to
set-root= use the proper UUID that I found in fdisk /dev/sda
linux /boot/grub/... find my vmlinuz
initrd /boot/grub/... find my initrd

and cross my fingers
Rate this Entry

trying vitualization kvm libvirt virsh virt-viewer

Posted 11-20-2015 at 05:27 AM by translator1111

20/11/2015
A couple of weeks ago a recruiter found my profile in the web and contacted me for a job as Linux Administrator.
He asked me about my server and was very surprised that I had not tried virtualization.
I answerd that I did not any need to have a virtualization as I did not have any Windows installed in any computer at home.
I did not understand the power of virtualization then.

Last weekend I had some time and decided to start with virtualization.
As I use ubuntu for my server I started with the Guide for ubuntu server following the steps.
Installing libvirt with apt-get.
installing virt-viewer with apt-get.
I used for the kernel a slitaz version, the version 3. That was probably a not good choice, Virtualization is more effective with servers. I will use a server as my virtualized machine next time.
The command
Code:
virsh -c qemu¨///system list
gave me the output of my slitaz3 that was running
this was the first moment of happiness.
However trying to use the virt-viewer was not so easy as I did not understand the error message.
Code:
virt-viewer -c qemu:///system slitaz3
The error was related to the display, virt-viewer did not know where to display the output.
After some trying to decide if I was mistyping orders or forget some step I took the error message into the browser and in the second result was my anwer
I was connecting to my server using ssh without specifying the display of the output the answer is:
Code:
ssh -X username@ipaddrees
The important part is the X
After typing again
Code:
virt-viewer -c qemu:///system slitaz3
another window opened with my slitaz asking for the language to use in the istalation.
After the instalation finished I found in an X window the desktop of my slitaz3 that was the second moment of happiness.
I shutdown the slitaz using the GUI
and I shutdown the virtual machine using:
Code:
virsh -c qemu:///system shutdown slitaz3
I tried to started again using
Code:
virsh -c qemy:///system start slitaz3
but slitaz3 is complaining because it cannot boot.
I will try to solve this later.
But the importance is that virtualization gives me the opportunity to try other releases of linux even RHEL and SUSE without really installing them.
This will be the next step
Posted in Uncategorized
Views 1843 Comments 0
« Prev     Main     Next »
Total Comments 0

Comments

 

  



All times are GMT -5. The time now is 08:04 AM.

Main Menu
Advertisement
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration