Review your favorite Linux distribution.
Go Back > Blogs > CLI is your friend
User Name


My new goal is to recover the broken link in my secondary HDD to restablish a system.
First step:
to find out how is recognized my secondary HDD
Trying with fdisk
fdisk /dev/sda
fdisk /dev/sdb

Recognizes both and also shows us UUID and GB

I know that my secondary HDD is /dev/sda

Now I have to find out how to make a custom entry in GRUB2

I have reviewd the information in ... GRUB2
and now I know that I have to do the custom entry in /etc/grub.d/40customentry...

Now I only have to
set-root= use the proper UUID that I found in fdisk /dev/sda
linux /boot/grub/... find my vmlinuz
initrd /boot/grub/... find my initrd

and cross my fingers
Rate this Entry

linux in old computer: from DSL to LinuxfromScratch through SLAX and ConnochaetOS

Posted 09-19-2013 at 05:10 AM by translator1111

I had an old Fujitsu notebook with W95 as OS with 2 partitions on it C:for OS; D: for Data. toguether a 5 GB HDDD. I made a third partition with the help of HAOS tools dividing C in half with volume EXT3 (1600 MB) took some space from D: for a fourth partition with volume EXT3 (50 MB) and another with volume EXT2 (120 MB).
This laptop has two problems, one is that there is a bad sector in HDD, which I hopefully has isolated when I made the partitions and a problem with memory.
As GUI are not good for the laptop, I thought that CLI will be better.
As I have been a user of Linux, until now only Ubuntu, but trying to use the console as much as possible I decided that it was the time to learn more about Linux. What better place to do this that in a laptop that is not good for anything else?

So this is my trial place for experimenting with linux

I started installing DSL in the (50 MB partition), amazing thing!
I learned a little bit, but it was not intended to be used as OS in hard drive

I tried installing Feather linux in the 120 Mb partition, but it was too little.

I tried to install it Feather linux in the 1600 MB partition. I succeded.
Feather linux is good in itself for the goal that was meant: to have a small linux installed in RAM as LIVE
It can be also used as a base for a debian based distribution.

Among the applications included in Feather linux was Dillo and Firefox as browsers
Dillo has not support for https
for actualizing Firefox I used downloaded the tar.gz file, untar it, but there were problems with the C precompiler while doing "./configure"

Next step was tried to install a packet manager in order to install more software.

As Feather linux was made a long time ago and there is no continuation, the scripts intended to install the package managers APT and DPKG are not properly working + the problem with my memory

I will try to describe what happened and the solutions I provide, maybe can help somebody:
When APT was reading the sources.list encounter the problem of that after I put the "sudo apt-get update" and it was reading the packets stopped at 86%

I reinstalled about 5 times Feather Linux again but always was stopping when reaches 86%
I decided that it was related to the problem memory and I changed my strategy

I started to install one by one the packets using "wget" and "" as http place.
make install

wget and untar was ok, but ./configure was always finishing with errors

I looked into the file config.log and see what was missing
I tried to install it

I searched for the
"/lib/cpp sanity fail"

and I found 2 solutions:
1. install a new kernel (using the headers)
2. problem with C compiler and precompiler

I tried to install gcc
and I had a problem, which version?
I tried first the unstable, then the stable and later on the oldstable

and then I ran into a loop
to install gcc, I needed automake, to install automake I needed autoconf, to intall autoconf, I needed gcc, to install gcc, I needed gnu maker, to install gnu maker I needed m4; to intall m4 I had to check the "/lib/cpp sanity fail"

I had then 2 options, install a new kernell, using spt, to install apt I needed gcc conf and again I ran into the loop or tried to repair the /lib/cpp

Fortunatelly I found Linux from scratch

and here is where I am now,

starting my adventure about Linux. I have made a quick reading thorught the whole book and it seems achievable.

installing the sources using wget, but instead of one by one, there is a way to send as input to wget a list of packets
there is a order in which sources has to be installed.
also the sources are installed twice and is explained how to make the configuration: (so "./configure" is not always working, you have to add options and this is what it make it work, also the PATH and the places where files are looking for files and info are important.

I am looking forward to the process.
First problem, I need a new kernel and in order to install the kernel I need, make, to have make, I need, gcc, m4 and so on<so we are again at the beginning

Here are my settings for the adventure, which means that I have to deep further if I want the adventure to start:
Binutils: line 8: ld: command not found line 9: bison: command not found
yacc not found
bzip2, Version 1.0.2, 30-Dec-2001.
Coreutils: 5.0.91
diff (GNU diffutils) 2.8.1
GNU find version 4.1.20
gawk: not an option: --version
/usr/bin/awk -> /usr/bin/mawk line 21: gcc: command not found line 22: /lib/ Permission denied
grep (GNU grep) 2.5.1
gzip 1.3.5
Linux version 2.4.27 (root@Knoppix) (gcc version 2.95.4 20011002 (Debian prerelease)) #2 SMP Mo Aug 9 19:34:51 CEST 2004 line 26: m4: command not found line 27: make: command not found
patch 2.5.9
Perl version='5.8.4';
GNU sed version 4.1.2
tar (GNU tar) 1.13.93 line 1: makeinfo: command not found
Texinfo: line 33: gcc: command not found
Compilation failed

09/09/2011 took me to Slackware. Now I am reading the book and starting to understand some basic concepts of Linux.

after reading the book I have realized that I do not need to compile the kernel
What I wanted is to save the contents of the Windows disk in a CD or a usb;
for USB: I can use "mount /mnt/usb" to mount my usb I copy the contents there
for CD I can use cdrecord or cdrtools from the console to burn the files into a CD
In order to have open ssh, I can use apt to install this packet.
So, right now, I will not complile the kernel either to start a new linux as Linux from scratch

Because the problem, and everything started because, in order to install apt, I needed develop tools, but develop tools could be installed only using source tarballs and for this were needed develo tools; so it was difficult
Now that apt is working, I can try to use this packet manager to update firefox and use open ssh.

13/09/2011 - 14/12/2011
In order to compile Linuxfromscratch I needed a kernel 2.6 and bigger and my DSL has only 2.4
So I was suggested to install slax
First time I installed slax using the application
Now that I have kernel 2.6 I discovered that I did not have internet connection.
I used the DSL as Live to get the files necessary for linuxfromscratch and started the process.
Compiling linuxfromscratch was stopped it because I faced a compilation problem at the gcc pass 1, one of the components could not find a file with a .h ending and crashed.
I then tried another distribution connochaetOS
I have internet connection but I cannot made my wifi dongle work. The driver has a problem and when I try to arise my network is said: "SCIOCSIFFLAGS: Invalid argument"
I tried the Slax as Live and the wifi dongle adapter was sucessfully until iwlist scan, I could connect it using iwconfig wlan0 esssid, but as I have WPA-personal I had to study further
Using my /boot/grub/menu.lst configuration I tried to add the kernel to grub
- I started the slax as Live in run level 3
- cp -r /boot /slax /mnt/hda3/

In the meanwhile I installed: slax, then connochaetOS
my next goal was to have my dongle wifi adapter working.

It is working with slax and is not working with ConnochaetOS yet.
Here is what I did:
I plugged the dongle
made the connection
iwconfig wlan0 essid MYESSID
I brought up the interface
ifconfig wlan0 up
I ask for an IP address to the router with
dhcpcd wlan0

and worked

I could connect only to not WEP/WPA routers

Next step is to install wpa_supplication in SLAX and connect to a WPA router
Afterwards to install the proper driver in ConnochaetOS and made it work also

I finally got the wifi to work, I am writing this blog using it

Ok, here is what I did:
Installed wpa using a lzma module from
and activate it
activate wpa_suppicant-0.....lzma
First to up the card
ifconfig wlan0 up
Second, to connect to the adapter
iwconfig wlan0 essid MYWIFICARD
Third start wpa with the -d at the end. This is the debug option in order to know if you are suceesfully connected or not.
wpa_supplicant -iwlan0 -Dwext -c/etc/wpa_supplicant.conf -d &
Fourth, ask the router for an IP address (in another session or another window of the terminal)
dhccpcd wlan0
Only one important thing, SLAX will not support hidden ESSID, so I had to untick at my router settings the field "hidden network"

Now I am on the way to get my ConnochaetOS to work with wifi also. Until now, only wired connection is possible to internet.
I have asked a question in the forum of the distribution and I am waiting for the answer
Here is my question:

I give up with connochaetOS. I need to understand better linux in order to help myself.
I believe that the problem is that the driver cannot find the firmware, so I need to study more
Now that I have a fully linux system with kernel 2.6 and a fully working internet connection + a text browser lynx, I will keep on my adventure with Linuxfromscratch.
I will tell you more in my next entry

the answer to my question in the forum of was that as it is a completely free kernel is not possible to run firmware.
Now, I have downloaded the LFS book and I will try to build it in my old notebook using SLAX 6 as a host requirement system.
I will tell you more in next post.

I followed the instructions in LFS book and succeded to install binutils pass1, UBS was about 40 minutes. However after issuing command make while trying to compile gcc-4-1.6 stopped the process with S=D for 6:00 hours. I killed the process genautomata.c. I am now searching on this topic.
The D in the command top means "uninterruptible sleep"
Posted in Uncategorized
Views 1392 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 08:16 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration