Visit Jeremy's Blog.
Go Back > Blogs > stuartd
User Name


Rate this Entry

Installing Slackware 12.2 On An Old Dell Laptop - Part V

Posted 09-28-2009 at 02:54 PM by stuartd

It's been some time since I did any work on that old laptop. I've been away on holiday and then very busy.
So this evening I tried to get my head back into configuring eth0.
I've come up with a couple of ideas and tried them to no avail. Here goes -

I read here about pcmcia configuration:

and after some more reading around created /etc/modprobe.d/xircom.conf as follows:

alias eth0 xirc2ps_cs
options xirc2ps_cs if_port=4
Rebooting did not get me eth0.

It seemed to me that I was on the right track but ifconfig doesn't show eth0 only the loopback interface.

Reading more around it I discovered that udev has a part to play in this.

At I found this file and so created it in /etc/udev/rules.d/

# This file will be overwritten in next upgrade.  Please put your
# custom rules somewhere else (90-local.rules is a good idea)

SUBSYSTEM=="net", NAME=="?*", ACTION=="add", RUN+=" $env{INTERFACE} start"
SUBSYSTEM=="net", NAME=="?*", ACTION=="remove", RUN+=" $env{INTERFACE} stop"
I tried running
/lib/udev/nethelper eth0 start
but it didn't start eth0 or give me any error messages, and rebooting the computer did not get me eth0 either.

I'm at a loss at the moment. I've read the Slackware manuals and searched around for information on the net. I am sure I'm missing something.

Posted in Uncategorized
Views 1975 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 04:28 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration