Review your favorite Linux distribution.
Go Back > Blogs > rokytnji
User Name


Rate this Entry

Broadcom Wireless

Posted 08-04-2013 at 02:45 PM by rokytnji

First, this really isn't an Ubuntu or a Debian or a Mint issue. The problem likely lies with Broadcom and their lack of availability of firmware information for their wireless hardware. Broadcom does make a "generic" wireless driver for Linux, but it allegedly doesn't work with everything. Therefore, the Ubuntu development team have had to use fwcutter to pull the firmware information from a Windows driver to build one that works for Linux. I tried to install Mint 15 Cinnamon on my wife's 8-year-old HP laptop this weekend and ran into this issue. Here's the fix, and I'm pretty sure this will work for most situations:

1. Determine the exact model and firmware version of the driver. Open a terminal and enter:
lspci -vnn -d 14e4:.

2. You'l get a string back that looks like this:
0001:01:01.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)

Look at the section between the brackets at the "14e4" part near the end.

3. Go here and make sure your adapter is compatible with the Broadcom b43 driver, on the chart about a quarter way down the page:

4. If you're in the green area, you're good to go. Now, the Ubuntu/Debian folks have made this easy for us. Just run this command:
sudo apt-get install firmware-b43-installer

5. Reboot and you're done.

This worked perfectly on the ancient boat anchor my lovely calls a laptop.
Posted in Uncategorized
Views 4963 Comments 1
« Prev     Main     Next »
Total Comments 1


  1. Old Comment
    Thanks for the advice!

    I've a friend whose laptop's Broadcom adapter is not on the list. Do you suppose there's any chance that drivers for the left-out adapters will be developed?

    I also have a problematic Broadcom adapter, and mine is in green on the list. I tried what you suggested before I realized that, apparently due to my Broadcom adapter not being recognized, I can't access the internet with that system. It sounds, from what you're saying, as if some people can access the internet even without a recognized adapter. Is that right? How confusing!
    Posted 09-28-2013 at 07:21 PM by Kirsten Kirsten is offline
    Updated 09-28-2013 at 07:26 PM by Kirsten


All times are GMT -5. The time now is 04:25 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration