Review your favorite Linux distribution.
Go Back > Blogs > brianL
User Name


Rate this Entry

Rendered hARMless 2

Posted 09-08-2010 at 04:07 AM by brianL
Updated 09-08-2010 at 04:12 AM by brianL
Tags arm

More detail. One of the problems is the runme.php script in the sheevaplug-installer package. It's the script to be run on Linux, which is meant to restore all the correct environment variables and the Ubuntu to the plug. Why PHP? Why not a bash shell script? The first time I ran it, it just echoed the file's contents to the terminal. That was because it had <? at the beginning, instead of <?php. I knew enough to fix that. But then it came up with two errors: one about the line regarding which OS, the other saying I should be root, which I was (lines 7 & 43). Don't know enough about PHP to solve these. I'll attach runme.php (as runme.php.txt), for anyone who's interested.
Attached Files
File Type: txt runme.php.txt (4.0 KB, 7 views)
Posted in ARM
Views 3468 Comments 6
« Prev     Main     Next »
Total Comments 6


  1. Old Comment
    Right, thanks. I'll try that.
    Posted 09-08-2010 at 08:02 AM by brianL brianL is offline
  2. Old Comment
    I am getting really pissed off with this again. Thought I'd try it on my Ubuntu netbook, with the original but slightly edited runme.php, but every time I run it, it comes up with a different error - instead of listing them all at once.
    Posted 09-08-2010 at 09:15 AM by brianL brianL is offline
  3. Old Comment
    Ooops! A bit of PEBCAK there! Forgot to plug the usb stick with necessary files into the sh*plug.
    Posted 09-08-2010 at 09:29 AM by brianL brianL is offline
  4. Old Comment
    Aaaaaaaaaargh!!! ****! ****! ****! It's running the script OK without any syntax errors, but now it can't find this, can't find that, can't find the other. Can't find its arse with its hands tied behind its back (as we say in Oldham ). Where's that hammer?!?!
    Posted 09-08-2010 at 09:49 AM by brianL brianL is offline
  5. Old Comment
    Listen...can you hear a thumping sound? Yes? Well, that is brianL kicking himself. Why? Because he's only just noticed, and read about, resetting the plug by pushing a paperclip (or whatever fits) through a little hole on the plug. If brains were dynamite, he wouldn't have enough to blow his hat off (as we say in Oldham ).
    Posted 09-09-2010 at 06:57 AM by brianL brianL is offline
  6. Old Comment
    Actually, that little hole thingy is for restarting/rebooting, not for resetting. I really should RTFM.
    Posted 11-17-2010 at 07:06 AM by brianL brianL is offline


All times are GMT -5. The time now is 09:14 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration