LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 02-24-2011, 12:53 AM   #1
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 101

Rep: Reputation: 4
Making a FreeBSD based distro


Hello all,

I am interested in making my own flavor of FreeBSD. I have been pointed to http://www.freebsd.org/doc/en_US.ISO...ase-build.html as my guide. Anyone know if this is an easy process or not???
 
Old 02-24-2011, 08:55 AM   #2
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 406

Rep: Reputation: 89
Relatively easy process:

http://romana.now.ie/writing/customfreebsdiso.html
http://www.cyclecide.com/~rudy/examp...m-freebsd.html
 
1 members found this post helpful.
Old 02-25-2011, 01:38 AM   #3
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 4
Both http://www.freebsd.org/doc/en_US.ISO...ase-build.html and http://romana.now.ie/writing/customfreebsdiso.html say to use the command: make release. I have tried the command make release and I get: "make: don't know how to make release. stop." I ran the command as regular user and as root both did not produce any results. The folder that I executed the command was src/release. I presume that is where I am supposed to execute the command. I tried make world and make buildworld but I get the same error of:"make: don't know how to make *. stop."
 
Old 02-25-2011, 04:21 AM   #4
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 406

Rep: Reputation: 89
@lonesoac0

Works here:

Code:
% cd /usr/src/release
% make release
To make a release you must set CHROOTDIR and BUILDNAME
*** Error code 1

Stop in /usr/src/release.
Are You sure have the sources on Your disk?

Code:
% du -sh /usr/src 
467M	/usr/src
 
Old 02-25-2011, 08:07 AM   #5
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 4
yeah, I was definitely missing the release dir. Pretty sure that was my issue. I am currently re-installing FreeBSD WITH the required software. I know I am using a nuke to kill a mosquito but it is the only way I know to have everything I need. I do not think that I will have any more issues after the new install, but I shall see! Thank you for the help Vermaden.
 
Old 02-25-2011, 09:04 AM   #6
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 406

Rep: Reputation: 89
Welcome mate
 
Old 03-09-2011, 02:44 PM   #7
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 4
Perl Error

when I ran make release I got an error about Perl. The following is the error verbatim:
--------------------------------
cd: can't cd to /home/lonesoac0/chroot/usr/ports/lang/perl5.10
***Error Code 2

Stop in /usr/src/release.
*** Error Code 1

Stop in /usr/src/release
--------------------------------
I looked in the /usr/src/release/makefile and found the following:
#Doing 'make index' in /usr/ports requires Perl.
MAKEINDEXPORTS= lang/perl5.10
---------------------------------

Is the make release command trying to make a perl based index of installed ports?
Is this index required?

I commented the MAKEINDEXPORTS out, re-ran make release and I was eventually presented with so many errors that they went off the screen. I cannot remember if they were perl related or not.
 
Old 03-10-2011, 12:01 AM   #8
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 406

Rep: Reputation: 89
Quote:
Originally Posted by lonesoac0 View Post
cd: can't cd to /home/lonesoac0/chroot/usr/ports/lang/perl5.10
Why like that, it should be at most /usr/ports/lang/perl5.10 not /home/lonesoac0/chroot/usr/ports/lang/perl5.10 ... You use chroot there?

make index (in /usr/ports) creates the /usr/ports/INDEX-8 file (or /usr/ports/INDEX-7 on FreeBSD 7.x etc) to allow You to search Ports by make command:
Code:
# cd /usr/ports
# make search name=xterm
Just add perl by package:
Code:
# pkg_add -r perl
 
Old 03-10-2011, 02:06 AM   #9
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 4
I looked at the Perl error a second time and I thought of the solution you said...install Perl. Glad we are on the same wave length on that issue. I ran pkg_add -rF perl with the -F option because my machine was saying: "pkg_add: package 'perl-5.10.1_1' or its older version already installed." I think that the correct Perl version was installed when I first ran make release. Only way to find out is to re-run the command to be sure.

Also I chose my CHROOT environment to be in my home dir because that is where I remember Ubuntu guides placing it. And I am going to say this because I think you are thinking this....I have not been using a Ubuntu HOWTO for FreeBSD. LOL!
 
Old 03-12-2011, 12:56 AM   #10
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 4
Fisrt I did the:
# cd /usr/ports
# make search name=xterm

Second I uncommented the MAKEINDEXPORTS line in the /usr/src/release/Makefile.

I then re-ran make release.

I still received the:
cd: can't cd to /home/lonesoac0/chroot/usr/ports/lang/perl5.10
***Error Code 2

Stop in /usr/src/release.
*** Error Code 1

Stop in /usr/src/release
--------------------------------
Any sujestions??
 
Old 03-12-2011, 07:00 PM   #11
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 406

Rep: Reputation: 89
Maybe this will help You mate:
http://freebsd.org/doc/en_US.ISO8859...g/article.html
 
Old 03-16-2011, 05:47 PM   #12
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 4
Well...it looks like I completed the make release command. I looked at the more detailed information posted by vermaden and I decided that I was reading too much into it. The make release command had been described to me as a relatively easy thing to do. As a result I decided to completely start from scratch in my build process. I found http://wiki.idefix.fechner.net/index...D-Build_Own_CD and decided to follow it. There were only two changes to the commands posted that I had to make. I just tested the installation ISO in VB 4.0 and it installed just fine.

Funny thing is, is that I expected only one ISO file to be made. make release made a LIVE ISO, and three other installation disks. I guess that is BSD magic for you....
 
Old 03-17-2011, 01:23 AM   #13
vermaden
Member
 
Registered: Jan 2006
Location: pl_PL.lodz
Distribution: FreeBSD
Posts: 406

Rep: Reputation: 89
Quote:
Originally Posted by lonesoac0 View Post
Funny thing is, is that I expected only one ISO file to be made. make release made a LIVE ISO, and three other installation disks. I guess that is BSD magic for you....
The 'RELEASE' consists of these types of images:
Code:
FreeBSD-{MAJOR}.{MINOR}-RELEASE-{ARCH}-bootonly.iso  To test how it boots
FreeBSD-{MAJOR}.{MINOR}-RELEASE-{ARCH}-disc1.iso     The CD version with small amount of packages
FreeBSD-{MAJOR}.{MINOR}-RELEASE-{ARCH}-dvd1.iso.xz   Compressed DVD (with xz) which contains also livefs (FIXIT mode) and more packages
FreeBSD-{MAJOR}.{MINOR}-RELEASE-{ARCH}-livefs.iso    The livefs (FIXIT mode) and nothing else
FreeBSD-{MAJOR}.{MINOR}-RELEASE-{ARCH}-memstick.img  The Pendrive/USB image with livefs (FIXIT mode) and pacakges is made with other script
My opinion, only use *-dvd1.iso or *-memstick.img images, as they contain livefs, which allows You to manually install FreeBSD:
http://forums.freebsd.org/showthread.php?t=12082
 
Old 03-18-2011, 02:39 AM   #14
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 4
Yeah, I like the LIVE feature built into Linux/BSD too.
 
  


Reply

Tags
bsd, distribution



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Making a debian based distro rmckayfleming Linux - General 24 12-30-2013 04:44 AM
Sorce based distro (gentoo) Vs Binary based distro(fedora, debian,..) ashwin_cse Linux - Distributions 7 02-08-2010 01:46 PM
How to convert a rpm based distro into deb (apt-get) distro ? pleasehelpme Linux - Newbie 3 02-11-2008 12:20 AM
Making a new distro based off Ubuntu BlahBlah_X Ubuntu 4 01-02-2007 01:47 PM
need help making USB based distro tuneout Linux - General 2 08-25-2005 11:24 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 01:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration