LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 05-01-2005, 02:57 PM   #1
VA3OG
Member
 
Registered: Apr 2005
Location: Ontario, Canada
Distribution: Ubuntu 10.10
Posts: 31

Rep: Reputation: 15
No Sound - Haory 5.04, Compaq Armada 7800 Laptop


I'm a newbie to LINUX & UBUNTU. Been reading the threads regarding sound problems hoping to find a soultion to my situation, but have finally given up & will post a request for help.

In a nutshell, UBUNTU doesn't recognise that there is a soundcard, whereas in WIndows sound works fine.

Here are some details from my system. In advance, I'll say thanks to anyone who can help me out. Other than the sound issue, I have been really enjoying my linux experience.

Bryan

Details: (sri abt length of post!)

Computer is a Compaq Armada 7800. 300MHz, 96M ram. 5 G hard drive split 2G for Win, 3 G for linux.
Dual boot with Win-98 & Ubuntu Hoary 5.04.

bryan@bandit:~$ uname -r
2.6.10-5-386


Windows recognises the sound card. Works just fine in Windows, shows up as:
Soundcard: ES1879 ESS technology.
IO range 0250=0257.
Driver ES1879 controller interface.
Microsoft

Logged in as root, I tried the following modprobe:
root@bandit:/ # modprobe snd-es18xx
FATAL: Error inserting snd_es18xx (/lib/modules/2.6.10-5-386/kernel/sound/isa/snd-es18xx.ko): No such device
FATAL: Error running install command for snd_es18xx

My Card doesn't show up in lspci:
bryan@bandit:~$ lspci
0000:00:00.0 Host bridge: Compaq Computer Corporation Northstar (rev 01)
0000:00:00.1 PCI bridge: Compaq Computer Corporation Northstar (rev 01)
0000:00:0c.0 CardBus bridge: Texas Instruments PCI1250 (rev 02)
0000:00:0c.1 CardBus bridge: Texas Instruments PCI1250 (rev 02)
0000:00:0e.0 ISA bridge: Compaq Computer Corporation CETUS-L (rev 03)
0000:00:0e.1 IDE interface: Compaq Computer Corporation Triflex Dual EIDE Controller (rev 01)
0000:00:0e.2 USB Controller: Compaq Computer Corporation ZFMicro Chipset USB (rev 11)
0000:01:00.0 VGA compatible controller: S3 Inc. ViRGE/MX (rev 06)
0000:02:00.0 Network controller: Linksys ADMtek ADM8211 802.11b Wireless Interface (rev 20)

Here are the loaded modules:
bryan@bandit:~$ lsmod
Module Size Used by
isofs 33720 0
udf 77060 0
proc_intf 4100 0
freq_table 4100 0
cpufreq_userspace 4572 0
cpufreq_ondemand 6172 0
cpufreq_powersave 1920 0
pcmcia 21380 4
video 16260 0
sony_acpi 6280 0
pcc_acpi 11264 0
button 6800 0
battery 10244 0
container 4608 0
ac 4996 0
ipv6 229504 9
af_packet 20744 2
ohci_hcd 19848 0
usbcore 107384 2 ohci_hcd
arc4 2048 1
adm8211 52224 0
yenta_socket 19584 1
pcmcia_core 53568 2 pcmcia,yenta_socket
pci_hotplug 30512 0
analog 10784 0
ns558 5632 0
gameport 4608 2 analog,ns558
rtc 12216 0
pcspkr 3816 0
floppy 54864 0
irtty_sir 7936 0
sir_dev 18092 1 irtty_sir
irda 168000 2 irtty_sir,sir_dev
crc_ccitt 2176 1 irda
nls_iso8859_1 4224 1
nls_cp437 5888 1
vfat 12928 1
fat 37792 1 vfat
md 43856 0
dm_mod 53116 1
capability 5000 0
commoncap 7808 1 capability
tsdev 7488 0
evdev 9088 0
psmouse 19336 0
mousedev 11160 1
parport_pc 34372 1
lp 10792 0
parport 33480 2 parport_pc,lp
ide_cd 38532 0
cdrom 36508 1 ide_cd
ext3 120968 1
jbd 54168 1 ext3
ide_generic 1664 0
triflex 4224 1
ide_disk 18176 4
ide_core 118988 4 ide_cd,ide_generic,triflex,ide_disk
unix 26164 879
thermal 13576 0
processor 22708 1 thermal
fan 4612 0
fbcon 34048 0
font 8448 1 fbcon
bitblit 5120 1 fbcon
vesafb 6948 0
cfbcopyarea 3968 1 vesafb
cfbimgblt 3072 1 vesafb
cfbfillrect 3584 1 vesafb
 
Old 05-01-2005, 03:41 PM   #2
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
A bit of digging reveals this to be an ISA card (which explains why lspci doesn't show it) and a look at my kernel source suggests that you need to load the snd-es18xx module (modprobe snd-es18xx). If that works then add it to the list of boot time modules (/etc/modprobe.preload I think) and it should then load every boot.

HTH
 
Old 05-01-2005, 04:01 PM   #3
VA3OG
Member
 
Registered: Apr 2005
Location: Ontario, Canada
Distribution: Ubuntu 10.10
Posts: 31

Original Poster
Rep: Reputation: 15
Well, the system isn't too happy with the modprobe - see below.
root@bandit:/ # modprobe snd-es18xx
FATAL: Error inserting snd_es18xx (/lib/modules/2.6.10-5-386/kernel/sound/isa/snd-es18xx.ko): No such device
FATAL: Error running install command for snd_es18xx

Bryan
 
Old 05-01-2005, 04:12 PM   #4
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
Sorry, should have read closer. Does dmesg give any hints about what went wrong? What does modinfo snd-ex18xx report? Look at setting a port= or irq= type option. dmesg will hopefully tell precisely which test failed and consequently what info needs to be supplied.
 
Old 05-01-2005, 09:06 PM   #5
VA3OG
Member
 
Registered: Apr 2005
Location: Ontario, Canada
Distribution: Ubuntu 10.10
Posts: 31

Original Poster
Rep: Reputation: 15
Thanks for your help! Haven't nailed it down yet. I'm not sure what I should look for in the dmesg output. It's a bit lengthy to post the whole thing here. It does refer to some pnp addresses:

pnp: 00:05: ioport range 0x250-0x257 has been reserved <-- this is the address range Windows used for the sound card.
pnp: 00:05: ioport range 0x270-0x271 has been reserved
pnp: 00:05: ioport range 0x40b-0x40b has been reserved
pnp: 00:05: ioport range 0x4d6-0x4d6 has been reserved
pnp: 00:05: ioport range 0xc48-0xc4a has been reserved
pnp: 00:05: ioport range 0xc6c-0xc6d has been reserved
pnp: 00:0f: ioport range 0x4d0-0x4d1 has been reserved
pnp: 00:0f: ioport range 0x800-0x87f has been reserved
pnp: 00:0f: ioport range 0xc10-0xc1f has been reserved
pnp: 00:0f: ioport range 0xc80-0xc9f could not be reserved


And here is the output of modinfo:
root@bandit:/ # modinfo snd-es18xx
filename: /lib/modules/2.6.10-5-386/kernel/sound/isa/snd-es18xx.ko
author: Christian Fischbach <fishbach@pool.informatik.rwth-aachen.de>, A bramo Bagnara <abramo@alsa-project.org>
description: ESS ES18xx AudioDrive
license: GPL
parm: index:Index value for ES18xx soundcard.
parm: id:ID string for ES18xx soundcard.
parm: enable:Enable ES18xx soundcard.
parm: isapnp:PnP detection for specified soundcard.
parm: port:Port # for ES18xx driver.
parm: mpu_port:MPU-401 port # for ES18xx driver.
parm: fm_port:FM port # for ES18xx driver.
parm: irq:IRQ # for ES18xx driver.
parm: dma1MA 1 # for ES18xx driver.
parm: dma2MA 2 # for ES18xx driver.
vermagic: 2.6.10-5-386 preempt 386 gcc-3.3
depends: snd-pcm,snd,snd-opl3-lib,snd-mpu401-uart
alias: pnp:cESS1868dESS1868dESS0000*
alias: pnp:cESS1868dESS8601dESS8600*
alias: pnp:cESS1868dESS8611dESS8610*
alias: pnp:cESS0003dESS1869dESS0006*
alias: pnp:cESS1869dESS1869dESS0006*
alias: pnp:cESS1878dESS1878dESS0004*
alias: pnp:cESS1879dESS1879dESS0009*
srcversion: 2A7952BB92B73FC3A09BEC9
 
Old 05-02-2005, 11:12 AM   #6
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
Nothing glaringly obvious there I'm afraid. Have a look in /proc/ioports and see what's using the 0xc80-0xc9f range. As something else to try, try loading it "modprobe snd-es18xx port=0x250" although I don't think this'll work as it (based on the dmesg output) is already using that address. If you find what's blocking it though and modprobe -r it then it might work.
 
Old 02-28-2007, 08:46 AM   #7
BlazeTechnologyWorx
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 6.06
Posts: 9

Rep: Reputation: 0
Help!!!!!!

I've got a simular if not identical problem with my Armada it came w/Windows 2k- Audio worked just fine, video-Idunno. Any way, I hate Windows and decided to join the Linux revolution only to discover that i am a bit further out of the technology loop than i should ever be, and apparently been stupefied by windows for the past decade or so, and dont know what i'm doing. so i need a bit of a crash course on Linux.

I will say this, the Ubuntu install went a lot cleaner than Blag.

My sound drivers wont work, or it doesn't recognize the sound card.

1 of the error messages state:
No volume control GStreamer plugins and/or no devices found

Modprobe was mentioned earlier, how/where are those entered?

I appreciate all of the help as well.
 
Old 03-01-2007, 08:06 AM   #8
VA3OG
Member
 
Registered: Apr 2005
Location: Ontario, Canada
Distribution: Ubuntu 10.10
Posts: 31

Original Poster
Rep: Reputation: 15
I received this helpful message from someone when I first posted the help request. (I, unfortunately didn't keep his/her name.) It worked like a charm!

---
I'm running Hoary on a Compaq Deskpro Dpend. I also had trouble getting sound to work until I found this solution:

* Save the following lines in the file /etc/modprobe.d/soundcard

Code:

alias sound-slot-0 snd-card-0
alias snd-card-0 snd-es18xx
options snd-es18xx enable=1 isapnp=0 port=0x220 mpu_port=0x388 fm_port=0x330 irq=5 dma1=1 dma2=0


* sudo modprobe snd-es18xx
* sudo /etc/init.d/alsa restart

Voila! I'm not sure if this will work on Warty or not but I thought I should post it just in case somebody else has the same problem.
----
 
Old 03-01-2007, 02:19 PM   #9
BlazeTechnologyWorx
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 6.06
Posts: 9

Rep: Reputation: 0
forgive me i'm slow.
VA30G Thankyou.- but here is what happens

blaze@Blaze-Laptop:~$ /etc/modprobe.d/soundcard
bash: /etc/modprobe.d/soundcard: No such file or directory

blaze@Blaze-Laptop:~$ /etc/
bash: /etc/: is a directory

blaze@Blaze-Laptop:~$ /etc/modprobe.d/
bash: /etc/modprobe.d/: is a directory

Apparently i don't have a the soundcard file (or txt, scripy-what is it) how do i insert it? root owns it how do i get in as root?
 
Old 03-01-2007, 02:41 PM   #10
BlazeTechnologyWorx
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 6.06
Posts: 9

Rep: Reputation: 0
x that slow part, well sort of. i logged in as root all is good so far thankyou for your help
 
Old 03-02-2007, 11:06 AM   #11
BlazeTechnologyWorx
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 6.06
Posts: 9

Rep: Reputation: 0
there is nothing quite like victory and defeat all within 30 seconds....
mod probe worked...sort of, i got sound and sound drivers tested but it wont last,
ran mod probe, it says the same issue at start up also,
root@Blaze-Laptop:~# sudo modprobe snd-es18xx
WARNING: /etc/modprobe.d/soundcard line 1: ignoring bad line starting with 'Code:'
WARNING: /etc/modprobe.d/soundcard line 1: ignoring bad line starting with 'Code:'
WARNING: /etc/modprobe.d/soundcard line 1: ignoring bad line starting with 'Code:'
It recognizes the sound card at 1879, it shows up in device manager, but as soon as I restart it is gone, and I have to do it all over again with the same results.


There is a problem here problealso with sudo /etc/init.d/alsa restart
root@Blaze-Laptop:~# sudo /etc/init.d/alsa restart
sudo: /etc/init.d/alsa: command not found

and the volume control keeps the "no sound symbol" and when you try to adjust the volume it usually says:
The volume control did not find any elements and/or devices to control.
This means either that you don't have the right GStreamer plugins installed,
or that you don't have a sound card configured.
I presume that this will be resolved once the sound card is satisfactorily configured, it will eventually allow me to adjust the sound but the character wont change
 
Old 03-08-2007, 11:55 AM   #12
BlazeTechnologyWorx
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 6.06
Posts: 9

Rep: Reputation: 0
deleted line says Code: since it obviously wasn't to be included.
mod probe works, when ever i run it how do i configure the system to run it automatically?
 
Old 03-08-2007, 11:55 AM   #13
BlazeTechnologyWorx
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 6.06
Posts: 9

Rep: Reputation: 0
"alsa restart" is no good
 
Old 03-13-2007, 10:32 AM   #14
VA3OG
Member
 
Registered: Apr 2005
Location: Ontario, Canada
Distribution: Ubuntu 10.10
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by BlazeTechnologyWorx
"alsa restart" is no good
Well, I must admit I am out of my depth. Maybe someone else can shed light on your situation.
Good Luck!
 
Old 03-14-2007, 01:22 PM   #15
BlazeTechnologyWorx
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu 6.06
Posts: 9

Rep: Reputation: 0
How Do You Get The Mod Probe To Run Itself Every Time The System Boots??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compaq Armada 7800 modem trouble diazjavier Linux - Laptop and Netbook 2 04-06-2005 09:03 PM
SuSE 9.2 +ACs- Compaq Armada laptop rnturn Suse/Novell 2 03-03-2005 09:36 PM
mdk 10 & laptop sound question (compaq armada 7400) rbonafied Mandriva 0 05-27-2004 05:26 PM
armada 7800 and a modem netboy_541 Linux - Laptop and Netbook 5 05-03-2004 06:33 PM
Sound Drivers for Compaq Armada 7800 mjayeh Linux - Newbie 6 02-05-2004 05:43 PM


All times are GMT -5. The time now is 10:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration