LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 03-15-2007, 09:42 PM   #1
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Rep: Reputation: 31
Cool Help me mount a drive?


Hello, i recently installed Ubuntu Edgy Eft, for a fresh start, with my dual boot system (Win XP), but one of my partitions is not visible in Ubuntu that is in windows, it is a Fat32 partition, the idea being to be able to transfer files from Linux to Windows, does anyone know how to make that partition visible in Linux?, (to mount it), my other partitions are all visible, but they are NTSF, so they are almost useless for transfering data, any help would be great... MJ
 
Old 03-15-2007, 10:40 PM   #2
spurious
Member
 
Registered: Apr 2003
Location: Vancouver, BC
Distribution: Slackware, Ubuntu
Posts: 558

Rep: Reputation: 31
To make a partition "visible", you need to mount it. In the Applications menu, go to Accessories and open a Terminal.

Then, make yourself root by typing this command:

sudo su

Enter your password, and now you are root. You need to mount your FAT partition to a directory, so create a new one, like /media/fat32:

mkdir -m 777 /media/fat32

The '-m 777' option gives permission to any user to read, write and run programs from the /media/fat32 directory.

Now you need to edit your fstab file, in your /etc directory; this tells your computer which partitions you want mounted when you boot. Use the mcedit text editor, like this:

mcedit /etc/fstab

In your fstab file, add the following line

/dev/hdaX /media/fat32 vfat defaults,umask=000 0 0

Where hdaX is your FAT partition. On my machine, my FAT partition is /dev/hda7. The umask=000 option allows any user to read, write and run files from the partition.

To save the file from mcedit, press F2. To quit, press F10.

In Ubuntu, you can also mount your NTFS partitions to be read/writable. In your /etc/fstab file, look for your NTFS line and change 'ntfs' to 'ntfs-3g'. Your computer will then use the ntfs-3g module to mount the NTFS. I've used this for writing, and although it is slow, it is reliable.

e.g. in my fstab, this looks like:

/dev/hda2 /media/ntfs ntfs-3g defaults,umask=000 0 0


Once you've made your fstab entries, you can mount these partitions without having to reboot. As root, do:

mount /media/fat32

To unmount the partition, do as root:

umount /media/fat32

Last edited by spurious; 03-15-2007 at 10:43 PM.
 
Old 03-15-2007, 11:27 PM   #3
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Original Poster
Rep: Reputation: 31
Hello, I have been facing this problem a lot today, I cannot change any system files per say, because as it says i am not "owner", this is the only account on the system, I am the OWNER legally, so anyway, i need to know what to do so that I am recognized as owner on my system any help? Thanks, MJ
 
Old 03-17-2007, 08:23 PM   #4
ckota
Member
 
Registered: Jan 2005
Distribution: Kubuntu Feisty
Posts: 35

Rep: Reputation: Disabled
You have to be root, you can use sudo command like
Quote:
sudo mount -a
and enter your password to mount all partitions listed in /etc/fstab. This is a well done How-to
http://www.debianadmin.com/mount-you...in-ubuntu.html
 
Old 03-17-2007, 08:59 PM   #5
mitchell7man
Member
 
Registered: Jan 2007
Location: Provo, UT
Distribution: OSX - Fedora
Posts: 458

Original Poster
Rep: Reputation: 31
Hello, i got the root permissions, so it all worked out!, MJ
 
  


Reply

Tags
drive, dual boot, mount, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
Mount usb drive, umount and mount another drive arubin Linux - Hardware 9 01-17-2007 03:46 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 07:16 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 1 12-24-2005 04:25 AM
when i mount my USB Flash Drive A Messenge has come that mount: can't find /dev/sda/h feda82 Red Hat 2 12-24-2005 02:15 AM


All times are GMT -5. The time now is 04:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration