LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Help me mount a drive? (http://www.linuxquestions.org/questions/ubuntu-63/help-me-mount-a-drive-537891/)

mitchell7man 03-15-2007 09:42 PM

Help me mount a drive?
 
Hello, i recently installed Ubuntu Edgy Eft, for a fresh start, with my dual boot system (Win XP), but one of my partitions is not visible in Ubuntu that is in windows, it is a Fat32 partition, the idea being to be able to transfer files from Linux to Windows, does anyone know how to make that partition visible in Linux?, (to mount it), my other partitions are all visible, but they are NTSF, so they are almost useless for transfering data, any help would be great... MJ

spurious 03-15-2007 10:40 PM

To make a partition "visible", you need to mount it. In the Applications menu, go to Accessories and open a Terminal.

Then, make yourself root by typing this command:

sudo su

Enter your password, and now you are root. You need to mount your FAT partition to a directory, so create a new one, like /media/fat32:

mkdir -m 777 /media/fat32

The '-m 777' option gives permission to any user to read, write and run programs from the /media/fat32 directory.

Now you need to edit your fstab file, in your /etc directory; this tells your computer which partitions you want mounted when you boot. Use the mcedit text editor, like this:

mcedit /etc/fstab

In your fstab file, add the following line

/dev/hdaX /media/fat32 vfat defaults,umask=000 0 0

Where hdaX is your FAT partition. On my machine, my FAT partition is /dev/hda7. The umask=000 option allows any user to read, write and run files from the partition.

To save the file from mcedit, press F2. To quit, press F10.

In Ubuntu, you can also mount your NTFS partitions to be read/writable. In your /etc/fstab file, look for your NTFS line and change 'ntfs' to 'ntfs-3g'. Your computer will then use the ntfs-3g module to mount the NTFS. I've used this for writing, and although it is slow, it is reliable.

e.g. in my fstab, this looks like:

/dev/hda2 /media/ntfs ntfs-3g defaults,umask=000 0 0


Once you've made your fstab entries, you can mount these partitions without having to reboot. As root, do:

mount /media/fat32

To unmount the partition, do as root:

umount /media/fat32

mitchell7man 03-15-2007 11:27 PM

Hello, I have been facing this problem a lot today, I cannot change any system files per say, because as it says i am not "owner", this is the only account on the system, I am the OWNER legally, so anyway, i need to know what to do so that I am recognized as owner on my system any help? Thanks, MJ

ckota 03-17-2007 08:23 PM

You have to be root, you can use sudo command like
Quote:

sudo mount -a
and enter your password to mount all partitions listed in /etc/fstab. This is a well done How-to
http://www.debianadmin.com/mount-you...in-ubuntu.html

mitchell7man 03-17-2007 08:59 PM

Hello, i got the root permissions, so it all worked out!, MJ


All times are GMT -5. The time now is 01:21 PM.