LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 06-17-2007, 07:38 PM   #1
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Rep: Reputation: 31
Connected but no internet


I recently installed Ubuntu 7.04 on my Acer Aspire 3003WLMi. After booting, the network tool next to the clock says: "Connection Established - You are now connected to the wired network." However, Firefox, for example, gives me 404 errors.

This is the output of ifconfig:

Code:
eth0      Link encap:Ethernet  HWaddr 00:C0:9F:D2:E0:53  
          inet6 addr: fe80::2c0:9fff:fed2:e053/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:63 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:3 Base address:0x1800 

eth0:avah Link encap:Ethernet  HWaddr 00:C0:9F:D2:E0:53  
          inet addr:169.254.9.148  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:3 Base address:0x1800 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1048 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1048 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:81676 (79.7 KiB)  TX bytes:81676 (79.7 KiB)
 
Old 06-17-2007, 07:42 PM   #2
fukawi2
Member
 
Registered: Oct 2006
Location: Melbourne, Australia
Distribution: ArchLinux, ArchServer, Fedora, CentOS
Posts: 448

Rep: Reputation: 34
Can you 'ping google.com'?

Also, could you post the output of 'route -n'?
 
Old 06-17-2007, 07:55 PM   #3
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
Code:
ping: unknown host google.com
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
0.0.0.0         0.0.0.0         0.0.0.0         U     1000   0        0 eth0
 
Old 06-17-2007, 08:06 PM   #4
fukawi2
Member
 
Registered: Oct 2006
Location: Melbourne, Australia
Distribution: ArchLinux, ArchServer, Fedora, CentOS
Posts: 448

Rep: Reputation: 34
I know Windoze uses the 169.254. range for when it can't get a DHCP lease and there's no static IP set... I'm going to assume Ubuntu does the same (haven't got one handy that I can test it on)

In which case, what it your network configuration? Do you have a router/modem that should be handing our DHCP addresses to your network?
 
Old 06-17-2007, 08:09 PM   #5
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by fukawi2
I know Windoze uses the 169.254. range for when it can't get a DHCP lease and there's no static IP set... I'm going to assume Ubuntu does the same (haven't got one handy that I can test it on)

In which case, what it your network configuration? Do you have a router/modem that should be handing our DHCP addresses to your network?
Yes, a router, and using the same cable, my desktop machine on which I'm writing this has no problems connecting.
 
Old 06-17-2007, 08:12 PM   #6
fukawi2
Member
 
Registered: Oct 2006
Location: Melbourne, Australia
Distribution: ArchLinux, ArchServer, Fedora, CentOS
Posts: 448

Rep: Reputation: 34
Interesting... What IP address / subnet / gateway does your desktop have set when it's plugged in and working?

Can you try manually setting the same settings to your laptop and see if that works? If it does, then there's just a problem with getting a DHCP lease for some reason, if it still doesn't work, then it's something more annoying :P

Just to be clear - does your desktop have a Static IP address or does it DHCP from the router?
 
Old 06-17-2007, 08:19 PM   #7
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
This is from my desktop:
Code:
eth0      Link encap:Ethernet  HWaddr 00:0C:6E:46:9F:F5
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:6eff:fe46:9ff5/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2485 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2455 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2194167 (2.0 MiB)  TX bytes:625899 (611.2 KiB)
          Interrupt:16

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:800 (800.0 b)  TX bytes:800 (800.0 b)
The desktop does not have a static IP.
 
Old 06-17-2007, 08:31 PM   #8
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
I tried using the same settings on my laptop, by selecting Static IP, but the problem remains.
 
Old 06-17-2007, 08:40 PM   #9
fukawi2
Member
 
Registered: Oct 2006
Location: Melbourne, Australia
Distribution: ArchLinux, ArchServer, Fedora, CentOS
Posts: 448

Rep: Reputation: 34
Can you post the output from 'route' when the laptop has the static IP please?
 
Old 06-17-2007, 08:45 PM   #10
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Rep: Reputation: 16
Quote:
eth0 Link encap:Ethernet HWaddr 00:C0:9F2:E0:53
inet6 addr: fe80::2c0:9fff:fed2:e053/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:63 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:3 Base address:0x1800
Everything looks good except for no "inet addr"

Did you try;

sudo ifdown eth0
sudo ifup etho
sudo dhclient eth0
 
Old 06-17-2007, 08:48 PM   #11
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0
default         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
 
Old 06-17-2007, 08:55 PM   #12
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by stratcat
Everything looks good except for no "inet addr"

Did you try;

sudo ifdown eth0
sudo ifup etho
sudo dhclient eth0
Code:
$ sudo ifdown eth0

There is already a pid file /var/run/dhclient.eth0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:c0:9f:d2:e0:53
Sending on   LPF/eth0/00:c0:9f:d2:e0:53
Sending on   Socket/fallback

$ sudo ifup eth0

Message from syslogd@athos at Mon Jun 18 03:48:27 2007 ...
athos kernel: [14649.728000] Disabling IRQ #3
There is already a pid file /var/run/dhclient.eth0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:c0:9f:d2:e0:53
Sending on   LPF/eth0/00:c0:9f:d2:e0:53
Sending on   Socket/fallback

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
 
Old 06-17-2007, 09:03 PM   #13
fukawi2
Member
 
Registered: Oct 2006
Location: Melbourne, Australia
Distribution: ArchLinux, ArchServer, Fedora, CentOS
Posts: 448

Rep: Reputation: 34
Well your route table with the static IP address looks good - you still can't ping google.com with that setup?

Interesting that it's not getting the DHCP offer, while your desktop gets it fine on the same cable... I can't remember if Ubuntu comes with iptables enabled by default, but try this:
Code:
sudo /etc/init.d/iptables stop
sudo dhclient eth0
EDIT: spelling
 
Old 06-17-2007, 09:11 PM   #14
merchtemeagle
Member
 
Registered: Oct 2004
Location: Belgium
Distribution: Slackware 13.37
Posts: 512

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by fukawi2
Well your route table with the static IP address looks good - you still can't ping google.com with that setup?

Interesting that it's not getting the DHCP offer, while your desktop gets it fine on the same cable... I can't remember if Ubuntu comes with iptables enabled by default, but try this:
Code:
sudo /etc/init.d/iptables stop
sudo dhclient eth0
EDIT: spelling
Still can't ping google.com. There is no such file (/etc/init.d/iptables) on my system.
 
Old 06-17-2007, 09:40 PM   #15
stratcat
Member
 
Registered: Jun 2006
Location: L.I.N.Y
Distribution: Ubuntu 10.04
Posts: 78

Rep: Reputation: 16
Quote:
Originally Posted by stratcat
Everything looks good except for no "inet addr"

Did you try;

sudo ifdown eth0
sudo ifup etho
sudo dhclient eth0
I just realized the commands I gave were for DHCP enabled. If you are just trying to get online open your network settings and select "automatic configuration (DHCP)". Then try those commands again.
 
  


Reply

Tags
cable, ethernet, modem


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unplug Internet Cable and plugin aging, but could not connected to the internet DevlinX Linux - General 2 07-02-2006 10:36 AM
Oh my. No internet connected? ElvenAssassin Linux - Newbie 8 04-25-2005 01:17 PM
help getting connected to internet leroy27336 Linux - Networking 2 01-22-2004 03:59 AM
Cannot get connected to the internet ullfrigg Linux - Networking 5 11-22-2003 02:47 PM
internet is connected but cannot browse internet?!?!? myk3 Linux - Newbie 3 11-17-2003 05:57 AM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration