LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-30-2004, 12:06 PM   #1
sud_crow
Member
 
Registered: Aug 2003
Location: Argentina
Distribution: Arch 0.7
Posts: 41

Rep: Reputation: 15
apt-get GPG problems (unknown signatures)...


Im having several issues with the GPG Check in apt-get... it doesnt let me install anything, im using the standard apt-get repos.

Here is the error:

Code:
Checking GPG signatures...
Unknown signature /var/cache/apt/archives/synaptic_0.53-0.suse091.rb.1_i586.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#8c9b4b0d)
E: Error(s) while checking package signatures:
0 unsigned package(s)
1 package(s) with unknown signatures
0 package(s) with illegal/corrupted signatures
Any idea on how to avoid GPG check or make it work??

(i have the rpmkeys group in the sources.list)

Thanks in advance!
 
Old 10-30-2004, 01:40 PM   #2
sud_crow
Member
 
Registered: Aug 2003
Location: Argentina
Distribution: Arch 0.7
Posts: 41

Original Poster
Rep: Reputation: 15
Well, aftear searching a bit i found the way:

Code:
apt install --no-checksig <pkgname>
(Note its "apt" and not "apt-get"... )

Just in case someone needs it.
 
Old 10-30-2004, 04:51 PM   #3
dwight
LQ Newbie
 
Registered: Sep 2004
Location: Estonia
Distribution: Arch
Posts: 14

Rep: Reputation: 0
Yep. That's one way to do it. If you don't want to type --no-checksig in every time you could disable GPG alltogether.
You can to this by editing the file /etc/apt/apt.conf.d/gpg-checker.conf: you need to change GPG::Check true;
to GPG::Check false;. If you do this, you should be careful which apt repositories you use.
There's also another way. You could install the rpmkey packages from each of the repositories. You can do this with:
Code:
apt-get install rpmkey*
This would install the needed signature files and the GPG check shouldn't fail. At least as long the rpmkeys are up to date. I find
that this is always not the case, so I have GPG checking turned off.
 
Old 10-30-2004, 05:57 PM   #4
Adler
Member
 
Registered: Oct 2004
Location: Wildwood, NJ
Distribution: Backbox Linux
Posts: 175

Rep: Reputation: 17
sud_crow,

I use the command -

"apt-get install XXXX" - e.g. apt-get install GAIM

To do an upgrade

"apt-get dist-upgrade"

I should mention this is all done @ Root level.
 
Old 07-05-2005, 03:00 AM   #5
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,255

Rep: Reputation: 118Reputation: 118
So I'm trying to disable this stupid MD5-sum checking:
I created the file /etc/apt/apt.conf.d/gpg-checker.conf and wrote the line
GPG::Check false;
It didn't help, still "MD5Sum mismatch"
I also imported GPG-key, same problem. (Currently freshrpms.net, but happens every now and then on various repos.)
Quote:
apt install --no-checksig <pkgname>
(Note its "apt" and not "apt-get"... )
No apt in Fedora, apt-get --no-checksig doesn't work.

This is in various versions of Fedora, FC3, CentOS, LormaLinux
Could someone please tell me how to get rid of all MD5 & GPG checking - they never do any good, I don't want them!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
All updates reported as 0KB and do not have valid GPG signatures. What's wrong? MadJock Fedora 3 01-17-2006 09:43 PM
Apt GPG error! please help THEHERO Debian 6 10-19-2005 07:35 AM
apt-rpm, SuSE 9.1, and signatures MachineShedFred Linux - Distributions 4 07-28-2004 07:59 AM
Can't verify package gpg signatures on Mandrake 10 ayn Mandriva 0 06-09-2004 07:45 AM
apt-get and illegal corrupted signatures Riichard Linux - General 3 02-11-2004 03:26 PM


All times are GMT -5. The time now is 11:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration