LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-14-2013, 12:46 PM   #1
dooglo
LQ Newbie
 
Registered: Mar 2007
Location: Northern Utah, USA
Distribution: Novel SUSE 10.2
Posts: 6

Rep: Reputation: 0
12.2 Runlevel 3


Ok, I've done a clean install of OpenSuse 12.2 64 bit on a spare computer with an NVIDIA 9400GT 1 mb vid card. To install NVIDIA driver I need to be in Runlevel 3. I've figured that much out, but now it say "login:" What do I type there?



Sorry, just don't know and trying to figure out.



Thanks,



D.
 
Old 02-14-2013, 09:04 PM   #2
jefro
Guru
 
Registered: Mar 2008
Posts: 11,000

Rep: Reputation: 1356Reputation: 1356Reputation: 1356Reputation: 1356Reputation: 1356Reputation: 1356Reputation: 1356Reputation: 1356Reputation: 1356Reputation: 1356
Run level 3 is without the window manager. I only assume that you installed OpenSuse with gnome or kde or some such window manager. There are many ways to get from a window manager (level 5) to a lower level. Most times I open a terminal and issue this command. sudo telinit 3.

Some disto's may make you find full path to that command or it may be init but I believe Opensuse should work correctly with telinit 3 from a root user permission.


To be sure you should read some posts on that subject. See these. Not sure you need to be in level 3.

http://en.opensuse.org/SDB:NVIDIA

http://users.suse.com/~sndirsch/nvid...ler-HOWTO.html
 
1 members found this post helpful.
Old 02-14-2013, 10:44 PM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 12,602

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
it is advisable to use the zypper repo to install the proprietary nvidia driver
for one the intred ( boot image) MUST be rebuilt to remove the nouveau driver

yast " install and remove software" will AUTO run the needed scripts to remove the opensource driver
that is already installed by default and replace it with the nvidia driver


this method
http://en.opensuse.org/SDB:NVIDIA_drivers#YaST

but if you REALLY want to install the NVIDIA.310.run driver
and manually rebuild the boot image
manually edit the modeprob "blacklist" rule ( the nvidia driver will do that but it installs it to a file that suse dose NOT see )
so you have to manually edit a system file

and only then boot into run level3
12.2 is now different than 12.1
you will need to manyally add a 3 during the booting !!!! by editing the boot line part way into the boot process
add a 3 to the end of the boot line
then finish booting into the text only start up
-- terminal only --
navigate to the .run driver and install it

but first you need to install gcc ,autotools, and the kernel headers

3 or 5 mouse clicks is a LOT easier

use yast !
 
Old 02-27-2013, 11:40 AM   #4
SilentSam
Member
 
Registered: Aug 2007
Location: Ottawa
Distribution: Arch Linux/Kubuntu/OpenSUSE
Posts: 287

Rep: Reputation: 31
I may be wrong, but I think the 310 driver doesn't properly support the 9400 GT. The OP may be attempting to run a legacy driver for better HW support.

as to the OP's question: at the login: prompt, you want to type root and hit enter. You'll need your root password, it may be the same as your user password (it was set up during install)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MES5 in runlevel 3 stuck after starting mavisd. Can't change back to runlevel 5 JnPson Linux - Enterprise 3 01-16-2013 05:58 PM
booting into runlevel 5, but I have it set for runlevel 3. Help. punt Fedora 13 06-01-2011 04:18 PM
[SOLVED] Getting a text console runlevel in Kubuntu 10.04 (Changing runlevel won't work) gregorian Linux - Newbie 4 09-05-2010 10:50 AM
New Install of PCLinuxOS boots into runlevel 3. Should be runlevel 5 MonctonJohn Linux - General 4 02-01-2008 04:38 PM
Soun Mixer absent in Runlevel 3 but present in Runlevel 5 debloxie Suse/Novell 1 01-18-2006 09:15 AM


All times are GMT -5. The time now is 10:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration