LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-31-2011, 11:59 AM   #1
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Rep: Reputation: 30
booting into runlevel 5, but I have it set for runlevel 3. Help.


I'm using Fedora 15. For some reason, my computer is booting up graphically. I do not have video drivers for a graphical setup apparently now that Gnome is getting more advanced, so I really need to restore to a CLI. My machine is currently booted up but it's been hanging on the "F" for 1.5 hours. Obviously Gnome3 is not for me.

I see /etc/inittab is now deprecated thanks to systemd. The instructions say the following:

Code:
# systemd uses 'targets' instead of runlevels. By default, there are two main targets:
#
# multi-user.target: analogous to runlevel 3
# graphical.target: analogous to runlevel 5
#
# To set a default target, run:
#
# ln -s /lib/systemd/system/<target name>.target /etc/systemd/system/default.target
And that's exactly what I have set up!

Code:
[root@server system]# pwd
/etc/systemd/system
[root@server system]# ls -la
total 20
lrwxrwxrwx 1 root root   37 May 31 10:41 default.target -> /lib/systemd/system/multi-user.target
So what gives? Why is this machine starting up graphically?

I even removed the symlink and recreated it... but that obviously isn't the issue here.


Speaking of which, how do I force X/Gnome to start up with "basic" video rather than have a frozen F on my desktop anyhow?
 
Old 05-31-2011, 12:30 PM   #2
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 677

Rep: Reputation: 95
Try linking to /lib/systemd/system/runlevel3.target instead, see if that works...never tried it myself since I do like booting up to graphical, but the default seems to be runlevel5.target, not graphical.target (at least on my system and I haven't changed it).

Also check what /lib/systemd/system/default.target is linked to, that IS linked to graphical.target on my system.

Last edited by Timothy Miller; 05-31-2011 at 12:36 PM.
 
Old 05-31-2011, 12:37 PM   #3
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
Tried that. Maybe it's not even the runlevel. This is the first time I've booted up from a reinstall from the Install DVD, so maybe it's doing something else first. I wouldn't know because it hangs on F for hours after I boot up.
 
Old 05-31-2011, 12:40 PM   #4
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,210
Blog Entries: 23

Rep: Reputation: 279Reputation: 279Reputation: 279
Quote:
Speaking of which, how do I force X/Gnome to start up with "basic" video rather than have a frozen F on my desktop anyhow?
I'd set up an /etc/X11/xorg.conf to use VESA...helped me out all the time tru F10...until I moved to Arch.

If you cannot get "into" the machine, consider TTY linux. Get an ISO, burn it. Boot the affected machine with it and log in.
Find the hard drive and mount it

Quote:
fdisk -l
mount /what/fdisk/found /mnt/c:
That should mount the hard drive, make your way to the folder mentioned above and make an xorg.conf, of course, if there is one, make a backup, but you know this.

I'd make something like this

Quote:
Section Device
Identifier monitor
Driver vesa
EndSection
This is "ancient info" - X should be clever enough to figure things out, but is dire times...

I believe this should get the system up and running...be it in VESA.

Quote:
Obviously Gnome3 is not for me
I hear ya, I've been staring at a flat-line since this thing struck my system...I'm considering XFCE...by the way, there is an XFCE spin of Fedora...

Luck!

Thor
 
Old 05-31-2011, 12:41 PM   #5
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 677

Rep: Reputation: 95
Mine boots up quick. Restarts/halts take forever and a day though. I end up just holding the power button to shut down they take so long. Maybe I'll play with it a while. My Fedora box is just a laptop I keep lying around to play with and test out distros on, I don't keep anything on it anyway.
 
Old 05-31-2011, 12:48 PM   #6
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 677

Rep: Reputation: 95
Works here

ln -s /lib/systemd/system/runlevel3.target /etc/systemd/system/default.target
ln -s /lib/systemd/system/multi-user.target /lib/systemd/system/default.target

reboot and I get a console login exactly as it should work.

And WOW, what a faster reboot...so obviously the issue with rebooting is something in X on my system (I run KDE Fedora, not Gnome)

I did have to change BOTH however. Changing /etc/blahblahblah back to runlevel5.target and even with /lib/blah/default.target set to multi-user it booted graphical.

Last edited by Timothy Miller; 05-31-2011 at 12:51 PM.
 
Old 05-31-2011, 01:12 PM   #7
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 847

Rep: Reputation: Disabled
There are two things that could possibly help you. I have never worked with fedora - too bleeding edge for me.
1. If you have something like /etc/rc.d/rc.local or its equivalent you can simply type 'init 2'. The system would boot into gui but when rc.local gets executed you would be back on runlevel 2.
2. There should be some kernel parameter 'eg vesa=xxxx' that can help fix the gui. Boot the cd once agaon and try a couple of options.
Well just thought about the third you can lookup where gdm is (been with slackware for a very long time now) and mv it to gdm.0. This way even if you boot into runlevel 5 you wont have a gui.
My advise: download xfce4 and install it - will make your life a lot easier.
Hope this helps.
 
Old 05-31-2011, 01:16 PM   #8
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 677

Rep: Reputation: 95
Quote:
Originally Posted by SilverBack View Post
There are two things that could possibly help you. I have never worked with fedora - too bleeding edge for me.
1. If you have something like /etc/rc.d/rc.local or its equivalent you can simply type 'init 2'. The system would boot into gui but when rc.local gets executed you would be back on runlevel 2.
2. There should be some kernel parameter 'eg vesa=xxxx' that can help fix the gui. Boot the cd once agaon and try a couple of options.
Well just thought about the third you can lookup where gdm is (been with slackware for a very long time now) and mv it to gdm.0. This way even if you boot into runlevel 5 you wont have a gui.
My advise: download xfce4 and install it - will make your life a lot easier.
Hope this helps.
I don't believe the 'init' string will work anymore with Fedora having moved to systemd
 
Old 05-31-2011, 01:44 PM   #9
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
I've posted about 5 things on this forum since I upgraded from Fedora 14 to 15, so I figure a clean reinstall will fix these problems. I have NO idea what is wrong with my system, but I do know it's a mess. Will keep you posted if there's anything notable.
 
Old 05-31-2011, 02:25 PM   #10
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 677

Rep: Reputation: 95
Yeah, Fedora, because RH uses it to test the very latest technologies, does not generally have the smoothest upgrades between versions. Doubly so this version, since the entire system initialization has been replaced. Something that major I would definitely recommend backup data and reinstall rather than upgrade.
 
Old 05-31-2011, 02:55 PM   #11
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Timothy Miller View Post
Something that major I would definitely recommend backup data and reinstall rather than upgrade.
Backup is done; the restore will be so not exciting, especially with my partition setups. I hope Fedora 15 continues to serve my needs; I'm not using GUIs at all too much and use my box primarily as an FTP/WWW server anyhow, so I wonder now if I should try another yum-based distro that is more server-friendly.
 
Old 06-01-2011, 04:25 AM   #12
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 847

Rep: Reputation: Disabled
Cant pass init=/bin/bash! that sucks.
@OP - make a seperate partition for home in case you do not want to loose data. On my pc I have a seperate partition /data which contains a backup of all important data.
Hope this helps.
PS:- Is fedora getting more and more unstable with each release? And I think Ubuntu is happily following its footsteps? Is it my perception or are things really this way?
 
Old 06-01-2011, 07:46 AM   #13
punt
Member
 
Registered: Jun 2001
Distribution: Fedora 14
Posts: 336

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by SilverBack View Post
PS:- Is fedora getting more and more unstable with each release? And I think Ubuntu is happily following its footsteps? Is it my perception or are things really this way?
Yes, it is I've downgraded to Fedora 14.
 
Old 06-01-2011, 04:18 PM   #14
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 677

Rep: Reputation: 95
Quote:
Originally Posted by SilverBack View Post
Cant pass init=/bin/bash! that sucks.
@OP - make a seperate partition for home in case you do not want to loose data. On my pc I have a seperate partition /data which contains a backup of all important data.
Hope this helps.
PS:- Is fedora getting more and more unstable with each release? And I think Ubuntu is happily following its footsteps? Is it my perception or are things really this way?
It is, but that's the purpose of Fedora. It's there to test out stuff that they may wish to incorporate into RHEL, and have the community test it out. If it weren't for using megapackages I'd happily use it as an every day system, too. But as is, it will never get beyond my "testing" pc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's the difference between runlevel 2 and runlevel 5 in Debian? davidas Linux - Newbie 2 01-05-2012 01:10 PM
[SOLVED] Getting a text console runlevel in Kubuntu 10.04 (Changing runlevel won't work) gregorian Linux - Newbie 4 09-05-2010 10:50 AM
Can using vi in runlevel 3 then runlevel 5 cause syntax errors? kevmcool Linux - Newbie 3 01-15-2010 03:26 AM
New Install of PCLinuxOS boots into runlevel 3. Should be runlevel 5 MonctonJohn Linux - General 4 02-01-2008 04:38 PM
Soun Mixer absent in Runlevel 3 but present in Runlevel 5 debloxie Suse/Novell 1 01-18-2006 09:15 AM


All times are GMT -5. The time now is 03:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration