LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2008, 11:19 AM   #1
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Rep: Reputation: 16
Xfce terminal shows "bash-3.11" instead of the path


I can see a bash-3.11 instead of user@darkstar~$ that I see on pure console (Ctrl-Alt-F1). I also see bash-3.11 on xterm and I see a sh-3.11 rxvt.

I have the aliases from ~/.bashrc but not the ones from /etc/profile.d/coreutils-dircolors.sh. This means I can solve the problem by adjusting my .bashrc but this seems like a "hack". It's not a problem to do this for all the user accounts but I like solutions that work at once for everything.

Why doesn't Terminal has the same settings like standard console does? And how I can change its default behavior?
 
Old 01-13-2008, 11:58 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,749

Rep: Reputation: 461Reputation: 461Reputation: 461Reputation: 461Reputation: 461
Different strokes... Not all programs will use the same method or info for setting what you want. Short of a small patch for each program or choosing programs which display the way you want, I don't see a way around this.
 
Old 01-13-2008, 12:58 PM   #3
marciobarbalho
Member
 
Registered: Dec 2007
Location: Brazil
Distribution: slackware 13
Posts: 151

Rep: Reputation: 30
edit "terminal" command by right-clicking on that icon, by the way, try out some like this:

user@darkstar~$ terminal -ls &

try "pwd" command, it shows the path

user@darkstar~$ pwd

that's it! You have to replace it, "terminal -ls" instead of "terminal"

Last edited by marciobarbalho; 01-13-2008 at 01:15 PM.
 
Old 01-13-2008, 01:20 PM   #4
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 50
Or, Open a Terminal session. Go Edit > Preferences

You will see a sub heading "Command"

Check the box that says "Run Command as login shell"

Restart Terminal.


tobyl

Last edited by tobyl; 01-13-2008 at 01:23 PM.
 
1 members found this post helpful.
Old 01-13-2008, 01:24 PM   #5
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 505

Rep: Reputation: Disabled
There is an entry on this here: http://slackwiki.org/Login_Shell
 
Old 01-13-2008, 02:30 PM   #6
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by marciobarbalho
user@darkstar~$ terminal -ls &

that's it! You have to replace it, "terminal -ls" instead of "terminal"
xterm and rxvt both support the -ls switch which produces exactly what I wanted. The Xfce terminal doesn't. But I managed to get it with this:

Quote:
Originally Posted by tobyl
Or, Open a Terminal session. Go Edit > Preferences

You will see a sub heading "Command"

Check the box that says "Run Command as login shell"

Restart Terminal.
=====

Quote:
Originally Posted by rg3
There is an entry on this here: http://slackwiki.org/Login_Shell
This website will come very handy By the way, the author dislikes the .bashrc solution as much as I do :-P

Quote:
Originally Posted by marciobarbalho
try "pwd" command, it shows the path
This works but it's tiresome to type pwd all the time.

Thank you all for your quick replies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 6 03-21-2013 10:35 AM
Why "bash-2.05b$" in Terminal instead of "username@localhost username" jayelitumbiolo Linux - General 9 10-04-2009 03:16 AM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
"rm -rf /tmp", now Evolution shows "(no folder displayed" Ed-MtnBiker Linux - Software 7 04-10-2006 04:05 PM
newly opened terminal shows bash-2.05$ instead of path jang Linux - General 6 01-18-2004 05:21 PM


All times are GMT -5. The time now is 01:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration